summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authornoirscape2018-11-13 18:02:45 +0100
committernoirscape2018-11-13 18:02:45 +0100
commitb122166f86a6fb8281ed6015004e6606558aa620 (patch)
treeccd9b713c319af10249aa40d91ee50914837a9bb
downloadaur-b122166f86a6fb8281ed6015004e6606558aa620.tar.gz
Initial commit
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD25
2 files changed, 43 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..0ac5b8e0544a
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = fatattr-git
+ pkgdesc = Small linux application to see or modify MSDOS attributes in a FAT file system
+ pkgver = 1
+ pkgrel = 1
+ url = https://github.com/Terseus/fatattr
+ arch = x86_64
+ arch = i686
+ license = GPL
+ makedepends = git
+ makedepends = scons
+ makedepends = clang
+ provides = fatattr
+ conflicts = fatattr
+ source = git+https://github.com/Terseus/fatattr.git
+ md5sums = SKIP
+
+pkgname = fatattr-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..f966b8d07fbc
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,25 @@
+# Maintainer: noirscape <neko at catgirlsin dot space>
+pkgname=fatattr-git
+_pkgname=fatattr
+pkgver=1
+pkgrel=1
+pkgdesc="Small linux application to see or modify MSDOS attributes in a FAT file system"
+arch=('x86_64' 'i686')
+url="https://github.com/Terseus/fatattr"
+license=('GPL')
+depends=()
+makedepends=('git' 'scons' 'clang')
+provides=('fatattr')
+conflicts=('fatattr')
+options=()
+source=(git+https://github.com/Terseus/fatattr.git)
+md5sums=('SKIP')
+build() {
+ cd "$srcdir"/"$_pkgname"
+ scons
+}
+package() {
+ cd "$srcdir"/"$_pkgname"
+ mkdir -p "$pkgdir"/usr/bin
+ install -Dm755 "bin/$_pkgname" "$pkgdir"/usr/bin
+}