summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorStoyan Minaev2019-05-24 19:42:51 +0300
committerStoyan Minaev2019-05-24 19:42:51 +0300
commit3f779372ff937ea0ccee0d839c1e1951a5742c23 (patch)
tree752862e5e1ef1dc4bb936da319435442e904e89d
parentac960ebbf4d4852917cf2af1c8935064a51c1e1a (diff)
downloadaur-3f779372ff937ea0ccee0d839c1e1951a5742c23.tar.gz
Added shell laucnher
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD9
2 files changed, 11 insertions, 4 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 06a842e11d0e..dddb05ae4647 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,16 +1,18 @@
pkgbase = fate-the-game
pkgdesc = The Game is based to simulate a real life hack
pkgver = 0.2
- pkgrel = 1
+ pkgrel = 2
arch = x86_64
license = custom
depends = dosbox
source = https://master.dl.sourceforge.net/project/host-fate-dos-game/Fate.zip
source = https://master.dl.sourceforge.net/project/host-fate-dos-game/fate-the-game.desktop
source = https://master.dl.sourceforge.net/project/host-fate-dos-game/fate-the-game.png
+ source = https://master.dl.sourceforge.net/project/host-fate-dos-game/fate-the-game-launcher
md5sums = 3db0a0bbc8279477f672272d20270c89
- md5sums = 0a585e4d38a2b7a62a8895ae2bf4eef3
+ md5sums = 3fa39b232b412b8319c5e97284d6123a
md5sums = 3aad39f65bef9ff83a55c255615f5ea2
+ md5sums = fb449564d16a30fe1c05660a13ba8f69
pkgname = fate-the-game
diff --git a/PKGBUILD b/PKGBUILD
index 2ef21c1ac2c7..23a5b43026ce 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,19 +3,21 @@
pkgname=fate-the-game
pkgver=0.2
-pkgrel=1
+pkgrel=2
pkgdesc="The Game is based to simulate a real life hack"
license=('custom')
source=(
"https://master.dl.sourceforge.net/project/host-fate-dos-game/Fate.zip"
"https://master.dl.sourceforge.net/project/host-fate-dos-game/fate-the-game.desktop"
"https://master.dl.sourceforge.net/project/host-fate-dos-game/fate-the-game.png"
+ "https://master.dl.sourceforge.net/project/host-fate-dos-game/fate-the-game-launcher"
)
arch=('x86_64')
md5sums=(
'3db0a0bbc8279477f672272d20270c89'
- '0a585e4d38a2b7a62a8895ae2bf4eef3'
+ '3fa39b232b412b8319c5e97284d6123a'
'3aad39f65bef9ff83a55c255615f5ea2'
+ 'fb449564d16a30fe1c05660a13ba8f69'
)
depends=(
dosbox
@@ -32,10 +34,13 @@ package() {
mkdir -p $pkgdir/usr/share/doc/$pkgname/
mkdir -p $pkgdir/usr/share/applications/
mkdir -p $pkgdir/usr/share/icons/hicolor/64x64/
+ mkdir -p $pkgdir/usr/bin/
install -m 0644 Fate.exe $pkgdir/usr/share/$pkgname/
install -m 0644 Readme.txt $pkgdir/usr/share/doc/$pkgname/
install -m 0644 $pkgname.desktop $pkgdir/usr/share/applications/
install -m 0644 $pkgname.png $pkgdir/usr/share/icons/hicolor/64x64/
+ install -m 0755 $pkgname-launcher $pkgdir/usr/bin/
+ ln -s $pkgdir/usr/bin/$pkgname-launcher $pkgdir/usr/bin/fate
}
#vim: syntax=sh