summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorStoyan Minaev2019-05-24 19:07:03 +0300
committerStoyan Minaev2019-05-24 19:07:03 +0300
commitac960ebbf4d4852917cf2af1c8935064a51c1e1a (patch)
tree7985b29f76065611eff736afae90591ed0a34107
downloadaur-ac960ebbf4d4852917cf2af1c8935064a51c1e1a.tar.gz
Initial commit
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD41
2 files changed, 57 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..06a842e11d0e
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = fate-the-game
+ pkgdesc = The Game is based to simulate a real life hack
+ pkgver = 0.2
+ pkgrel = 1
+ arch = x86_64
+ license = custom
+ depends = dosbox
+ source = https://master.dl.sourceforge.net/project/host-fate-dos-game/Fate.zip
+ source = https://master.dl.sourceforge.net/project/host-fate-dos-game/fate-the-game.desktop
+ source = https://master.dl.sourceforge.net/project/host-fate-dos-game/fate-the-game.png
+ md5sums = 3db0a0bbc8279477f672272d20270c89
+ md5sums = 0a585e4d38a2b7a62a8895ae2bf4eef3
+ md5sums = 3aad39f65bef9ff83a55c255615f5ea2
+
+pkgname = fate-the-game
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..2ef21c1ac2c7
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,41 @@
+# Author m101
+# Maintainer Stoyan Minaev <stoyan.minaev@gmail.com>
+
+pkgname=fate-the-game
+pkgver=0.2
+pkgrel=1
+pkgdesc="The Game is based to simulate a real life hack"
+license=('custom')
+source=(
+ "https://master.dl.sourceforge.net/project/host-fate-dos-game/Fate.zip"
+ "https://master.dl.sourceforge.net/project/host-fate-dos-game/fate-the-game.desktop"
+ "https://master.dl.sourceforge.net/project/host-fate-dos-game/fate-the-game.png"
+)
+arch=('x86_64')
+md5sums=(
+ '3db0a0bbc8279477f672272d20270c89'
+ '0a585e4d38a2b7a62a8895ae2bf4eef3'
+ '3aad39f65bef9ff83a55c255615f5ea2'
+)
+depends=(
+ dosbox
+)
+
+prepare() {
+ cd $srcdir/
+ 7z -y x Fate.zip
+}
+
+package() {
+ cd $srcdir/
+ mkdir -p $pkgdir/usr/share/$pkgname/
+ mkdir -p $pkgdir/usr/share/doc/$pkgname/
+ mkdir -p $pkgdir/usr/share/applications/
+ mkdir -p $pkgdir/usr/share/icons/hicolor/64x64/
+ install -m 0644 Fate.exe $pkgdir/usr/share/$pkgname/
+ install -m 0644 Readme.txt $pkgdir/usr/share/doc/$pkgname/
+ install -m 0644 $pkgname.desktop $pkgdir/usr/share/applications/
+ install -m 0644 $pkgname.png $pkgdir/usr/share/icons/hicolor/64x64/
+}
+
+#vim: syntax=sh