summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorRhys Perry2019-09-10 21:43:02 +0200
committerRhys Perry2019-09-10 21:43:02 +0200
commita9a4a6af464911087e26792a17beafbacb835029 (patch)
tree2427231e1985b6a4dac2fe49b0b096692b719c77
parentd65ecc589d2568a191f6245a00a305278107f6fd (diff)
downloadaur-a9a4a6af464911087e26792a17beafbacb835029.tar.gz
Make compatible with yay
-rw-r--r--PKGBUILD7
1 files changed, 7 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
index bd1c4aaabcac..d5d6434a61f9 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -27,7 +27,13 @@ prepare(){
build(){
cp -r "$srcdir" "$blddir"
+ cd "$blddir"
+
+ mkdir -p gopath/src/github.com/usefathom
+ ln -rTsf "$_gitname" gopath/src/github.com/usefathom/fathom
+
export GOPATH="$blddir"/gopath
+ cd "$_gitname"
make build
}
@@ -35,4 +41,5 @@ package(){
cd "$blddir"/"$_gitname"
install -Dm644 LICENSE "$pkgdir"/usr/share/licenses/"$pkgname"/LICENSE
install -Dm755 fathom "$pkgdir"/usr/bin/fathom
+ rm -rf "$blddir"
} \ No newline at end of file