summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorcorp2018-11-16 20:13:42 -0500
committercorp2018-11-16 20:13:42 -0500
commit3377ffc6fac4b2efc44b62b41f5b7ecb966f28ea (patch)
treed5e21213b18d1ddd1e09ed70e246c1a57aab64b2
parent80a9b1b1cdb162ba3540055db39c6379acbef3fc (diff)
downloadaur-3377ffc6fac4b2efc44b62b41f5b7ecb966f28ea.tar.gz
Updated for 1.15 (fix)
-rw-r--r--.SRCINFO13
-rw-r--r--PKGBUILD17
-rw-r--r--fatx.patch12
3 files changed, 31 insertions, 11 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 2d332b1f3476..f3bf248a55b4 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,17 +1,18 @@
pkgbase = fatx
pkgdesc = XBox filesystem support for linux
- pkgver = 1.14
- pkgrel = 1
+ pkgver = 1.15
+ pkgrel = 2
url = http://sourceforge.net/projects/fatx/
- arch = i686
- arch = x86_64
+ arch = any
license = GPL
depends = fuse
depends = boost
depends = boost-libs
provides = fatx
- source = http://downloads.sourceforge.net/project/fatx/fatx-1.14.tar.gz
- sha256sums = 7fc2a877267218eaabc4a16318371774e85dfdc2c8d2962ce984c87146e81a4e
+ source = http://downloads.sourceforge.net/project/fatx/fatx-1.15.tar.gz
+ source = fatx.patch
+ sha256sums = bcdd90d37ff16c83ae5350273cf000064de698e2ddde3ba7aa1da3e6cfc4c455
+ sha256sums = f7a9cf753c130654dd3d5de109b562dc2f9b188688d961f57023e29eb2f89470
pkgname = fatx
diff --git a/PKGBUILD b/PKGBUILD
index 186b85c3d478..368583f282e2 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,19 +1,26 @@
# Maintainer: t3kk3n <corp [at] hush [dot] ai>
pkgname=fatx
-pkgver=1.14
-pkgrel=1
+pkgver=1.15
+pkgrel=2
pkgdesc="XBox filesystem support for linux"
-arch=('i686' 'x86_64')
+arch=('any')
url="http://sourceforge.net/projects/fatx/"
license=('GPL')
provides=($pkgname)
depends=('fuse' 'boost' 'boost-libs')
-source=("http://downloads.sourceforge.net/project/fatx/${pkgname}-${pkgver}.tar.gz")
-sha256sums=('7fc2a877267218eaabc4a16318371774e85dfdc2c8d2962ce984c87146e81a4e')
+source=("http://downloads.sourceforge.net/project/fatx/${pkgname}-${pkgver}.tar.gz" "fatx.patch")
+sha256sums=('bcdd90d37ff16c83ae5350273cf000064de698e2ddde3ba7aa1da3e6cfc4c455'
+ 'f7a9cf753c130654dd3d5de109b562dc2f9b188688d961f57023e29eb2f89470')
+
+prepare() {
+ cd "${srcdir}/${pkgname}-${pkgver}"
+ patch -Np1 -i "../fatx.patch"
+}
build() {
cd "${srcdir}/${pkgname}-${pkgver}"
+ export CC=/usr/bin/gcc-6
./configure --prefix=/usr --sbindir=/usr/bin
make
}
diff --git a/fatx.patch b/fatx.patch
new file mode 100644
index 000000000000..cd525eb75832
--- /dev/null
+++ b/fatx.patch
@@ -0,0 +1,12 @@
+diff -ura fatx-1.15.orig/fatx.cpp fatx-1.15.new/fatx.cpp
+--- fatx-1.15.orig/fatx.cpp 2018-02-15 12:27:26.000000000 -0500
++++ fatx-1.15.new/fatx.cpp 2018-11-16 19:52:12.000000000 -0500
+@@ -61,7 +61,7 @@
+ }
+ if(container.size() + vv.size() > capacity) {
+ typename container_type::right_iterator b = container.right.begin();
+- advance(b, container.size() + vv.size() - capacity);
++ std::advance(b, container.size() + vv.size() - capacity);
+ #if defined DEBUG && defined DBG_CACHE
+ dbglog((format("Xx. fatbuf: reduce (%d)\n") % container.size()).str())
+ #endif