summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authort3kk3n2024-04-17 11:24:14 -0400
committert3kk3n2024-04-17 11:24:14 -0400
commit4e79cc12fd2796c0ee9af5e0d2d4e8d236fecb5f (patch)
tree907de0ef2aaaecee498ac74713854094a96d2050
parentf8db47af51d8c01107fc8535dc1c6d626194b9d5 (diff)
downloadaur-4e79cc12fd2796c0ee9af5e0d2d4e8d236fecb5f.tar.gz
Bend CMAKE to my will
-rw-r--r--PKGBUILD2
1 files changed, 2 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
index b062c906ae02..8dfbffcd9f8b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -15,6 +15,8 @@ source=("http://downloads.sourceforge.net/project/fatx/${pkgname}-${pkgver}.tar.
sha256sums=('533b1a40d9fe0e7038d0ad8a461624c01cd0bc7c52a79cdc9293db0fcc1b4e25')
build() {
+ sed -i 's/SBIN/BIN/g' "${srcdir}/CMakeLists.txt"
+ sed -i 's/sbin/bin/g' "${srcdir}/CMakeLists.txt"
cmake -B build -S "$srcdir" -DCMAKE_BUILD_TYPE='None' -DCMAKE_INSTALL_PREFIX='/usr' -Wno-dev
cmake --build build
}