summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorBakasura2021-07-24 17:03:48 -0500
committerBakasura2021-07-24 17:03:48 -0500
commit4e9ec5f18ac2cb3d909cf3fb3166fd5105acba88 (patch)
treee69c7dae2a42aedf88f4e43c5123827c2d9e9da7
parente62668f5eb3630a8fa703adf4f73f4868ab6a79f (diff)
downloadaur-4e9ec5f18ac2cb3d909cf3fb3166fd5105acba88.tar.gz
Change maintainer, fix patch
-rw-r--r--.SRCINFO3
-rw-r--r--PKGBUILD4
-rw-r--r--fatx.patch31
3 files changed, 24 insertions, 14 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 4dbf1a69196e..19e41300fdab 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -12,7 +12,6 @@ pkgbase = fatx
source = http://downloads.sourceforge.net/project/fatx/fatx-1.15.tar.gz
source = fatx.patch
sha256sums = bcdd90d37ff16c83ae5350273cf000064de698e2ddde3ba7aa1da3e6cfc4c455
- sha256sums = f7a9cf753c130654dd3d5de109b562dc2f9b188688d961f57023e29eb2f89470
+ sha256sums = a03197b4639cc019aca9e8cf784e2a41b0bd2d6a8e7bce1f624c079dd877f429
pkgname = fatx
-
diff --git a/PKGBUILD b/PKGBUILD
index cbc99ff2461b..50edb20e82ed 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,4 +1,4 @@
-# Maintainer: t3kk3n <corp [at] hush [dot] ai>
+# Maintainer: Bakasura <bakasura@protonmail.ch>
pkgname=fatx
pkgver=1.15
@@ -11,7 +11,7 @@ provides=($pkgname)
depends=('fuse' 'boost' 'boost-libs')
source=("http://downloads.sourceforge.net/project/fatx/${pkgname}-${pkgver}.tar.gz" "fatx.patch")
sha256sums=('bcdd90d37ff16c83ae5350273cf000064de698e2ddde3ba7aa1da3e6cfc4c455'
- 'f7a9cf753c130654dd3d5de109b562dc2f9b188688d961f57023e29eb2f89470')
+ 'a03197b4639cc019aca9e8cf784e2a41b0bd2d6a8e7bce1f624c079dd877f429')
prepare() {
cd "${srcdir}/${pkgname}-${pkgver}"
diff --git a/fatx.patch b/fatx.patch
index cd525eb75832..c2436095742c 100644
--- a/fatx.patch
+++ b/fatx.patch
@@ -1,12 +1,23 @@
-diff -ura fatx-1.15.orig/fatx.cpp fatx-1.15.new/fatx.cpp
---- fatx-1.15.orig/fatx.cpp 2018-02-15 12:27:26.000000000 -0500
-+++ fatx-1.15.new/fatx.cpp 2018-11-16 19:52:12.000000000 -0500
+--- fatx-1.15/fatx.cpp 2018-02-15 12:27:26.000000000 -0500
++++ fatx-1.15/fatx.cpp 2021-05-09 12:16:25.971134000 -0500
@@ -61,7 +61,7 @@
- }
- if(container.size() + vv.size() > capacity) {
- typename container_type::right_iterator b = container.right.begin();
+ }
+ if(container.size() + vv.size() > capacity) {
+ typename container_type::right_iterator b = container.right.begin();
- advance(b, container.size() + vv.size() - capacity);
-+ std::advance(b, container.size() + vv.size() - capacity);
- #if defined DEBUG && defined DBG_CACHE
- dbglog((format("Xx. fatbuf: reduce (%d)\n") % container.size()).str())
- #endif
++ std::advance(b, container.size() + vv.size() - capacity);
+ #if defined DEBUG && defined DBG_CACHE
+ dbglog((format("Xx. fatbuf: reduce (%d)\n") % container.size()).str())
+ #endif
+@@ -1969,8 +1969,8 @@
+
+ dskmap:: dskmap(const fatxpar& par) :
+ memnext(
+- bind(&dskmap::real_read, this, _1, _2),
+- bind(&dskmap::real_write, this, _1, _2),
++ bind(&dskmap::real_read, this, boost::placeholders::_1, boost::placeholders::_2),
++ bind(&dskmap::real_write, this, boost::placeholders::_1, boost::placeholders::_2),
+ #define CACHESIZE (par.clus_fat * par.chain_size / max_cache_div > par.clus_size ? par.clus_fat * par.chain_size / max_cache_div : par.clus_size)
+ CACHESIZE,
+ (CACHESIZE / nb_cache_div > par.clus_size ? CACHESIZE / nb_cache_div : par.clus_size)
+