summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorcorp2015-06-09 01:49:20 -0400
committercorp2015-06-09 01:49:20 -0400
commitfd70c1f1003a9387eb6ab1bb6e00318bb2a54120 (patch)
treeb0f3c12f7eaa1d2128f7eed95f06af097059945c
downloadaur-fd70c1f1003a9387eb6ab1bb6e00318bb2a54120.tar.gz
Initial import
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD24
2 files changed, 40 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..8f59da4bdaac
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = fatx
+ pkgdesc = XBox filesystem support for linux
+ pkgver = 1.9
+ pkgrel = 2
+ url = http://sourceforge.net/projects/fatx/
+ arch = i686
+ arch = x86_64
+ license = GPL
+ depends = fuse
+ depends = boost
+ depends = boost-libs
+ provides = fatx
+ source = http://downloads.sourceforge.net/project/fatx/fatx_1.9.orig.tar.gz
+
+pkgname = fatx
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..617a3f5d2a5d
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,24 @@
+# Maintainer: t3kk3n <corp [at] hush [dot] ai>
+
+pkgname=fatx
+pkgver=1.9
+pkgrel=2
+pkgdesc="XBox filesystem support for linux"
+arch=('i686' 'x86_64')
+url="http://sourceforge.net/projects/fatx/"
+license=('GPL')
+provides=($pkgname)
+depends=('fuse' 'boost' 'boost-libs')
+source=("http://downloads.sourceforge.net/project/fatx/${pkgname}_${pkgver}.orig.tar.gz")
+sha256sum=('0e0203fce77b28101437265de9bf52bd113cb51658b9af45761a368bbeb1aa4c')
+
+build() {
+ cd "${srcdir}/${pkgname}-${pkgver}"
+ ./configure --prefix=/usr --sbindir=/usr/bin
+ make
+}
+
+package() {
+ cd "${srcdir}/${pkgname}-${pkgver}"
+ make DESTDIR="$pkgdir/" install
+}