summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJoe Davis2018-07-19 18:58:01 +0100
committerJoe Davis2018-07-19 18:58:01 +0100
commit471bd49e22d977d301479894cd9e6599a1a2990f (patch)
tree4631a29f3e554bf9176d621acdcb5c871d59338e
parentb63eaff01839b871dbd22e036cc1a5ef7a0986c0 (diff)
downloadaur-471bd49e22d977d301479894cd9e6599a1a2990f.tar.gz
moved to seperate repository
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD12
-rw-r--r--faur.134
-rwxr-xr-xfaur.sh79
4 files changed, 8 insertions, 125 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 3dfe263b2661..d6440ca08af3 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,13 +1,11 @@
pkgbase = faur
pkgver = 0.1
- pkgrel = 2
+ pkgrel = 3
arch = any
license = custom:ISC
depends = git
- source = faur.1
- source = faur.sh
- md5sums = a01b73f1e9abd471e53b11440f94f492
- md5sums = 72c778c3c8a782673e4971bfcaa28819
+ source = faur::git+https://gitlab.com/tharkun/faur.git#branch=v0.1
+ md5sums = SKIP
pkgname = faur
diff --git a/PKGBUILD b/PKGBUILD
index e807358ea7a2..4ce234b48fbf 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,16 +1,14 @@
# Maintainer: Joe Davis <me@jo.ie>
pkgname='faur'
pkgver='0.1'
-pkgrel='2'
+pkgrel='3'
arch=('any')
license=('custom:ISC')
depends=('git')
-source=('faur.1'
- 'faur.sh')
-md5sums=('a01b73f1e9abd471e53b11440f94f492'
- '72c778c3c8a782673e4971bfcaa28819')
+source=('faur::git+https://gitlab.com/tharkun/faur.git#branch=v0.1')
+md5sums=('SKIP')
package() {
- install -D -m 755 "$srcdir/$pkgname.sh" "$pkgdir/usr/bin/$pkgname"
- install -D -m 444 "$srcdir/$pkgname.1" "$pkgdir/usr/share/man/man1/$pkgname.1"
+ install -D -m 755 "$srcdir/faur/$pkgname.sh" "$pkgdir/usr/bin/$pkgname"
+ install -D -m 444 "$srcdir/faur/$pkgname.1" "$pkgdir/usr/share/man/man1/$pkgname.1"
}
diff --git a/faur.1 b/faur.1
deleted file mode 100644
index 449d069f1ba8..000000000000
--- a/faur.1
+++ /dev/null
@@ -1,34 +0,0 @@
-.\" Automatically generated by Pandoc 2.2.2
-.\"
-.TH "FAUR" "1" "July 17, 2018" "\- faur\-0.1" ""
-.hy
-.SH NAME
-.PP
-faur \- lightweight, opinionated AUR helper
-.SH SYNOPSIS
-.PP
-faur fetch [\f[I]pkgs\f[]]\&...
-.PP
-faur update
-.PP
-faur help
-.SH DESCRIPTION
-.PP
-faur downloads packages to the directory specified in $AURDIR.
-If $AURDIR is unset $HOME/aur is used as a default.
-Packages are cloned from the git repository located under $AUR_PATH, if
-unset https://aur.archlinux.org/ is used as a default value.
-.PP
-The update command checks to see which if any of the packages underneath
-$AURDIR need to be updated and notifies the user.
-.SH DEPENDENCY MANAGEMENT
-.PP
-faur \f[I]does not\f[] attempt to resolve dependencies, as doing so
-would discourage the user from reading PKGBUILD files before
-installation.
-.PP
-Users should bear in mind that the AUR is an \f[I]untrusted\f[] source
-of packages and always exercise caution when installing packages from
-it.
-.SH AUTHORS
-Joe Davis <me@jo.ie>.
diff --git a/faur.sh b/faur.sh
deleted file mode 100755
index bf6a6b49ce96..000000000000
--- a/faur.sh
+++ /dev/null
@@ -1,79 +0,0 @@
-#!/bin/sh
-# Copyright (c) 2018, Joe Davis <me@jo.ie>
-#
-# Permission to use, copy, modify, and/or distribute this software for any
-# purpose with or without fee is hereby granted, provided that the above
-# copyright notice and this permission notice appear in all copies.
-#
-# THE SOFTWARE IS PROVIDED "AS IS" AND THE AUTHOR DISCLAIMS ALL WARRANTIES
-# WITH REGARD TO THIS SOFTWARE INCLUDING ALL IMPLIED WARRANTIES OF
-# MERCHANTABILITY AND FITNESS. IN NO EVENT SHALL THE AUTHOR BE LIABLE FOR
-# ANY SPECIAL, DIRECT, INDIRECT, OR CONSEQUENTIAL DAMAGES OR ANY DAMAGES
-# WHATSOEVER RESULTING FROM LOSS OF USE, DATA OR PROFITS, WHETHER IN AN
-# ACTION OF CONTRACT, NEGLIGENCE OR OTHER TORTIOUS ACTION, ARISING OUT OF
-# OR IN CONNECTION WITH THE USE OR PERFORMANCE OF THIS SOFTWARE.
-
-set -e
-
-AURDIR=${AURDIR:-$HOME/aur}
-AUR_PATH=${AUR_PATH:-https://aur.archlinux.org/}
-
-PROG=$(basename "$0")
-
-usage() {
- printf 'USAGE: %s fetch [pkg...]\n' "$PROG" 2>&1
- printf ' %s update\n' "$PROG" 2>&1
- printf ' %s help\n' "$PROG" 2>&1
- exit $1
-}
-
-update() {
- printf "The following packages need updating: "
- none="none found"
-
- for pkg in $*; do
- out=$(cd "$pkg" && git pull)
- if [ "$out" != "Already up to date." ]; then
- none=''
- printf '\n %s' "$pkg"
- fi
- done
- echo $none
-}
-
-fetch() {
- while [ $# -gt 0 ]; do
- git clone "${AUR_PATH}$1.git"
- shift
- done
-}
-
-if [ $# -eq 0 ]; then
- usage 1
-fi
-
-if [ "$1" = "help" ]; then
- usage 0
-fi
-
-cd "$AURDIR"
-
-if [ "$1" = "fetch" ]; then
- shift
- if [ $# -eq 0 ]; then
- usage 1
- fi
- fetch $*
-elif [ "$1" = "update" ]; then
- # Skip folders containing spaces, newlines and those beginning with '.'
- # This avoids problems with for loops over find output
- PKGS=$(find . -maxdepth 1 \
- ! -name ".*" \
- ! -name "* *" ! -name "$(printf "*\\n*")" \
- -type d)
- update $PKGS
-else
- echo "Unknown command: $1" 2>&1
- usage
- exit 1
-fi