summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDavid Runge2018-01-23 22:18:38 +0100
committerDavid Runge2018-01-23 22:18:38 +0100
commitf8da3ecc47ef81cbfd65a3c1d2adadc06d55f573 (patch)
treefa1f1fbc13556485b221ba5c82498ac2a5e0a140
parent206e58b15a95bd3739a28c4e4079cf255f629d99 (diff)
downloadaur-f8da3ecc47ef81cbfd65a3c1d2adadc06d55f573.tar.gz
PKGBUILD: Changing maintainer. Adding java-runtime to optdepends.
Removing options. Adding conflicts with faust-git. Switchting to tarball for source. Switching to sha512sums. Fixing installation of docs. Adding syntax files for atom. Minor fixes.
-rw-r--r--PKGBUILD92
-rw-r--r--python2-fix.patch10
2 files changed, 51 insertions, 51 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 808843940de1..8230c177bc76 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,91 +1,81 @@
-# Maintainer: Albert Graef <aggraef at gmail.com>
+# Maintainer: David Runge <dave@sleepmap.de>
+# Contributor: Albert Graef <aggraef at gmail.com>
# Contributor: Bernardo Barros <bernardobarros at gmail dot com>
# Contributor: bjoern lindig (bjoern _dot_ lindig _at_ google.com)
pkgname=faust
pkgver=2.5.10
-tag=$(echo $pkgver | sed -e 's/\./-/g' -e s/^/v/)
pkgrel=2
pkgdesc="A functional programming language for realtime audio signal processing."
-arch=('i686' 'x86_64')
-url="http://faust.grame.fr/"
-license=('GPL')
-depends=('llvm-libs'
-# needed for sound2faust:
- 'libsndfile'
-# needed for libfaustremote and faustbench:
-# 'jack2'
-# needed for libHTTPDFaust:
- 'libmicrohttpd' 'openssl')
-# We need xxd at build time, which is provided by 'gvim', 'vim' and
-# 'xxd-standalone' (AUR).
+arch=('x86_64')
+url="https://faust.grame.fr/"
+license=('GPL2')
+depends=('llvm-libs' 'libsndfile' 'libmicrohttpd')
makedepends=('llvm' 'git' 'xxd')
optdepends=('clang: needed for sound2reader'
- 'python2: needed for faust2md'
- 'ruby: needed for faust2sc and scbuilder')
+ 'python2: needed for faust2md'
+ 'ruby: needed for faust2sc and scbuilder'
+ 'java-runtime=8: needed for faust2android')
provides=('faust')
-conflicts=('faust')
-# This keeps the static libraries. Remove the 'staticlibs' option if this
-# isn't wanted.
-options=('strip' 'staticlibs')
-source=("$pkgname::git+https://github.com/grame-cncm/faust.git#tag=$tag"
- "git+https://github.com/agraef/emacs-faust-mode.git"
- "python2-fix.patch"
- "llvm-501-fix.patch")
-md5sums=('SKIP'
- 'SKIP'
- '8680b87fc4e34445e02f34781ee45f19'
- 'abac254a7fbe56f927e3d14ab5603849')
+conflicts=('faust-git')
+source=("https://github.com/grame-cncm/${pkgname}/releases/download/v${pkgver//./-}/${pkgname}-${pkgver}.tar.gz"
+ "git+https://github.com/agraef/emacs-faust-mode.git"
+ 'python2-fix.patch'
+ 'llvm-501-fix.patch')
+sha512sums=('ee8e6a409eb092a59c2a5229087f8d5eb2a38c998df97398202aff48f0ad4ff4dd6c8f54f8f02aad24e32b54b0be7f273d2b7adc04f80a5fc4d607bafd4fc926'
+ 'SKIP'
+ 'aefee8c8bfe1115f8b2a576e6021bd0da3eeced9403878dc124fe7fbcb819d3910f1f119662ae09c52e60dff6ebfc76f0f63e07df3705e0849149fa540104482'
+ '3af0037631a4663156b29b3cbff8d1914b290708919aedbeaf44cbc4cc1ef6bbe02d064e7a5f901689afe44038f4c048a7edfbf4e2fa6611ba5ebeb2d9aae2d5')
prepare() {
- cd $srcdir/$pkgname
- git submodule update --init
- # fix up scripts like faust2md which need python2 to run
- patch -Np1 < $srcdir/python2-fix.patch
+ cd "${pkgname}-${pkgver}"
+ # fix scripts requiring python2
+ patch -Np1 < "${srcdir}/python2-fix.patch"
# temporary fix in 2.5.10
- patch -Np1 < $srcdir/llvm-501-fix.patch
+ patch -Np1 < "${srcdir}/llvm-501-fix.patch"
}
-# NOTE: libHTTPDFaust requires 'liblo', 'libmicrohttpd' and 'openssl'.
-# Similarly, sound2faust requires libsndfile which we also include by default.
-# These are all optional, so you can get rid of the extra dependencies by
-# changing the build target from 'world' to 'all' and removing the
-# corresponding dependencies above.
-
build() {
- cd $srcdir/$pkgname
+ cd "${pkgname}-${pkgver}"
make PREFIX=/usr world
- # 'remote' and 'benchmark' are disabled right now since they require jack2.
- #make benchmark remote PREFIX=/usr
}
package() {
- cd $srcdir/$pkgname
+ cd "${pkgname}-${pkgver}"
make install PREFIX=/usr DESTDIR="$pkgdir"
# docs
- install -d "$pkgdir/usr/share/doc/faust"
- for x in documentation/*.{pdf,html} libraries/doc/*.{pdf,html}; do test -f $x && install -Dm644 $x "$pkgdir/usr/share/doc/faust"; done
+ install -t "${pkgdir}/usr/share/doc/${pkgname}" \
+ -Dm644 documentation/*.{pdf,html}
# examples
- install -d "$pkgdir/usr/share/faust/examples"
- cp -R "examples/"* "$pkgdir/usr/share/faust/examples/"
+ install -d "${pkgdir}/usr/share/${pkgname}/examples"
+ cp -R "examples/"* "${pkgdir}/usr/share/${pkgname}/examples/"
## syntax highlighting files
cd syntax-highlighting
-
+ # atom
+ install -Dm644 "atom/language-${pkgname}/package.json" \
+ "${pkgdir}/usr/lib/atom/dot-atom/packages/language-faust/package.json"
+ install -Dm644 "atom/language-${pkgname}/grammars/${pkgname}.cson" \
+ "${pkgdir}/usr/lib/atom/dot-atom/packages/language-faust/grammars/${pkgname}.cson"
+ install -Dm644 "atom/language-${pkgname}/settings/language-${pkgname}.cson" \
+ "${pkgdir}/usr/lib/atom/dot-atom/packages/language-faust/settings/language-${pkgname}.cson"
+ install -t "${pkgdir}/usr/lib/atom/dot-atom/packages/language-faust/snippets/" \
+ -Dm644 "atom/language-${pkgname}/snippets/"*
+ install -Dm644 "atom/language-${pkgname}/process-palette.json.linux" \
+ "${pkgdir}/usr/share/doc/${pkgname}/process-palette.json"
# kate
install -Dm644 faust.xml "$pkgdir/usr/share/apps/katepart/syntax/faust.xml"
# gedit
install -Dm644 faust.lang "$pkgdir/usr/share/gtksourceview-2.0/language-specs/faust.lang"
install -Dm644 faust.lang "$pkgdir/usr/share/gtksourceview-3.0/language-specs/faust.lang"
-
# highlight
install -Dm644 dsp.lang "$pkgdir/usr/share/highlight/langDefs/dsp.lang"
-
+ # nano
+ install -Dm644 "${pkgname}.nanorc" "$pkgdir/usr/share/nano/${pkgname}.nanorc"
# vim
install -Dm644 faust.vim "$pkgdir/usr/share/vim/vimfiles/syntax/faust.vim"
-
# emacs
install -d "$pkgdir/usr/share/emacs/site-lisp/"
install -Dm644 "$srcdir/emacs-faust-mode/faust-mode.el" "$pkgdir/usr/share/emacs/site-lisp/"
diff --git a/python2-fix.patch b/python2-fix.patch
index 81e932f38a56..dcb473d7b02f 100644
--- a/python2-fix.patch
+++ b/python2-fix.patch
@@ -8,3 +8,13 @@ index 2e460fcb9..5831a86a9 100755
#---------------------- faust2md -----------------------
# Usage: `faust2md [-t 4] [-c] [-f] foo.dsp > foo.md`
+diff --git a/tools/faust2appls/faust2atomsnippets b/tools/faust2appls/faust2atomsnippets
+index 183436022..989618a30 100755
+--- a/tools/faust2appls/faust2atomsnippets
++++ b/tools/faust2appls/faust2atomsnippets
+@@ -1,4 +1,4 @@
+-#!/usr/bin/env python
++#!/usr/bin/env python2
+
+ #---------------------- faust2atomsnippets -----------------------
+ # Usage: `faust2atomsnippets *.lib > faust-library.cson`