summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAlbert Graef2016-03-29 20:15:22 +0200
committerAlbert Graef2016-03-29 20:15:22 +0200
commitd23eaab316c48908f9771294754f0531299af219 (patch)
tree5f6b86da44772e1154de5fafe000e33537de31b2
parentc1aa6d3ebbe7b8b115de10e42704e544808b2991 (diff)
downloadaur-d23eaab316c48908f9771294754f0531299af219.tar.gz
Update to latest revision, add custom GUI support.
-rw-r--r--.SRCINFO14
-rwxr-xr-xPKGBUILD14
2 files changed, 17 insertions, 11 deletions
diff --git a/.SRCINFO b/.SRCINFO
index fcbde8c2e935..9a6be148794d 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,16 +1,18 @@
# Generated by mksrcinfo v8
-# Sun Feb 14 06:54:39 UTC 2016
+# Tue Mar 29 18:12:13 UTC 2016
pkgbase = faust-vst-git
- pkgdesc = VST plugin architecture for Faust
- pkgver = 40.f65d286
+ pkgdesc = Faust VST plugin examples
+ pkgver = 77.cd06479
pkgrel = 1
url = https://bitbucket.org/agraef/faust-vst/
arch = i686
arch = x86_64
license = LGPL
- depends = faust
- depends = boost
- depends = steinberg-vst36
+ makedepends = faust
+ makedepends = boost
+ makedepends = steinberg-vst36
+ depends = qt5-base
+ depends = qt5-x11extras
source = git+https://bitbucket.org/agraef/faust-vst
md5sums = SKIP
diff --git a/PKGBUILD b/PKGBUILD
index 87ab454aa196..59021c758e9b 100755
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,14 +1,14 @@
# Maintainer: Albert Graef <aggraef at gmail dot com>
pkgname=faust-vst-git
-pkgver=40.f65d286
+pkgver=77.cd06479
pkgrel=1
-pkgdesc="VST plugin architecture for Faust"
+pkgdesc="Faust VST plugin examples"
arch=("i686" "x86_64")
license=('LGPL')
url="https://bitbucket.org/agraef/faust-vst/"
-depends=('faust' 'boost' 'steinberg-vst36')
-makedepends=()
+depends=('qt5-base' 'qt5-x11extras')
+makedepends=('faust' 'boost' 'steinberg-vst36')
source=("git+https://bitbucket.org/agraef/faust-vst")
md5sums=(SKIP)
@@ -17,11 +17,15 @@ pkgver() {
echo $(git rev-list --count HEAD).$(git rev-parse --short HEAD)
}
+# You can remove 'gui=1' (as well as the 'qt5-base' 'qt5-x11extras' depends)
+# if you don't want the custom plugin GUIs.
build() {
cd $srcdir/faust-vst
- make || return 1
+ make gui=1 || return 1
}
+# Architecture and helper script aren't installed as they're also included in
+# the latest Faust revisions. Add the 'install-faust' target if you need them.
package() {
cd $srcdir/faust-vst
make prefix=/usr DESTDIR=$pkgdir install || return 1