summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAlbert Graef2015-06-13 22:58:31 +0200
committerAlbert Graef2015-06-13 22:58:31 +0200
commit96a86403c64d02840099039effb418b623d023ce (patch)
tree72ce6d6be2ad0c8c664cb58f293b7f5c4e93cdce
downloadaur-96a86403c64d02840099039effb418b623d023ce.tar.gz
Initial import
-rw-r--r--.AURINFO20
-rw-r--r--.SRCINFO20
-rw-r--r--PKGBUILD31
3 files changed, 71 insertions, 0 deletions
diff --git a/.AURINFO b/.AURINFO
new file mode 100644
index 000000000000..8ba43935eecb
--- /dev/null
+++ b/.AURINFO
@@ -0,0 +1,20 @@
+pkgbase = faust2pd
+ pkgdesc = Generate Pd GUI abstractions from Faust programs
+ pkgver = 2.12
+ pkgrel = 1
+ url = http://purelang.bitbucket.org/
+ arch = i686
+ arch = x86_64
+ groups = pure-complete
+ groups = pure-multimedia
+ license = GPL3
+ makedepends = faust
+ depends = pure
+ depends = pure-xml
+ depends = pd
+ depends = curl
+ source = https://bitbucket.org/purelang/pure-lang/downloads/faust2pd-2.12.tar.gz
+ md5sums = 2ef0fd7b5aa22986ac9ec6c36fd073da
+
+pkgname = faust2pd
+
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..8ba43935eecb
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,20 @@
+pkgbase = faust2pd
+ pkgdesc = Generate Pd GUI abstractions from Faust programs
+ pkgver = 2.12
+ pkgrel = 1
+ url = http://purelang.bitbucket.org/
+ arch = i686
+ arch = x86_64
+ groups = pure-complete
+ groups = pure-multimedia
+ license = GPL3
+ makedepends = faust
+ depends = pure
+ depends = pure-xml
+ depends = pd
+ depends = curl
+ source = https://bitbucket.org/purelang/pure-lang/downloads/faust2pd-2.12.tar.gz
+ md5sums = 2ef0fd7b5aa22986ac9ec6c36fd073da
+
+pkgname = faust2pd
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..38711c2b5dc1
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,31 @@
+# Maintainer: Albert Graef <aggraef@gmail.com>
+
+pkgname=faust2pd
+pkgver=2.12
+pkgrel=1
+pkgdesc="Generate Pd GUI abstractions from Faust programs"
+arch=("i686" "x86_64")
+license=('GPL3')
+url="http://purelang.bitbucket.org/"
+depends=('pure' 'pure-xml' 'pd' 'curl')
+makedepends=('faust')
+groups=(pure-complete pure-multimedia)
+source=("https://bitbucket.org/purelang/pure-lang/downloads/$pkgname-$pkgver.tar.gz")
+md5sums=('2ef0fd7b5aa22986ac9ec6c36fd073da')
+
+# NOTE: The tarball contains C++ sources generated from the Faust programs,
+# which may need updating, depending on the Faust version we're compiling
+# with. To be on the safe side, we just clean out all generated sources with
+# 'make realclean' in order force a recompile.
+
+build() {
+ cd $srcdir/$pkgname-$pkgver
+ make prefix=/usr PUREC_FLAGS=-mcpu=generic realclean all examples
+}
+
+package() {
+ cd $srcdir/$pkgname-$pkgver
+ make DESTDIR=$pkgdir prefix=/usr install install-pd
+ install -d $pkgdir/usr/lib/pd/extra/faust2pd
+ cp -r examples $pkgdir/usr/lib/pd/extra/faust2pd
+}