summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAlphaJack2022-12-15 01:39:31 +0100
committerAlphaJack2022-12-15 01:39:31 +0100
commitf9af822302149203abd683bee44c50a4af89c0e3 (patch)
treef93b09a4f04a79550407192aa44e675d220885f9
downloadaur-f9af822302149203abd683bee44c50a4af89c0e3.tar.gz
Initial commit
-rw-r--r--.SRCINFO22
-rw-r--r--PKGBUILD37
2 files changed, 59 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..74c838f95789
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,22 @@
+pkgbase = fava-investor-git
+ pkgdesc = Comprehensive set of reports, analyses, and tools for investments, for Beancount and Fava
+ pkgver = 0.4.0.r0.g0e3f652
+ pkgrel = 1
+ url = https://github.com/redstreet/fava_investor
+ arch = any
+ license = GPL3
+ makedepends = git
+ makedepends = python-build
+ makedepends = python-installer
+ makedepends = python-setuptools-scm
+ makedepends = python-wheel
+ depends = fava
+ depends = python-click-aliases
+ depends = python-importlib-metadata
+ depends = python-tabulate
+ depends = python-yfinance
+ options = !strip
+ source = git+https://github.com/redstreet/fava_investor
+ sha256sums = SKIP
+
+pkgname = fava-investor-git
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..e2a7058f6999
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,37 @@
+# Maintainer: AlphaJack <alphajack at tuta dot io>
+
+pkgname="fava-investor-git"
+pkgver=0.4.0.r0.g0e3f652
+pkgrel=1
+pkgdesc="Comprehensive set of reports, analyses, and tools for investments, for Beancount and Fava"
+url="https://github.com/redstreet/fava_investor"
+license=("GPL3")
+arch=("any")
+depends=( "fava"
+ "python-click-aliases"
+ "python-importlib-metadata"
+ "python-tabulate"
+ "python-yfinance")
+makedepends=("git"
+ "python-build"
+ "python-installer"
+ "python-setuptools-scm"
+ "python-wheel")
+options=("!strip")
+source=("git+$url")
+sha256sums=("SKIP")
+
+pkgver() {
+ cd "fava_investor"
+ git describe --long --tags | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
+}
+
+build(){
+ cd "fava_investor"
+ python -m build --wheel --no-isolation
+}
+
+package(){
+ cd "fava_investor"
+ python -m installer --destdir="$pkgdir" dist/*.whl
+}