summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorroot2021-02-20 10:12:10 +0100
committerroot2021-02-20 10:12:10 +0100
commit57f1ce78a17272cdcc64fcc2d7b092d939c49dda (patch)
treeae15af69e4865d905ca6048a87bd392ef956c63c
downloadaur-57f1ce78a17272cdcc64fcc2d7b092d939c49dda.tar.gz
Initial Commit.
-rw-r--r--.SRCINFO22
-rw-r--r--PKGBUILD58
2 files changed, 80 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..8513ec6c7316
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,22 @@
+pkgbase = favicon-to-png-upload
+ pkgdesc = Downloads the 'favicon.ico' from a given URL and uploads it's PNG-version to imgur.com. The imgut.com-URL is printed on stdout and pushed to the clipboard. Also supports markdown-output.
+ pkgver = 0.3_2021_02_20
+ pkgrel = 2
+ epoch = 0
+ arch = any
+ license = GPL3
+ makedepends = awk
+ depends = bash
+ depends = coreutils
+ depends = curl
+ depends = imagemagick
+ depends = imgur.sh
+ depends = sed
+ optdepends = xclip: To copy the result to the X clipboard.
+ optdepends = xsel: To copy the result to the X clipboard (alternative to 'xclip').
+ options = emptydirs
+ source = favicon-to-png-upload::http://ix.io/2Q37
+ sha256sums = d1735de80b57894422bf2142cf0b4cb8213c6a6665c7549062c9125da9636c29
+
+pkgname = favicon-to-png-upload
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..33ef4ec16d5a
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,58 @@
+# Maintainer: dreieck
+
+_pkgname=favicon-to-png-upload
+pkgname="${_pkgname}"
+
+_pkgver="latest"
+epoch=0
+pkgver=0.3_2021_02_20
+pkgrel=2
+
+pkgdesc="Downloads the 'favicon.ico' from a given URL and uploads it's PNG-version to imgur.com. The imgut.com-URL is printed on stdout and pushed to the clipboard. Also supports markdown-output."
+
+license=('GPL3')
+
+arch=(
+ 'any'
+)
+
+depends=(
+ 'bash'
+ 'coreutils'
+ 'curl'
+ 'imagemagick' # Can also be graphicsmagick.
+ 'imgur.sh'
+ 'sed'
+)
+makedepends=(
+ 'awk'
+)
+optdepends=(
+ "xclip: To copy the result to the X clipboard."
+ "xsel: To copy the result to the X clipboard (alternative to 'xclip')."
+)
+provides=()
+replaces=()
+conflicts=()
+
+options=('emptydirs')
+
+source=(
+ "favicon-to-png-upload::http://ix.io/2Q37"
+)
+
+sha256sums=(
+ 'd1735de80b57894422bf2142cf0b4cb8213c6a6665c7549062c9125da9636c29'
+)
+
+prepare() {
+ chmod 755 "${srcdir}/favicon-to-png-upload"
+}
+
+pkgver() {
+ "${srcdir}/favicon-to-png-upload" -f help | grep -Ei '^Version:' | head -n 1 | awk '{print $2}' | tr '-' '_'
+}
+
+package() {
+ install -D -m755 -v "${srcdir}/favicon-to-png-upload" "${pkgdir}/usr/bin/favicon-to-png-upload"
+} \ No newline at end of file