summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorChocobo12021-05-19 18:13:49 +0800
committerChocobo12021-05-19 18:24:41 +0800
commitddbb10ade47ac1632d730c4321eeba1715620dc7 (patch)
tree1878b7e6c65b27eed8287ec4ce630e456f6714a5
downloadaur-ddbb10ade47ac1632d730c4321eeba1715620dc7.tar.gz
newpkg: fawkes-bin 1.0-1
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD24
2 files changed, 41 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..7b5233cb1765
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = fawkes-bin
+ pkgdesc = Image cloaking tool for personal privacy
+ pkgver = 1.0
+ pkgrel = 1
+ url = https://sandlab.cs.uchicago.edu/fawkes/
+ arch = x86_64
+ license = BSD
+ depends = zlib
+ provides = fawkes
+ conflicts = fawkes
+ source = LICENSE::https://raw.githubusercontent.com/Shawn-Shan/fawkes/master/LICENSE
+ sha256sums = SKIP
+ source_x86_64 = https://mirror.cs.uchicago.edu/fawkes/files/1.0/fawkes_binary_linux-v1.0.zip
+ sha256sums_x86_64 = ff74e9fa671b0d3e0fe2a749d2aed9a5cb86298a2546915b5a199669fc5e88b7
+
+pkgname = fawkes-bin
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..64547dc7afd8
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,24 @@
+# Maintainer: Chocobo1 <chocobo1 AT archlinux DOT net>
+
+pkgname=fawkes-bin
+pkgver=1.0
+pkgrel=1
+pkgdesc="Image cloaking tool for personal privacy"
+arch=('x86_64')
+url="https://sandlab.cs.uchicago.edu/fawkes/"
+license=('BSD')
+depends=('zlib')
+provides=('fawkes')
+conflicts=('fawkes')
+source=("LICENSE::https://raw.githubusercontent.com/Shawn-Shan/fawkes/master/LICENSE")
+source_x86_64=("https://mirror.cs.uchicago.edu/fawkes/files/$pkgver/fawkes_binary_linux-v$pkgver.zip")
+sha256sums=('SKIP')
+sha256sums_x86_64=('ff74e9fa671b0d3e0fe2a749d2aed9a5cb86298a2546915b5a199669fc5e88b7')
+
+
+package() {
+ cd "$srcdir"
+
+ install -Dm755 "protection" -t "$pkgdir/usr/bin"
+ install -Dm644 "LICENSE" -t "$pkgdir/usr/share/licenses/fawkes"
+}