summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorYen Chi Hsuan2017-06-02 19:34:00 +0800
committerYen Chi Hsuan2017-06-02 19:34:00 +0800
commit3fb6431d6d7bd0c3fb1a955a521f3ad1966afd3a (patch)
tree35413cbaee2e96f674defc92eeaf8d07f6c20c4d
parenta79602a727d66b7853c57ac169f4977227805d8d (diff)
downloadaur-3fb6431d6d7bd0c3fb1a955a521f3ad1966afd3a.tar.gz
Add a variable to change target API
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD12
2 files changed, 10 insertions, 4 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 64aa447e8481..c2a2b3ad5751 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = fb-adb-git
pkgdesc = A better shell to use in place of adb when connecting to Android devices
pkgver = 20170417.r359.0cc0534
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/facebook/fb-adb
arch = x86_64
license = GPL3
diff --git a/PKGBUILD b/PKGBUILD
index cfd7b25a4ddd..d8967be75b38 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,15 +1,18 @@
# Maintainer: Kevin MacMartin <prurigro at gmail dot com>
+# You may want to change this value if your target device is not API 19
+_TARGET_API=19
+
_pkgname=fb-adb
pkgname=$_pkgname-git
pkgver=20170417.r359.0cc0534
-pkgrel=1
+pkgrel=2
pkgdesc='A better shell to use in place of adb when connecting to Android devices'
url='https://github.com/facebook/fb-adb'
license=('GPL3')
arch=('x86_64')
depends=('android-tools')
-makedepends=('git' 'vim' 'android-sdk-build-tools' 'android-platform-19')
+makedepends=('git' 'vim' 'android-sdk-build-tools' "android-platform-$_TARGET_API")
options=('!strip' '!buildflags')
source=("git+$url.git"
"fix-build.patch"::"https://github.com/facebook/fb-adb/pull/59.patch")
@@ -35,7 +38,10 @@ build() {
# build
install -d build
cd build
- ../configure --enable-checking=yes --with-android-sdk="$ANDROID_HOME"
+ ../configure \
+ --enable-checking=yes \
+ --with-android-sdk="$ANDROID_HOME" \
+ --with-android-platform=android-$_TARGET_API
make
}