summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorKevin MacMartin2015-11-25 18:41:18 -0500
committerKevin MacMartin2015-11-25 18:41:18 -0500
commit8c7f30c69a47e916caf7a1c12a821f8fce10d6fe (patch)
tree7f7f667adb86dcb1bcb74bfcf6566fad654bee07
parentcceba3ce27a507c6b1daed88e61be16cc1d56194 (diff)
downloadaur-8c7f30c69a47e916caf7a1c12a821f8fce10d6fe.tar.gz
Remove the no-longer-necessary zip makedepends and operation in the build function
-rw-r--r--PKGBUILD11
1 files changed, 4 insertions, 7 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 70155db9e1ac..7573da984f26 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,13 +3,13 @@
_pkgname=fb-adb
pkgname=$_pkgname-git
pkgver=20151122.r327.a682c99
-pkgrel=1
+pkgrel=2
pkgdesc='A better shell to use in place of adb when connecting to Android devices'
url='https://github.com/facebook/fb-adb'
license=('GPL3')
arch=('i686' 'x86_64')
depends=('android-tools')
-makedepends=('git' 'vim' 'zip')
+makedepends=('git' 'vim')
options=('!strip' '!buildflags')
source=("git+$url.git")
sha512sums=('SKIP')
@@ -29,7 +29,8 @@ pkgver() {
}
build() {
- [[ -z "$ANDROID_NDK" ]] && export ANDROID_NDK="$srcdir/android-ndk-r$_ndkver"
+ [[ -z "$ANDROID_NDK" ]] \
+ && export ANDROID_NDK="$srcdir/android-ndk-r$_ndkver"
# configure
cd $_pkgname
@@ -40,10 +41,6 @@ build() {
cd build
../configure --enable-checking=yes
make
-
- # compress android deployment binary
- cd stub-arm
- zip $_pkgname-android-arm.zip $_pkgname
}
package() {