summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorKevin MacMartin2016-05-30 21:11:04 -0400
committerKevin MacMartin2016-05-30 21:11:04 -0400
commitd5ee11b6667d9e487d06f127d8581565ddf2a549 (patch)
tree147b46ea85c5aaece58adf4af62102e68be2b538
parent24c27c2628fbbb6c9ed1012c6f90019c99c7bb11 (diff)
downloadaur-d5ee11b6667d9e487d06f127d8581565ddf2a549.tar.gz
Update to 20160514.r338.5e970a4, make the required changes to the PKGBUILD to build correctly and add *.tgz to the .gitignore to account for the android sdk
-rw-r--r--.SRCINFO7
-rw-r--r--.gitignore1
-rw-r--r--PKGBUILD21
3 files changed, 25 insertions, 4 deletions
diff --git a/.SRCINFO b/.SRCINFO
index d8c1d2ccce34..46512645c151 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,8 @@
# Generated by mksrcinfo v8
-# Fri Apr 22 17:11:00 UTC 2016
+# Tue May 31 01:07:16 UTC 2016
pkgbase = fb-adb-git
pkgdesc = A better shell to use in place of adb when connecting to Android devices
- pkgver = 20160421.r337.ae33dc4
+ pkgver = 20160514.r338.5e970a4
pkgrel = 1
url = https://github.com/facebook/fb-adb
arch = i686
@@ -10,11 +10,14 @@ pkgbase = fb-adb-git
license = GPL3
makedepends = git
makedepends = vim
+ makedepends = android-sdk-build-tools
depends = android-tools
options = !strip
options = !buildflags
source = git+https://github.com/facebook/fb-adb.git
+ source = https://dl.google.com/android/android-sdk_r24.4.1-linux.tgz
sha512sums = SKIP
+ sha512sums = 96fb71d78a8c2833afeba6df617edcd6cc4e37ecd0c3bec38c39e78204ed3c2bd54b138a56086bf5ccd95e372e3c36e72c1550c13df8232ec19537da93049284
source_i686 = android-ndk-r10e-linux-i686.bin::http://dl.google.com/android/ndk/android-ndk-r10e-linux-x86.bin
sha512sums_i686 = 8d66229f6f07d6fba00650a96267c3c4a8308d296d9f13aa359af34ad49f57ba3a02e39f14d2b04609816e5f28ed939e71024043a0f08dc3711895a42e39f771
source_x86_64 = http://dl.google.com/android/ndk/android-ndk-r10e-linux-.bin
diff --git a/.gitignore b/.gitignore
index 75ea71ba7c01..3c1c8ce9db45 100644
--- a/.gitignore
+++ b/.gitignore
@@ -1,4 +1,5 @@
*.pkg.tar.xz
+*.tgz
pkg
src
fb-adb
diff --git a/PKGBUILD b/PKGBUILD
index e35df5187056..ec7a129d0ed0 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,19 +2,20 @@
_pkgname=fb-adb
pkgname=$_pkgname-git
-pkgver=20160421.r337.ae33dc4
+pkgver=20160514.r338.5e970a4
pkgrel=1
pkgdesc='A better shell to use in place of adb when connecting to Android devices'
url='https://github.com/facebook/fb-adb'
license=('GPL3')
arch=('i686' 'x86_64')
depends=('android-tools')
-makedepends=('git' 'vim')
+makedepends=('git' 'vim' 'android-sdk-build-tools')
options=('!strip' '!buildflags')
source=("git+$url.git")
sha512sums=('SKIP')
sha512sums=('SKIP')
_ndkver=10e
+_sdkver=24.4.1
[[ -z "$ANDROID_NDK" ]] && {
source_i686+=("android-ndk-r$_ndkver-linux-i686.bin::http://dl.google.com/android/ndk/android-ndk-r$_ndkver-linux-x86.bin")
@@ -23,15 +24,31 @@ _ndkver=10e
sha512sums_x86_64+=('b2ba10d7757ed7189b4e6dc2ecd38fce0c32dc6701151542b9e225e890faee84dded30dd4e907b0e42473e2a6df8ef4d46f37514edc270a04e1129d9c9e677fa')
}
+[[ -z "$ANDROID_SDK" ]] && {
+ source+=("https://dl.google.com/android/android-sdk_r$_sdkver-linux.tgz")
+ sha512sums+=('96fb71d78a8c2833afeba6df617edcd6cc4e37ecd0c3bec38c39e78204ed3c2bd54b138a56086bf5ccd95e372e3c36e72c1550c13df8232ec19537da93049284')
+}
+
pkgver() {
cd $_pkgname
printf "%s.r%s.%s" "$(git show -s --format=%ci master | sed 's/\ .*//g;s/-//g')" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
}
+prepare() {
+ [[ -z "$ANDROID_SDK" ]] && {
+ cd android-sdk-linux
+ ln -sf /opt/android-sdk/build-tools build-tools
+ printf '%s\n' 'y' | ./tools/android update sdk --no-ui
+ }
+}
+
build() {
[[ -z "$ANDROID_NDK" ]] \
&& export ANDROID_NDK="$srcdir/android-ndk-r$_ndkver"
+ [[ -z "$ANDROID_SDK" ]] \
+ && export ANDROID_SDK="$srcdir/android-sdk-linux"
+
# configure
cd $_pkgname
./autogen.sh