summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorLassebq2023-09-18 22:13:10 +0300
committerLassebq2023-09-18 22:13:10 +0300
commit4461578137bb54c162b10a02a63e6eebf5123472 (patch)
treef85ee4c97c9947e82171dd20c58236285c3c0926
downloadaur-4461578137bb54c162b10a02a63e6eebf5123472.tar.gz
Initial commit
-rw-r--r--.SRCINFO13
-rw-r--r--PKGBUILD17
2 files changed, 30 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..46be82158ad8
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,13 @@
+pkgbase = fbcon-autorotate
+ pkgdesc = Automatically changes screen orientation in framebuffer console based on the state of accelerometer
+ pkgver = 0.1.0
+ pkgrel = 1
+ url = https://github.com/Lassebq/fbcon-autorotate
+ arch = any
+ license = MIT
+ depends = iio-sensor-proxy
+ depends = sed
+ source = fbcon-autorotate.tar.gz::https://github.com/Lassebq/fbcon-autorotate/archive/refs/tags/0.1.0.tar.gz
+ sha256sums = SKIP
+
+pkgname = fbcon-autorotate
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..b1f3d0b038e8
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,17 @@
+# Maintainer: Lassebq <lassebq dot mine at gmail dot com>
+pkgname=fbcon-autorotate
+pkgver=0.1.0
+pkgrel=1
+pkgdesc="Automatically changes screen orientation in framebuffer console based on the state of accelerometer"
+arch=(any)
+url="https://github.com/Lassebq/fbcon-autorotate"
+license=('MIT')
+depends=('iio-sensor-proxy' 'sed')
+source=("$pkgname.tar.gz::https://github.com/Lassebq/fbcon-autorotate/archive/refs/tags/$pkgver.tar.gz")
+sha256sums=('SKIP')
+
+package() {
+ cd "$srcdir/$pkgname-$pkgver"
+ install -Dm755 fbcon-autorotate "$pkgdir/usr/lib/systemd/scripts/fbcon-autorotate"
+ install -Dm644 fbcon-autorotate.service "$pkgdir/usr/lib/systemd/system/fbcon-autorotate.service"
+}