summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorBartłomiej Piotrowski2018-01-06 14:35:56 +0100
committerBartłomiej Piotrowski2018-01-06 14:35:56 +0100
commitdad541ca36c70dc521b4b1808538f73b7ca81aa9 (patch)
tree96b929fb9d4d730763c83e16f51100e4e395969e
downloadaur-dad541ca36c70dc521b4b1808538f73b7ca81aa9.tar.gz
Import from official repositories
-rw-r--r--.SRCINFO12
-rw-r--r--PKGBUILD24
2 files changed, 36 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..253cb7b64c55
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,12 @@
+pkgbase = fbdump
+ pkgdesc = captures the contents of the visible portion of the Linux framebuffer to stdout
+ pkgver = 0.4.2
+ pkgrel = 4
+ url = http://www.rcdrummond.net/fbdump/
+ arch = x86_64
+ license = GPL
+ source = http://www.rcdrummond.net/fbdump/fbdump-0.4.2.tar.gz
+ md5sums = 85ae97c0800a2caf2b04ad7764e3915b
+
+pkgname = fbdump
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..3804a0a0992a
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,24 @@
+# $Id: PKGBUILD 266875 2017-11-15 14:29:11Z foutrelis $
+# Maintainer: Sergej Pupykin <pupykin.s+arch@gmail.com>
+
+pkgname=fbdump
+pkgver=0.4.2
+pkgrel=4
+pkgdesc="captures the contents of the visible portion of the Linux framebuffer to stdout"
+arch=('x86_64')
+url="http://www.rcdrummond.net/fbdump/"
+license=("GPL")
+depends=()
+source=(http://www.rcdrummond.net/$pkgname/$pkgname-$pkgver.tar.gz)
+md5sums=('85ae97c0800a2caf2b04ad7764e3915b')
+
+build() {
+ cd "$srcdir"/$pkgname-$pkgver
+ ./configure --prefix=/usr
+ make
+}
+
+package() {
+ cd "$srcdir"/$pkgname-$pkgver
+ make DESTDIR="$pkgdir" install
+}