summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorEnsar Sarajčić2022-05-20 18:02:45 +0200
committerEnsar Sarajčić2022-05-20 18:02:45 +0200
commit9d4c37c6b5fef6f76fe4c97f1f63ba1fb606b7e1 (patch)
treed3d60a4865666c3aaee8b7864e88f0cb0f77ac8d
downloadaur-9d4c37c6b5fef6f76fe4c97f1f63ba1fb606b7e1.tar.gz
Version 0.3.0
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD35
2 files changed, 49 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..56ab98ffe363
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = fbihtax-bin
+ pkgdesc = CLI tool to help manage tax payments in FBiH (Bosnia and Herzegovina Federation) written in Rust.
+ pkgver = 0.3.0
+ pkgrel = 1
+ url = https://github.com/esensar/fbihtax
+ arch = x86_64
+ license = MIT
+ optdepends = pdftk: PDF output support
+ source = https://github.com/esensar/fbihtax/releases/download/0.3.0/fbihtax-linux.zip
+ source = https://raw.githubusercontent.com/esensar/fbihtax/0.3.0/LICENSE
+ sha256sums = 6ed1ae73cbe32022e5be9ddd4689e9177891de69fcccb9ea4b07e66dc682179f
+ sha256sums = 5ed063358afdef13866ed90f97205d89ff3747869a6c737f5b618e73773404fb
+
+pkgname = fbihtax-bin
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..b475a978d0dd
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,35 @@
+# Maintainer: Ensar Sarajčić <es.enar at gmail dot com>
+#
+pkgname="fbihtax-bin"
+pkgver="0.3.0"
+pkgrel=1
+epoch=
+pkgdesc="CLI tool to help manage tax payments in FBiH (Bosnia and Herzegovina Federation) written in Rust."
+arch=('x86_64')
+url="https://github.com/esensar/fbihtax"
+license=('MIT')
+groups=()
+depends=()
+makedepends=()
+checkdepends=()
+optdepends=("pdftk: PDF output support")
+provides=()
+conflicts=()
+replaces=()
+backup=()
+options=()
+install=
+changelog=
+source=("https://github.com/esensar/fbihtax/releases/download/$pkgver/fbihtax-linux.zip"
+ "https://raw.githubusercontent.com/esensar/fbihtax/$pkgver/LICENSE")
+noextract=()
+sha256sums=('6ed1ae73cbe32022e5be9ddd4689e9177891de69fcccb9ea4b07e66dc682179f'
+ '5ed063358afdef13866ed90f97205d89ff3747869a6c737f5b618e73773404fb')
+validpgpkeys=()
+
+package() {
+ install -Dm644 "$srcdir/LICENSE" "$pkgdir/usr/share/licenses/fbihtax/LICENSE"
+ install -Dm775 "$srcdir/fbihtax" "$pkgdir/usr/bin/fbihtax"
+}
+
+# vim:set ts=4 sw=2 ft=sh et syn=sh ft=sh: