summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJulia2022-04-03 16:43:19 +0200
committerJulia2022-04-03 16:43:19 +0200
commitbb7813301eea4a5cf095d17ff4e9cdf808aa5930 (patch)
treea8682d7596bbad656e09b1522eb43557d3255c47
downloadaur-bb7813301eea4a5cf095d17ff4e9cdf808aa5930.tar.gz
Initial commit
-rw-r--r--.SRCINFO11
-rw-r--r--PKGBUILD26
2 files changed, 37 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..97ded36a985c
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,11 @@
+pkgbase = fbkeyboard
+ pkgdesc = A framebuffer softkeyboard for touchscreen devices
+ pkgver = 0.4
+ pkgrel = 1
+ url = https://github.com/bakonyiferenc/fbkeyboard
+ arch = any
+ license = GPL3
+ source = https://github.com/bakonyiferenc/fbkeyboard/archive/refs/tags/0.4.zip
+ sha256sums = ad05e22d6fc1c74f44e7fb3a2b4578c2650d1a09a012237d444e4e7938a023b5
+
+pkgname = fbkeyboard
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..b41c9419b2d4
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,26 @@
+# This is an example PKGBUILD file. Use this as a start to creating your own,
+# and remove these comments. For more information, see 'man PKGBUILD'.
+# NOTE: Please fill out the license field for your package! If it is unknown,
+# then please put 'unknown'.
+
+# Maintainer: Julia <juliag2 (at) protonmail (dot) com>
+pkgname=fbkeyboard
+pkgver=0.4
+pkgrel=1
+pkgdesc="A framebuffer softkeyboard for touchscreen devices"
+arch=(any)
+url="https://github.com/bakonyiferenc/fbkeyboard"
+license=('GPL3')
+source=("https://github.com/bakonyiferenc/$pkgname/archive/refs/tags/$pkgver.zip")
+sha256sums=("ad05e22d6fc1c74f44e7fb3a2b4578c2650d1a09a012237d444e4e7938a023b5")
+
+build() {
+ cd "$pkgname-$pkgver"
+ make
+}
+
+package() {
+ cd "$pkgname-$pkgver"
+ install -Dm755 "$pkgname" "$pkgdir/usr/bin/$pkgname"
+ install -Dm644 "$pkgname.1" "$pkgdir/usr/share/man/man1/$pkgname.1"
+}