summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authoraksr2015-06-28 08:36:20 +0200
committeraksr2015-06-28 08:36:20 +0200
commit08fcbcfcdb7f2f3a0213ab99c441a51b58f0f2fd (patch)
treeb4425c19cdaa034ff9ee5e84db0931a4951c539e
downloadaur-08fcbcfcdb7f2f3a0213ab99c441a51b58f0f2fd.tar.gz
Start.
-rw-r--r--.SRCINFO36
-rw-r--r--LICENSE25
-rw-r--r--PKGBUILD76
-rw-r--r--config.h54
-rw-r--r--fbpad-256.info6
-rw-r--r--fbpad-git.install9
6 files changed, 206 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..68dc44bfd3db
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,36 @@
+pkgbase = fbpad-git
+ pkgdesc = A small linux framebuffer virtual terminal.
+ pkgver = 0.r250.3d7ca84
+ pkgrel = 3
+ url = http://repo.or.cz/w/fbpad.git
+ install = fbpad-git.install
+ arch = i686
+ arch = x86_64
+ license = custom:BSD
+ makedepends = git
+ makedepends = ft2tf
+ makedepends = ttf-dejavu
+ depends = bash
+ depends = vim
+ depends = mutt
+ provides = fbpad
+ conflicts = fbpad
+ source = fbpad-git::git://repo.or.cz/fbpad.git
+ source = config.h
+ source = fbpad-256.info
+ source = LICENSE
+ md5sums = SKIP
+ md5sums = cdc8e8c4582768dd90b954a143f805d2
+ md5sums = 185b9d6ec1c539213226a3e2509c7ccd
+ md5sums = ec67f29a7dec10f86ef31515ed657a91
+ sha1sums = SKIP
+ sha1sums = 85cbf626883ec0febb714c7226e4de0685985f69
+ sha1sums = dbb816fe37faf0acb4e1a916d7493787c2b647fc
+ sha1sums = 76a535243054e1fdd9caaa46a1571cd381d74353
+ sha256sums = SKIP
+ sha256sums = 10347e990c1fe1316b69c47170a7d7b4e9e53a9cabe1417269da769647a78445
+ sha256sums = fb8ae049aa7d41fb285cbf7aa4487b28014273ebcfceefb4d58fb07018312e9c
+ sha256sums = 0ea8d51c57a3a59ca57428b6fe9b47fdb1fde281fc1b095c9832872e85b09a72
+
+pkgname = fbpad-git
+
diff --git a/LICENSE b/LICENSE
new file mode 100644
index 000000000000..e90e615c0aca
--- /dev/null
+++ b/LICENSE
@@ -0,0 +1,25 @@
+Copyright (c) 2009-2012, Ali Gholami Rudi
+All rights reserved.
+
+Redistribution and use in source and binary forms, with or without
+modification, are permitted provided that the following conditions are met:
+
+ * Redistributions of source code must retain the above copyright notice,
+ this list of conditions and the following disclaimer.
+ * Redistributions in binary form must reproduce the above copyright notice,
+ this list of conditions and the following disclaimer in the documentation
+ and/or other materials provided with the distribution.
+ * The names of its contributors may not be used to endorse or promote
+ products derived from this software without specific prior written
+ permission.
+
+THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS "AS IS" AND
+ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED
+WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE
+DISCLAIMED. IN NO EVENT SHALL THE COPYRIGHT HOLDER OR CONTRIBUTORS BE LIABLE
+FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL, EXEMPLARY, OR CONSEQUENTIAL
+DAMAGES (INCLUDING, BUT NOT LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR
+SERVICES; LOSS OF USE, DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER
+CAUSED AND ON ANY THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY,
+OR TORT (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE
+OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..e2713243be27
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,76 @@
+# Contributor: Sara <sara at archlinux dot us>
+# Maintainer: aksr <aksr at t-com dot me>
+pkgname=fbpad-git
+pkgver=0.r250.3d7ca84
+pkgrel=3
+pkgdesc="A small linux framebuffer virtual terminal."
+arch=('i686' 'x86_64')
+#url="http://litcave.rudi.ir/"
+url="http://repo.or.cz/w/fbpad.git"
+license=('custom:BSD')
+groups=()
+depends=('bash' 'vim' 'mutt')
+makedepends=('git' 'ft2tf' 'ttf-dejavu')
+optdepends=()
+provides=('fbpad')
+conflicts=('fbpad')
+replaces=()
+backup=()
+options=()
+install=$pkgname.install
+source=($pkgname::git://repo.or.cz/fbpad.git
+ 'config.h'
+ 'fbpad-256.info'
+ 'LICENSE')
+noextract=()
+md5sums=('SKIP'
+ 'cdc8e8c4582768dd90b954a143f805d2'
+ '185b9d6ec1c539213226a3e2509c7ccd'
+ 'ec67f29a7dec10f86ef31515ed657a91')
+sha1sums=('SKIP'
+ '85cbf626883ec0febb714c7226e4de0685985f69'
+ 'dbb816fe37faf0acb4e1a916d7493787c2b647fc'
+ '76a535243054e1fdd9caaa46a1571cd381d74353')
+sha256sums=('SKIP'
+ '10347e990c1fe1316b69c47170a7d7b4e9e53a9cabe1417269da769647a78445'
+ 'fb8ae049aa7d41fb285cbf7aa4487b28014273ebcfceefb4d58fb07018312e9c'
+ '0ea8d51c57a3a59ca57428b6fe9b47fdb1fde281fc1b095c9832872e85b09a72')
+
+pkgver() {
+ cd $srcdir/$pkgname
+ printf "0.r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+prepare() {
+ cd $srcdir/$pkgname
+ ## Custom config.h
+ cp $srcdir/config.h config.h
+}
+
+build() {
+ cd $srcdir/$pkgname
+ make
+}
+
+package() {
+ cd $srcdir/$pkgname
+
+ install -Dm755 $srcdir/$pkgname/fbpad $pkgdir/usr/bin/fbpad
+ install -Dm644 $srcdir/$pkgname/README $pkgdir/usr/share/doc/$pkgname/README
+ install -Dm644 $srcdir/LICENSE $pkgdir/usr/share/licenses/$pkgname/LICENSE
+
+ ## Compile terminfo
+ mkdir -p $pkgdir/usr/share/terminfo
+ tic -x -o $pkgdir/usr/share/terminfo $srcdir/fbpad-256.info
+
+ ## Setup fonts
+ ft2tf /usr/share/fonts/TTF/DejaVuSansMono.ttf:6 >$srcdir/font.ttf
+ ft2tf /usr/share/fonts/TTF/DejaVuSansMono-Oblique.ttf:6 >$srcdir/fonti.ttf
+ ft2tf /usr/share/fonts/TTF/DejaVuSansMono-Bold.ttf:6 >$srcdir/fontb.ttf
+
+ ## Install fonts
+ install -Dm644 $srcdir/font.ttf $pkgdir/usr/share/$pkgname/font.ttf
+ install -Dm644 $srcdir/fonti.ttf $pkgdir/usr/share/$pkgname/fonti.ttf
+ install -Dm644 $srcdir/fontb.ttf $pkgdir/usr/share/$pkgname/fontb.ttf
+}
+
diff --git a/config.h b/config.h
new file mode 100644
index 000000000000..6bbd4cf15c0c
--- /dev/null
+++ b/config.h
@@ -0,0 +1,54 @@
+/* list of tags */
+#define TAGS "xnlhtr01uiva-"
+#define TAGS_SAVED ""
+
+/* programs mapped to m-c, m-m, m-e */
+#define SHELL {"bash"}
+#define EDITOR {"vim"}
+#define MAIL {"mutt"}
+
+/* fbval_t should match framebuffer depth */
+typedef unsigned int fbval_t;
+
+/* tinyfont files for regular, italic, and bold fonts */
+#define FR "/usr/share/fbpad-git/font.ttf"
+#define FI "/usr/share/fbpad-git/fonti.ttf"
+#define FB "/usr/share/fbpad-git/fontb.ttf"
+
+/* foreground and background colors */
+#define FGCOLOR 0
+#define BGCOLOR 15
+
+/* where to write the screen shot */
+#define SCRSHOT "/tmp/scr"
+
+/* lock command password; NULL disables locking */
+#define PASS NULL
+
+/* optimized version of fb_val() */
+#define FB_VAL(r, g, b) fb_val((r), (g), (b))
+
+/* black */
+#define COLOR0 0x000000
+#define COLOR8 0x555555
+/* red */
+#define COLOR1 0xaa0000
+#define COLOR9 0xff5555
+/* green */
+#define COLOR2 0x00aa00
+#define COLOR10 0x55ff55
+/* yellow */
+#define COLOR3 0xaa5500
+#define COLOR11 0xffff55
+/* blue */
+#define COLOR4 0x0000aa
+#define COLOR12 0x5555ff
+/* magenta */
+#define COLOR5 0xaa00aa
+#define COLOR13 0xff55ff
+/* cyan */
+#define COLOR6 0x00aaaa
+#define COLOR14 0x55ffff
+/* white */
+#define COLOR7 0xaaaaaa
+#define COLOR15 0xffffff
diff --git a/fbpad-256.info b/fbpad-256.info
new file mode 100644
index 000000000000..11a894792741
--- /dev/null
+++ b/fbpad-256.info
@@ -0,0 +1,6 @@
+fbpad-256,
+ use=linux, U8#0,
+ colors#256,
+ pairs#32767,
+ setab=\E[%?%p1%{8}%<%t4%p1%d%e%p1%{16}%<%t10%p1%{8}%-%d%e48;5;%p1%d%;m,
+ setaf=\E[%?%p1%{8}%<%t3%p1%d%e%p1%{16}%<%t9%p1%{8}%-%d%e38;5;%p1%d%;m,
diff --git a/fbpad-git.install b/fbpad-git.install
new file mode 100644
index 000000000000..499102b15a44
--- /dev/null
+++ b/fbpad-git.install
@@ -0,0 +1,9 @@
+post_install(){
+ echo "==> To use fbpad, read /usr/share/doc/fbpad-git/README."
+ echo "==> Edit config.h in fbpad's PKGBUILD directory and"
+ echo " rebuild package if you want to change settings."
+ echo "==> Add 'export TERM=fbpad-256' to your shell rc for"
+ echo " 256-color support."
+ echo "==> Add 'export NCURSES_NO_UTF8_ACS=1' to your shell rc"
+ echo " if you are using dvtm."
+}