summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authornemesys2022-02-21 10:00:14 -0500
committernemesys2022-02-21 10:00:14 -0500
commit8e3f70fc5fe086cb838db83baaf0b3c47a42f545 (patch)
tree2817604f7605c4f89a1b87b6658633aa630fa5dc
parent8968f430e1a0faba345e01a3d72935d93bb5cc0a (diff)
downloadaur-8e3f70fc5fe086cb838db83baaf0b3c47a42f545.tar.gz
Updated PKGBUILD to refrect changes to switch fprintf with fputs
-rw-r--r--.SRCINFO1
-rw-r--r--PKGBUILD5
2 files changed, 4 insertions, 2 deletions
diff --git a/.SRCINFO b/.SRCINFO
index f29e9cb175bc..2627817ae5e1 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -43,4 +43,3 @@ pkgbase = fbsplash
md5sums = 64cf5c9a86b595733e8f2f428a183419
pkgname = fbsplash
-
diff --git a/PKGBUILD b/PKGBUILD
index b331d55a24ff..a20883822822 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -36,6 +36,9 @@ build() {
# fix fbcondecor_ctl splash type
sed -e 's,fbsplash_lib_init(fbspl_bootup),fbsplash_lib_init(fbspl_undef),' -i src/fbcon_decor_ctl.c
+ # switch fprintf to fputs
+ sed -i '696,696 s/fprintf/fputs/g' src/libfbsplash.c
+
# fix libdir
sed -i "s:/lib/splash/cache:/usr/lib/splash/cache:g" debian/splashutils.dirs
sed -i "s:/lib/splash/tmp:/usr/lib/splash/tmp:g" debian/splashutils.dirs
@@ -56,7 +59,7 @@ build() {
# fix set_event_dev call for initcpio usage (if evdev module is there)
patch -Np2 -i "$srcdir/splash_start_initcpio.patch"
- # patch to fix freetype error when compiling.
+ # patch to fix freetype error when compiling by removing static freetype.
patch -Np1 -i "$srcdir/fbsplash-freetype-fix.patch"
export LIBS="-lbz2"