summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDaichi Shinozaki2015-06-09 18:14:53 +0900
committerDaichi Shinozaki2015-06-09 18:14:53 +0900
commit23186d7dce0c182de0841235e23d500b221c864e (patch)
treeeb39497da908c571a6f181ca8e0a0732c0451f88
downloadaur-23186d7dce0c182de0841235e23d500b221c864e.tar.gz
Initial import
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD30
-rw-r--r--fbsplash-theme.install12
3 files changed, 56 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..e64e98735903
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = fbsplash-theme-natural-arch
+ pkgdesc = An fbsplash theme with natural-arch logo
+ pkgver = 1.0.0
+ pkgrel = 3
+ url = http://OpenDesktop.org/content/show.php?content=118457
+ install = fbsplash-theme.install
+ arch = any
+ license = CCPL:cc-by-nc-sa
+ depends = fbsplash
+ source = http://OpenDesktop.org/CONTENT/content-files/118457-natural-arch.tar.gz
+ md5sums = f871f019fc90b63f940af4a23b0bf7d4
+
+pkgname = fbsplash-theme-natural-arch
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..2f811f8bf775
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,30 @@
+# Contributor: Balwinder S "bsd" Dheeman (bdheeman AT gmail.com)
+
+pkgname=fbsplash-theme-natural-arch
+_thmname=${pkgname#fbsplash\-theme\-}
+pkgver=1.0.0
+pkgrel=3
+pkgdesc="An fbsplash theme with natural-arch logo"
+arch=(any)
+license=('CCPL:cc-by-nc-sa')
+url='http://OpenDesktop.org/content/show.php?content=118457'
+depends=('fbsplash')
+source=(http://OpenDesktop.org/CONTENT/content-files/118457-natural-arch.tar.gz)
+install=fbsplash-theme.install
+
+package() {
+ if [ -d /etc/fbsplash ]; then
+ _splashdir="fbsplash"
+ else
+ _splashdir="splash"
+ fi
+
+ mkdir -p "${pkgdir}/etc/${_splashdir}"
+ cp -a "${srcdir}/${_thmname}" "${pkgdir}/etc/${_splashdir}/${_thmname}"
+
+ # make install script nice...
+ sed -i "s/add '.*' to/add '${_thmname}' to/" $startdir/$install
+}
+
+# vim:set ts=4 sw=4 et:
+md5sums=('f871f019fc90b63f940af4a23b0bf7d4')
diff --git a/fbsplash-theme.install b/fbsplash-theme.install
new file mode 100644
index 000000000000..f2faf147ddb8
--- /dev/null
+++ b/fbsplash-theme.install
@@ -0,0 +1,12 @@
+post_install() {
+ cat <<-EOT
+>>> To enable, add 'natural-arch' to '/etc/conf.d/fbsplash' file
+>>> and update your initcpio, if you want fbsplash to start early:
+>>>
+>>> sudo /sbin/mkinitcpio -p kernel26-\${KERNEL_EXTENSION}
+EOT
+}
+
+post_upgrade() {
+ post_install
+}