summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorivanp72022-01-17 15:33:36 +0300
committerivanp72022-01-17 15:33:36 +0300
commit645a548b25b25219ca267a8d50f8e8270462ef92 (patch)
treee65db6f4c4e8b5418f906eef7220e7a2c9117aab
parentb8ba83949ff1ff96c6e13f5b1696fcded4e05729 (diff)
downloadaur-645a548b25b25219ca267a8d50f8e8270462ef92.tar.gz
fix(screen_render.cpp): allow background to be any color; improve documentation
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD13
-rw-r--r--color_palette.patch23
-rw-r--r--fbtermrc13
4 files changed, 47 insertions, 18 deletions
diff --git a/.SRCINFO b/.SRCINFO
index e9fa744a3bc4..9f1d837af8d6 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = fbterm
pkgdesc = Framebuffer terminal emulator
pkgver = 1.7_5
- pkgrel = 4
+ pkgrel = 5
url = https://salsa.debian.org/debian/fbterm
arch = x86_64
arch = armv7h
@@ -14,20 +14,20 @@ pkgbase = fbterm
provides = fbterm
conflicts = fbterm
source = http://deb.debian.org/debian/pool/main/f/fbterm/fbterm_1.7.orig.tar.gz
- source = fbconfig.patch
- source = color_palette.patch
- source = fbterm.patch
source = 0001-Fix-build-with-gcc-6.patch
source = fix_ftbfs_crosscompile.patch
source = fix_ftbfs_epoll.patch
+ source = fbconfig.patch
+ source = color_palette.patch
+ source = fbterm.patch
source = fbtermrc
sha256sums = b98d487e84618503887e3996162354c482e24884bad8bf2219b6776372f306ad
- sha256sums = 0d1781e2654d32d5dfd1cbf17680b49aefbb124b7164ca1d70fcf4468563be7c
- sha256sums = 3b83ffe402cdb66f0bf46a05823ec13357cfebb6534d05acf6d1e4a732441cfc
- sha256sums = 5cd1c14c640679a40f8a9d9781c2a5af5db7543c2296cda99f2886aa40468735
sha256sums = 8054410ab97da3df03406543c6a471acf3323b9e5712da6455d7c49cad7489ce
sha256sums = 73f0c87aaa5a74631c167fb765c0340dc28626b00d0a3cd065cebf71acc585f7
sha256sums = 2b5daa2664adf1efb3e478c2f97376c055b1698422524d262fbae2e7a530a323
- sha256sums = 3d4b9fd36444477b8b6320644f30903ac302a765214285cc55bd07dc8f454c1a
+ sha256sums = 0d1781e2654d32d5dfd1cbf17680b49aefbb124b7164ca1d70fcf4468563be7c
+ sha256sums = ad865628f2f6d67c82a5d29b1ec68af37293b9df5f4a6e8fad6b356d08ab368b
+ sha256sums = 5cd1c14c640679a40f8a9d9781c2a5af5db7543c2296cda99f2886aa40468735
+ sha256sums = ccd21f8b66631067393cb74e222aca1935c449be569b95c1008d6c7c76b7d4b6
pkgname = fbterm
diff --git a/PKGBUILD b/PKGBUILD
index f2674341fcaa..e37eb1f08c08 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,7 +4,7 @@ pkgname=fbterm
_gitname=fbterm
_majorver=1.7
pkgver=1.7_5
-pkgrel=4
+pkgrel=5
pkgdesc='Framebuffer terminal emulator'
arch=('x86_64' 'armv7h')
url='https://salsa.debian.org/debian/fbterm'
@@ -14,16 +14,17 @@ makedepends=(autoconf patch)
provides=(fbterm)
conflicts=(fbterm)
source=("http://deb.debian.org/debian/pool/main/f/fbterm/fbterm_1.7.orig.tar.gz"
- 'fbconfig.patch' 'color_palette.patch' 'fbterm.patch' '0001-Fix-build-with-gcc-6.patch' 'fix_ftbfs_crosscompile.patch' 'fix_ftbfs_epoll.patch'
+ '0001-Fix-build-with-gcc-6.patch' 'fix_ftbfs_crosscompile.patch' 'fix_ftbfs_epoll.patch'
+ 'fbconfig.patch' 'color_palette.patch' 'fbterm.patch'
'fbtermrc')
sha256sums=('b98d487e84618503887e3996162354c482e24884bad8bf2219b6776372f306ad'
- '0d1781e2654d32d5dfd1cbf17680b49aefbb124b7164ca1d70fcf4468563be7c'
- '3b83ffe402cdb66f0bf46a05823ec13357cfebb6534d05acf6d1e4a732441cfc'
- '5cd1c14c640679a40f8a9d9781c2a5af5db7543c2296cda99f2886aa40468735'
'8054410ab97da3df03406543c6a471acf3323b9e5712da6455d7c49cad7489ce'
'73f0c87aaa5a74631c167fb765c0340dc28626b00d0a3cd065cebf71acc585f7'
'2b5daa2664adf1efb3e478c2f97376c055b1698422524d262fbae2e7a530a323'
- '3d4b9fd36444477b8b6320644f30903ac302a765214285cc55bd07dc8f454c1a')
+ '0d1781e2654d32d5dfd1cbf17680b49aefbb124b7164ca1d70fcf4468563be7c'
+ 'ad865628f2f6d67c82a5d29b1ec68af37293b9df5f4a6e8fad6b356d08ab368b'
+ '5cd1c14c640679a40f8a9d9781c2a5af5db7543c2296cda99f2886aa40468735'
+ 'ccd21f8b66631067393cb74e222aca1935c449be569b95c1008d6c7c76b7d4b6')
prepare() {
cd $srcdir/$_gitname-$_majorver
diff --git a/color_palette.patch b/color_palette.patch
index e417c75de254..efc7eefe7eab 100644
--- a/color_palette.patch
+++ b/color_palette.patch
@@ -1,3 +1,14 @@
+--- a/src/screen_render.cpp
++++ b/src/screen_render.cpp
+@@ -78,7 +78,7 @@ void Screen::initFillDraw()
+
+ u32 color = 0;
+ Config::instance()->getOption("color-background", color);
+- if (color > 7) color = 0;
++ if (color >= NR_COLORS) color = 0;
+ bgcolor = color;
+
+ u32 size = mBytesPerLine * ((mRotateType == Rotate0 || mRotateType == Rotate180) ? mHeight : mWidth);
--- a/src/fbshell.h 2010-10-18 11:20:11.000000000 +0300
+++ b/src/fbshell.h 2021-11-27 23:48:54.286721768 +0300
@@ -58,6 +58,7 @@ class FbShell : public Shell {
@@ -77,3 +88,15 @@
+NoTouch:;
+ }
+}
+--- a/doc/fbterm.1.in 2010-10-18 11:20:11.000000000 +0300
++++ b/doc/fbterm.1.in 2021-11-27 23:11:43.270223092 +0300
+@@ -176,6 +176,9 @@
+
+ A new terminfo database entry named "fbterm" was added to use these private sequences, all program based on terminfo should work with it.
+ By default, FbTerm sets environment variable "TERM" to value "linux", user need run "TERM=fbterm /path/to/program" to enable 256 color mode.
++
++The palette colors may be changed in the configuration using options "\fIcolor-num\fR=RRGGBB", where "num" is a color number from 0 to 255.
++
+ .SH "INPUT METHOD"
+ Instead of adding input method directly in FbTerm, a client-server based input method framework is designed to do
+ this work. FbTerm acts as a client, standalone IM program as a server, and they run in separated processes.
diff --git a/fbtermrc b/fbtermrc
index d26db3539e0a..f2ef3201a9cd 100644
--- a/fbtermrc
+++ b/fbtermrc
@@ -14,10 +14,11 @@ font-size=12
#font-width=
#font-height=
-# default color of foreground/background text
-# available colors: 0 = black, 1 = red, 2 = green, 3 = brown, 4 = blue, 5 = magenta, 6 = cyan, 7 = white
-color-foreground=7
-color-background=0
+# terminal palette consists of 256 colors (0-255)
+# 0 = black, 1 = red, 2 = green, 3 = brown, 4 = blue, 5 = magenta, 6 = cyan, 7 = white
+# 8-15 are brighter versions of 0-7
+# 16-231 is 6x6x6 color cube
+# 232-255 is grayscale
color-0=000000
color-1=AA0000
color-2=00AA00
@@ -35,6 +36,10 @@ color-13=FF55FF
color-14=55FFFF
color-15=FFFFFF
+# default foreground/background colors (chosen from palette)
+color-foreground=7
+color-background=0
+
# max scroll-back history lines of every window, value must be [0 - 65535], 0 means disable it
history-lines=0