summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAleksandar Trifunovic2018-09-28 14:28:17 +0200
committerAleksandar Trifunovic2018-09-28 14:28:17 +0200
commita65671ce5f18e20e65b8e7fd68ee14fce34c2221 (patch)
tree44745157cd2d913baf42945bda593c9fd32e906a
parent9cee52bcfc4c8e867669e90b33582eb024b409a5 (diff)
downloadaur-a65671ce5f18e20e65b8e7fd68ee14fce34c2221.tar.gz
repackage and bump to 2018.09.24.00
-rw-r--r--.SRCINFO22
-rw-r--r--PKGBUILD51
2 files changed, 36 insertions, 37 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 11a442298420..13e9dd9e8e35 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,26 +1,26 @@
-# Generated by mksrcinfo v8
-# Mon Mar 27 09:31:20 UTC 2017
pkgbase = fbthrift
- pkgdesc = Facebook's branch of Apache Thrift, including a new C++ server
- pkgver = 2017.03.20.00
- pkgrel = 2
+ pkgdesc = Facebook's branch of Apache Thrift, including a new C++ server.
+ pkgver = 2018.09.24.00
+ pkgrel = 1
url = https://github.com/facebook/fbthrift
arch = i686
arch = x86_64
license = Apache
- makedepends = scons
+ makedepends = cmake
makedepends = zstd
makedepends = libunwind
depends = folly
depends = krb5
depends = numactl
- depends = python2
+ depends = gflags
+ depends = google-glog
+ depends = mstch
+ depends = fizz
+ depends = wangle
provides = thrift
conflicts = thrift
- options = !emptydirs
- options = staticlibs
- source = https://github.com/facebook/fbthrift/archive/v2017.03.20.00.tar.gz
- md5sums = eb8b04def043e4b897e5ce1617695486
+ source = https://github.com/facebook/fbthrift/archive/v2018.09.24.00.tar.gz
+ sha256sums = f5964d4860b83bd3809cf06b4b3b129acddcf8ee13c3c805b6f44c907c3e85e8
pkgname = fbthrift
diff --git a/PKGBUILD b/PKGBUILD
index c68fde72df25..b09afcfb2b5d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,45 +1,44 @@
+# Maintainer: Aleksandar Trifunović <akstrfn at gmail dot com>
# Maintainer: Daichi Shinozaki <dsdseg@gmail.com>
+
pkgname=fbthrift
-pkgver=2017.03.20.00
-pkgrel=2
-pkgdesc="Facebook's branch of Apache Thrift, including a new C++ server"
+pkgver=2018.09.24.00
+pkgrel=1
+pkgdesc="Facebook's branch of Apache Thrift, including a new C++ server."
arch=('i686' 'x86_64')
url="https://github.com/facebook/fbthrift"
license=('Apache')
-depends=('folly' 'krb5' 'numactl' 'python2')
+depends=('folly' 'krb5' 'numactl' 'gflags' 'google-glog' 'mstch' 'fizz' 'wangle')
conflicts=('thrift')
provides=('thrift')
-makedepends=('scons' 'zstd' 'libunwind')
-options=('!emptydirs' 'staticlibs')
-source=("https://github.com/facebook/$pkgname/archive/v${pkgver}.tar.gz")
-md5sums=('eb8b04def043e4b897e5ce1617695486')
+makedepends=('cmake' 'zstd' 'libunwind')
+source=("$url/archive/v${pkgver}.tar.gz")
+sha256sums=('f5964d4860b83bd3809cf06b4b3b129acddcf8ee13c3c805b6f44c907c3e85e8')
prepare() {
- cd "$pkgname-$pkgver/thrift"
- sed -ie '1 s/python/python2/' ./compiler/py/main.py
- # ArchLinux system has both libboost_python.so and libboost3_python.so.
- # Use python2 for build, so prevent libboost3_python.so to be chosen
- sed -i -e 's/libboost_python\*.so\*/libboost_python.so\*/' ./m4/ax_boost_python.m4
- autoreconf -ivf
+ cd "$pkgname-$pkgver"
+ cmake -H. -B_build \
+ -DCMAKE_C_FLAGS:STRING="${CFLAGS}" \
+ -DCMAKE_CXX_FLAGS:STRING="${CXXFLAGS}" \
+ -DCMAKE_EXE_LINKER_FLAGS:STRING="${LDFLAGS}" \
+ -DCMAKE_INSTALL_PREFIX=/usr \
+ -DCMAKE_BUILD_TYPE=Release
}
build() {
- cd "$pkgname-$pkgver/thrift"
- PYTHON=/usr/bin/python2 ./configure --prefix=/usr
- sed --in-place -e 's/python\( -mthrift_compiler.main\)/python2 \1/g' ./lib/cpp2/Makefile
- make
+ cd "$pkgname-$pkgver"
+ cmake --build _build
}
-#check() {
-# cd "$pkgname-$pkgver/thrift"
-# make check
-#}
+# check() {
+# cd "$pkgname-$pkgver"
+# cmake --build _build -- test
+# }
package() {
- cd "$pkgname-$pkgver/thrift"
- make \
+ cd "$pkgname-$pkgver"
+ cmake --build _build -- \
PY_INSTALL_HOME="$pkgdir/usr" \
PY_INSTALL_ARGS="--root '${pkgdir}' --prefix=/usr" \
- DESTDIR="$pkgdir" \
- install
+ DESTDIR="$pkgdir" install
}