summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorYuxin Wu2016-05-01 03:40:22 -0400
committerYuxin Wu2016-05-01 03:40:22 -0400
commitc9953aaccf4bb9f93ece1a0abe391d3fb83ae009 (patch)
tree6cbd82d9817995b77274cfb48874461261cd57f1
downloadaur-c9953aaccf4bb9f93ece1a0abe391d3fb83ae009.tar.gz
initial
-rw-r--r--.SRCINFO26
-rw-r--r--PKGBUILD44
2 files changed, 70 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..8f02ab18017b
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,26 @@
+pkgbase = fbthrift-git
+ pkgdesc = Facebook branch of Apache Thrift, including a new C++ server.
+ pkgver = 0.31.0.r463.g8b8b6fb
+ pkgrel = 1
+ url = https://github.com/facebook/fbthrift
+ arch = i686
+ arch = x86_64
+ license = Apache
+ makedepends = git
+ makedepends = scons
+ makedepends = cmake
+ depends = wangle-git
+ depends = folly-git
+ depends = numactl
+ depends = krb5
+ depends = python2
+ provides = fbthrift
+ provides = thrift
+ conflicts = fbthrift
+ conflicts = thrift
+ replaces = fbthrift
+ source = git+https://github.com/facebook/fbthrift.git
+ md5sums = SKIP
+
+pkgname = fbthrift-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..075a853a9ab0
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,44 @@
+# Maintainer: Anatol Pomozov <anatol.pomozov@gmail.com>
+# Contributor: Joel Teichroeb <joel@teichroeb.net>
+# Contributor: Jonas Heinrich <onny@project-insanity.org>
+
+pkgname=fbthrift-git
+pkgver=0.31.0.r463.g8b8b6fb
+pkgrel=1
+pkgdesc='Facebook branch of Apache Thrift, including a new C++ server.'
+arch=(i686 x86_64)
+url='https://github.com/facebook/fbthrift'
+license=(Apache)
+conflicts=(fbthrift thrift)
+provides=(fbthrift thrift)
+replaces=(fbthrift)
+depends=(wangle-git folly-git numactl krb5 python2)
+makedepends=(git scons cmake)
+source=(git+https://github.com/facebook/fbthrift.git)
+md5sums=(SKIP)
+
+pkgver() {
+ cd fbthrift/thrift
+ git describe --long --tags | sed 's/^v//;s/\([^-]*-g\)/r\1/;s/-/./g'
+}
+
+prepare() {
+ cd fbthrift/thrift
+ # fix python2/python3 compatibility issues
+ sed -i 's/env python /env python2 /' compiler/py/main.py
+ sed -i 's/libboost_python\*/libboost_python/g' m4/ax_boost_python.m4
+}
+
+build() {
+ cd fbthrift/thrift
+ autoreconf -ivf
+ # it builds to /lib by default, however we use /usr/lib
+ PY_PREFIX="$pkgdir/usr" PYTHON=/usr/bin/python2 ./configure --prefix=/usr
+ make
+}
+
+package() {
+ cd fbthrift/thrift
+ make DESTDIR="$pkgdir" install
+}
+