summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDawit Abate2023-10-19 05:57:02 +0300
committerDawit Abate2023-10-19 05:57:02 +0300
commit6f9755da24abd2871e11de2893282e08555e7848 (patch)
treeba1a6c67543b911ec96b7e102597eb204e4904fc
parentd7b53d91443023135e5b99683ddbcad479f0ded8 (diff)
downloadaur-6f9755da24abd2871e11de2893282e08555e7848.tar.gz
Initial commit
-rw-r--r--.SRCINFO47
-rw-r--r--.gitignore4
-rwxr-xr-xPKGBUILD50
-rw-r--r--fcast-receiver.desktop9
-rw-r--r--install.sh78
-rwxr-xr-xtest.sh1
6 files changed, 85 insertions, 104 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 6cdebff70562..b051fee6c518 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,12 +1,41 @@
-pkgbase = pkgbase
- pkgdesc = osfetch-sh is a stupid system fetch program written in bash for linux. (git version)
- pkgver = r17.ec5682d
+pkgbase = fcast-receiver-bin
+ pkgdesc = Binary releases of Fcast
+ pkgver = 23.0.0
pkgrel = 1
- url = https://github.com/mzakyr12/osfetch-sh
- arch = any
+ url = https://gitlab.futo.org/videostreaming/fcast
+ arch = x86_64
license = MIT
- makedepends = git
- source = git+https://github.com/mzakyr12/osfetch-sh.git
- sha512sums = SKIP
+ depends = nss
+ depends = alsa-lib
+ depends = libxext
+ depends = dbus
+ depends = expat
+ depends = libxcb
+ depends = libxrandr
+ depends = nspr
+ depends = at-spi2-core
+ depends = pango
+ depends = glibc
+ depends = libxkbcommon
+ depends = libx11
+ depends = libxcomposite
+ depends = mesa
+ depends = cairo
+ depends = glib2
+ depends = libdrm
+ depends = gcc-libs
+ depends = libxdamage
+ depends = libcups
+ depends = libxfixes
+ depends = gtk3
+ provides = fcast-receiver
+ conflicts = fcast-receiver-bin
+ conflicts = fcast-receiver-git
+ conflicts = fcast-receiver
+ noextract = fcast-receiver-bin-23.0.0.zip
+ source = fcast-receiver-bin-23.0.0.zip::https://releases.grayjay.app/fcastreceiver/fcast-receiver-linux-x64.zip
+ source = fcast-receiver.desktop
+ md5sums = 0b0aef8b4f50c0f1d2a104e699471452
+ md5sums = 787f5a72d47c0b654f08204bf6c495e2
-pkgname = osfetch-sh-git
+pkgname = fcast-receiver-bin
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..c190c4dcdc7c
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+pkg/
+src/
+*.zip
+*.pkg.tar.zst
diff --git a/PKGBUILD b/PKGBUILD
index dd43af1a90c8..c559be3f01dc 100755
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,21 +1,39 @@
-# Maintainer: MisconceivedSec (@misconceivedsec)
-pkgname=salawat
-pkgver=1.3.0
+# Maintainer: Dawit Abate <dawitabate2@gmail.com>
+pkgname=fcast-receiver-bin
+pkgver=23.0.0
pkgrel=1
-pkgdesc="A prayer times (Adhan) app for Windows and GNU/Linux written in JavaFX"
+pkgdesc="Binary releases of Fcast"
arch=('x86_64')
-conflicts=("salawat-appimage" "salawat")
-provides=("salawat")
-url="https://github.com/DBChoco/Salawat"
+conflicts=("fcast-receiver-bin" "fcast-receiver-git" "fcast-receiver")
+provides=("fcast-receiver")
+url="https://gitlab.futo.org/videostreaming/fcast"
license=('MIT')
-depends=('zstd' 'gtk3' 'alsa-lib' 'nss')
-source=("Salawat-$pkgver-linux.tar.gz::https://github.com/DBChoco/Salawat/releases/download/v$pkgver/Salawat-$pkgver-linux.tar.gz")
-md5sums=('c623351938306b5c437aa1d680004dab')
+depends=('nss' 'alsa-lib' 'libxext' 'dbus' 'expat' 'libxcb' 'libxrandr' 'nspr' 'at-spi2-core' 'pango' 'glibc' 'libxkbcommon' 'libx11' 'libxcomposite' 'mesa' 'cairo' 'glib2' 'libdrm' 'gcc-libs' 'libxdamage' 'libcups' 'libxfixes' 'gtk3')
+source=("${pkgname}-${pkgver}.zip::https://releases.grayjay.app/fcastreceiver/fcast-receiver-linux-x64.zip"
+ 'fcast-receiver.desktop')
+md5sums=('0b0aef8b4f50c0f1d2a104e699471452'
+ '787f5a72d47c0b654f08204bf6c495e2')
-package()
-{
- mkdir -p "${pkgdir}/opt" "${pkgdir}/usr/share/applications"
- cp -r "${srcdir}/Salawat" "${pkgdir}/opt/"
- sed -i "s/Salawat.png/icon.png/" "${srcdir}/Salawat/Salawat.desktop"
- install -Dm755 "${srcdir}/Salawat/Salawat.desktop" "${pkgdir}/usr/share/applications/salawat.desktop"
+pkgver() {
+ cat "${srcdir}/${pkgname}/version"
+}
+
+noextract=(
+ "${pkgname}-${pkgver}.zip"
+)
+
+prepare() {
+ mkdir -p "${srcdir}/${pkgname}"
+ bsdtar -xf "${srcdir}/${pkgname}-${pkgver}.zip" -C "${srcdir}/${pkgname}"
+}
+
+package() {
+ cd "${srcdir}/${pkgname}"
+ install -d "${pkgdir}/opt/${pkgname}/" "${pkgdir}/usr/bin"
+ cp -r * "${pkgdir}/opt/${pkgname}/"
+ chmod +x "${pkgdir}/opt/${pkgname}/fcast-receiver"
+ ln -s "/opt/${pkgname}/fcast-receiver" "${pkgdir}/usr/bin/fcast-receiver"
+ install -Dm644 "resources/app/dist/app.png" "${pkgdir}/usr/share/pixmaps/fcast-receiver.png"
+ install -Dm644 "${srcdir}/fcast-receiver.desktop" "${pkgdir}/usr/share/applications/fcast-receiver.desktop"
+ install -Dm644 "LICENSE" "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
}
diff --git a/fcast-receiver.desktop b/fcast-receiver.desktop
new file mode 100644
index 000000000000..6bed79bc5ebd
--- /dev/null
+++ b/fcast-receiver.desktop
@@ -0,0 +1,9 @@
+[Desktop Entry]
+Name=Fcast Receiver
+GenericName=Fcast Receiver
+Icon=fcast-receiver
+Comment=An open source protocol that enables wireless streaming of audio and video content between devices, supporting various stream types such as DASH, HLS, and mp4.
+Exec=fcast-receiver %u
+Terminal=false
+Type=Application
+Categories=Network;Application;AudioVideo;Audio;Video
diff --git a/install.sh b/install.sh
deleted file mode 100644
index ddc8827df6df..000000000000
--- a/install.sh
+++ /dev/null
@@ -1,78 +0,0 @@
-basename=slk-eng
-pkgname=dict-freedict-$basename
-dictd_conf=/etc/dict/dictd.conf
-datadir=/usr/share/dictd
-conf="database $basename {
- data $datadir/$basename.dict.dz
- index $datadir/$basename.index
-}"
-
-post_install()
-{
- echo
- if pacman -Qq dictd > /dev/null 2>&1
- then
- if grep -q "^database *$basename" "$dictd_conf"
- then
- echo "$pkgname already configured in $dictd_conf"
- else
- echo "Adding configuration for $pkgname to $dictd_conf"
- echo "$conf" >> "$dictd_conf"
- fi
-
- if systemctl -q is-active dictd.service
- then
- echo "Restarting dictd service in order to" \
- "use the new dictionary database"
- systemctl restart dictd.service
- else
- echo "Starting dictd service in order to" \
- "use the new dictionary database"
- systemctl start dictd.service
- fi
- else
- echo "dictd does not appear to be installed."
- echo "In order to use this database you should either" \
- "install dictd or alternatively" \
- "another dict server and configure it on your own."
- fi
- echo
-}
-
-post_upgrade()
-{
- if pacman -Qq dictd > /dev/null 2>&1 && \
- systemctl -q is-active dictd.service
- then
- echo -e "\nRestarting dictd service in order to" \
- "use the updated dictionary database"
- systemctl restart dictd.service
- fi
-}
-
-post_remove()
-{
- if pacman -Qq dictd > /dev/null 2>&1
- then
- current_conf="$(grep -A 3 "^database *$basename" "$dictd_conf")"
- if test -n "$current_conf"
- then
- echo
- if test "$current_conf" = "$conf"
- then
- echo "Removing configuration for $pkgname from $dictd_conf"
- sed -i "/database $basename {/,/}/d" "$dictd_conf"
- else
- echo "User created / modified configuration" \
- "for $pkgname in $dictd_conf is left untouched."
- fi
- fi
-
- if systemctl -q is-active dictd.service
- then
- echo "Restarting dictd service in order to" \
- "stop using the removed dictionary database"
- systemctl restart dictd.service
- fi
- fi
-}
diff --git a/test.sh b/test.sh
deleted file mode 100755
index 36f0670f54d0..000000000000
--- a/test.sh
+++ /dev/null
@@ -1 +0,0 @@
-echo 'test'