summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDaniel M. Capella2018-08-02 04:47:23 -0400
committerDaniel M. Capella2018-08-02 05:00:10 -0400
commit8e8e1141cff7a16d0ea860e7572059ac4cf621fb (patch)
treed4834036fe0004322700c53001bc2939412625fe
downloadaur-8e8e1141cff7a16d0ea860e7572059ac4cf621fb.tar.gz
Initial commit
-rw-r--r--.SRCINFO19
-rw-r--r--PKGBUILD33
2 files changed, 52 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..264ac9f0ce84
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+# Generated by mksrcinfo v8
+# Thu Aug 2 08:50:32 UTC 2018
+pkgbase = fcat-git
+ pkgdesc = cat implementation in Rust using Linux' splice syscall
+ pkgver = r15.8a6af01
+ pkgrel = 1
+ url = https://github.com/mre/fcat
+ arch = x86_64
+ license = Apache
+ license = MIT
+ makedepends = rust
+ depends = gcc-libs
+ provides = fcat
+ conflicts = fcat
+ source = git+https://github.com/mre/fcat.git
+ sha512sums = SKIP
+
+pkgname = fcat-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..3f61bcac4db8
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,33 @@
+# Maintainer: Daniel M. Capella <polycitizen@gmail.com>
+
+pkgname=fcat-git
+pkgver=r15.8a6af01
+pkgrel=1
+pkgdesc="cat implementation in Rust using Linux' splice syscall"
+arch=('x86_64')
+url=https://github.com/mre/fcat
+license=('Apache' 'MIT')
+depends=('gcc-libs')
+makedepends=('rust')
+provides=('fcat')
+conflicts=('fcat')
+source=("git+$url.git")
+sha512sums=('SKIP')
+
+pkgver() {
+ cd fcat
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+build() {
+ cd fcat
+ cargo build --release
+}
+
+package() {
+ cd fcat
+ install -Dm644 LICENSE-MIT "$pkgdir"/usr/share/licenses/fcat-git/LICENSE-MIT
+ install -Dm755 target/release/fcat "$pkgdir"/usr/bin/fcat
+}
+
+# vim:set ts=2 sw=2 et: