summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authormjbudd772021-01-20 23:03:36 -0500
committermjbudd772021-01-20 23:03:36 -0500
commit24784c90e9ffde399ecae14b423abef0066906ad (patch)
tree1addeb2cc8042e42e154b19e68d1c7835906e517
parente877de7aa3c65de2fb307d6543669dc5536acd25 (diff)
downloadaur-24784c90e9ffde399ecae14b423abef0066906ad.tar.gz
Updated package dependencies to reflect new Qt5/SDL2 GUI. Minor changes
to the build and install.
-rw-r--r--PKGBUILD20
1 files changed, 10 insertions, 10 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 83cbdf8f0ac1..1a3fc2ec5f6a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,14 +1,14 @@
# Maintainer: Lukas Sabota <LTsmooth42 _at_ gmail _dot_ com>
pkgname=fceux-git
-pkgver=2.2.3.1633.gf333a62d
+pkgver=2.3.0.17.gc6752c41
pkgrel=1
pkgdesc="Fast and ultra-compatible NES/Famicom emulator with SDL, OpenGL and SVGALIB support"
arch=('i686' 'x86_64')
url="http://fceux.com/"
license=('GPL')
-depends=('sdl' 'lua51' 'gtk2' 'gd' 'libgl')
-makedepends=('git' 'cmake' 'libgl' 'glu')
+depends=('sdl2' 'lua51' 'qt5-base' 'minizip')
+makedepends=('git' 'cmake' 'make' 'mesa-libgl' 'glu')
optdepends=('xchm: for viewing the help manual')
provides=('fceux')
conflicts=('fceux')
@@ -17,7 +17,7 @@ md5sums=('SKIP')
pkgver() {
cd fceux
- git describe --always| sed 's/-/./g' | sed 's/fceux.//'
+ git describe --tags --always | sed 's/-/./g' | sed 's/fceux.//'
}
@@ -25,15 +25,15 @@ build() {
cd fceux
mkdir -p build
cd build
- cmake ../
+ cmake \
+ -DCMAKE_INSTALL_PREFIX=/usr \
+ -DCMAKE_C_FLAGS="$CFLAGS -fPIC -w" \
+ -DCMAKE_CXX_FLAGS="$CXXFLAGS -fPIC -w" \
+ ..
make
}
package() {
cd fceux
-
- install -D -m755 build/src/fceux "$pkgdir/usr/bin/fceux"
- install -D -m644 output/fceux.chm "$pkgdir/usr/share/doc/fceux/fceux.chm"
- install -D -m644 "fceux.desktop" "$pkgdir/usr/share/applications/fceux.desktop"
- install -D -m644 "fceux.png" "$pkgdir/usr/share/pixmaps/fceux.png"
+ DESTDIR="$pkgdir" make -C build install
}