summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMoritz Kaspar Rudert (mortzu)2015-05-21 14:42:58 +0200
committerMoritz Kaspar Rudert (mortzu)2015-05-21 14:42:58 +0200
commit3251a09482d8491e49ed7798bfb96cd2472607d2 (patch)
treee7b57b6ed24de04cb2ca746afb97cdb03e882361
downloadaur-3251a09482d8491e49ed7798bfb96cd2472607d2.tar.gz
initial commit
-rw-r--r--.SRCINFO13
-rw-r--r--PKGBUILD29
2 files changed, 42 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..22015ba88047
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,13 @@
+pkgbase = fcgi-cgi
+ pkgdesc = FastCGI application to run cgi applications
+ pkgver = 0.2.2.r0.g42b7646
+ pkgrel = 1
+ url = http://cgit.stbuehler.de/gitosis/fcgi-cgi/
+ arch = any
+ license = MIT
+ makedepends = libev
+ source = git://git.lighttpd.net/fcgi-cgi.git
+ md5sums = SKIP
+
+pkgname = fcgi-cgi
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..cca29c382e82
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,29 @@
+pkgname=fcgi-cgi
+pkgver=0.2.2.r0.g42b7646
+pkgrel=1
+pkgdesc="FastCGI application to run cgi applications"
+arch=('any')
+url="http://cgit.stbuehler.de/gitosis/fcgi-cgi/"
+license=('MIT')
+source=('git://git.lighttpd.net/fcgi-cgi.git')
+md5sums=('SKIP')
+makedepends=('libev')
+
+pkgver() {
+ cd "$pkgname"
+ git describe --long | sed -r 's/^fcgi-cgi-//;s/([^-]*-g)/r\1/;s/-/./g'
+}
+
+build() {
+ cd "$pkgname"
+ ./autogen.sh
+ ./configure --prefix=/usr
+ make
+}
+
+package() {
+ cd "$pkgname"
+ make DESTDIR="$pkgdir" install
+}
+
+# vim:set ts=2 sw=2 et: