summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorNocifer2022-12-30 17:59:00 +0200
committerNocifer2022-12-30 17:59:00 +0200
commit4fcd2a86484d3593c68c864039fdf5a09929403f (patch)
treeb747e167985de051838685e5afa9362bdcf1a639
parent0b5159ff6b523579880c8ad3a278c49ba133e01a (diff)
downloadaur-4fcd2a86484d3593c68c864039fdf5a09929403f.tar.gz
v=2.28.4960.102,r=1
-rw-r--r--.SRCINFO12
-rw-r--r--PKGBUILD12
-rw-r--r--fcitx.patch62
3 files changed, 43 insertions, 43 deletions
diff --git a/.SRCINFO b/.SRCINFO
index a1e467f5533b..f7c9637762b1 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = fcitx-mozc-ut
pkgdesc = Mozc module for Fcitx
- pkgver = 2.28.4950.102
- pkgrel = 2
+ pkgver = 2.28.4960.102
+ pkgrel = 1
url = https://github.com/fcitx/mozc
arch = x86_64
license = Apache
@@ -13,15 +13,15 @@ pkgbase = fcitx-mozc-ut
makedepends = python
makedepends = qt5-base
depends = fcitx
- depends = mozc>=2.28.4950.102
+ depends = mozc>=2.28.4960.102
optdepends = fcitx-configtool
- provides = fcitx-mozc=2.28.4950.102
+ provides = fcitx-mozc=2.28.4960.102
conflicts = fcitx-mozc
options = !distcc
options = !ccache
- source = fcitx-mozc-ut-git::git+https://github.com/google/mozc.git#commit=db37db71b53c9accc9ad66d12ad8196b25c771b3
+ source = fcitx-mozc-ut-git::git+https://github.com/google/mozc.git#commit=7ec82c9356dbd5e15736627cfef05ec0f2c9bb9b
source = fcitx.patch
sha256sums = SKIP
- sha256sums = 0d4b270b9a33918c87b86cff1caa9b7481e98e01defd4af8618bfe18ff5b7cff
+ sha256sums = 64df891e11450a026d08ae32d36d6cb96a04a2b2a6140082868eee6e2f58a41c
pkgname = fcitx-mozc-ut
diff --git a/PKGBUILD b/PKGBUILD
index d83523697de1..230a61c1d7e6 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,22 +4,22 @@
# Contributor: ponsfoot <cabezon dot hashimoto at gmail dot com>
pkgname='fcitx-mozc-ut'
-pkgver=2.28.4950.102
-pkgrel=2
+pkgver=2.28.4960.102
+pkgrel=1
pkgdesc='Mozc module for Fcitx'
arch=('x86_64')
url='https://github.com/fcitx/mozc'
license=('Apache' 'BSD' 'LGPL' 'custom')
-depends=('fcitx' 'mozc>=2.28.4950.102')
+depends=('fcitx' 'mozc>=2.28.4960.102')
makedepends=('bazel' 'git' 'python' 'qt5-base')
optdepends=('fcitx-configtool')
-provides=('fcitx-mozc=2.28.4950.102')
+provides=('fcitx-mozc=2.28.4960.102')
conflicts=('fcitx-mozc')
options=(!distcc !ccache)
-source=("${pkgname}-git::git+https://github.com/google/mozc.git#commit=db37db71b53c9accc9ad66d12ad8196b25c771b3"
+source=("${pkgname}-git::git+https://github.com/google/mozc.git#commit=7ec82c9356dbd5e15736627cfef05ec0f2c9bb9b"
"fcitx.patch")
sha256sums=('SKIP'
- '0d4b270b9a33918c87b86cff1caa9b7481e98e01defd4af8618bfe18ff5b7cff')
+ '64df891e11450a026d08ae32d36d6cb96a04a2b2a6140082868eee6e2f58a41c')
prepare() {
cd ${pkgname}-git/src
diff --git a/fcitx.patch b/fcitx.patch
index 26850d49c7a9..63810f897197 100644
--- a/fcitx.patch
+++ b/fcitx.patch
@@ -1,6 +1,6 @@
diff -ruN google-mozc-git/src/BUILD.fcitx.bazel fcitx-mozc-git/src/BUILD.fcitx.bazel
--- google-mozc-git/src/BUILD.fcitx.bazel 1970-01-01 02:00:00.000000000 +0200
-+++ fcitx-mozc-git/src/BUILD.fcitx.bazel 2022-12-21 09:49:37.641213259 +0200
++++ fcitx-mozc-git/src/BUILD.fcitx.bazel 2022-12-30 15:40:50.400454328 +0200
@@ -0,0 +1,27 @@
+package(
+ default_visibility = ["//visibility:public"],
@@ -31,7 +31,7 @@ diff -ruN google-mozc-git/src/BUILD.fcitx.bazel fcitx-mozc-git/src/BUILD.fcitx.b
+)
diff -ruN google-mozc-git/src/unix/fcitx/BUILD fcitx-mozc-git/src/unix/fcitx/BUILD
--- google-mozc-git/src/unix/fcitx/BUILD 1970-01-01 02:00:00.000000000 +0200
-+++ fcitx-mozc-git/src/unix/fcitx/BUILD 2022-12-21 09:49:37.644546746 +0200
++++ fcitx-mozc-git/src/unix/fcitx/BUILD 2022-12-30 15:40:50.413787897 +0200
@@ -0,0 +1,97 @@
+load(
+ "//:build_defs.bzl",
@@ -132,7 +132,7 @@ diff -ruN google-mozc-git/src/unix/fcitx/BUILD fcitx-mozc-git/src/unix/fcitx/BUI
+
diff -ruN google-mozc-git/src/unix/fcitx/eim.cc fcitx-mozc-git/src/unix/fcitx/eim.cc
--- google-mozc-git/src/unix/fcitx/eim.cc 1970-01-01 02:00:00.000000000 +0200
-+++ fcitx-mozc-git/src/unix/fcitx/eim.cc 2022-12-21 09:49:37.644546746 +0200
++++ fcitx-mozc-git/src/unix/fcitx/eim.cc 2022-12-30 15:40:50.413787897 +0200
@@ -0,0 +1,271 @@
+// Copyright 2012~2013, Weng Xuetian <wengxt@gmail.com>
+// All rights reserved.
@@ -407,7 +407,7 @@ diff -ruN google-mozc-git/src/unix/fcitx/eim.cc fcitx-mozc-git/src/unix/fcitx/ei
+}
diff -ruN google-mozc-git/src/unix/fcitx/fcitx.gyp fcitx-mozc-git/src/unix/fcitx/fcitx.gyp
--- google-mozc-git/src/unix/fcitx/fcitx.gyp 1970-01-01 02:00:00.000000000 +0200
-+++ fcitx-mozc-git/src/unix/fcitx/fcitx.gyp 2022-12-21 09:49:37.644546746 +0200
++++ fcitx-mozc-git/src/unix/fcitx/fcitx.gyp 2022-12-30 15:40:50.413787897 +0200
@@ -0,0 +1,111 @@
+#
+# Copyright (c) 2010-2012 fcitx Project http://code.google.com/p/fcitx/
@@ -522,7 +522,7 @@ diff -ruN google-mozc-git/src/unix/fcitx/fcitx.gyp fcitx-mozc-git/src/unix/fcitx
+}
diff -ruN google-mozc-git/src/unix/fcitx/fcitx_key_event_handler.cc fcitx-mozc-git/src/unix/fcitx/fcitx_key_event_handler.cc
--- google-mozc-git/src/unix/fcitx/fcitx_key_event_handler.cc 1970-01-01 02:00:00.000000000 +0200
-+++ fcitx-mozc-git/src/unix/fcitx/fcitx_key_event_handler.cc 2022-12-21 09:49:37.644546746 +0200
++++ fcitx-mozc-git/src/unix/fcitx/fcitx_key_event_handler.cc 2022-12-30 15:40:50.413787897 +0200
@@ -0,0 +1,243 @@
+// Copyright 2010-2012, Google Inc.
+// Copyright 2012~2013, Weng Xuetian <wengxt@gmail.com>
@@ -769,7 +769,7 @@ diff -ruN google-mozc-git/src/unix/fcitx/fcitx_key_event_handler.cc fcitx-mozc-g
+} // namespace mozc
diff -ruN google-mozc-git/src/unix/fcitx/fcitx_key_event_handler.h fcitx-mozc-git/src/unix/fcitx/fcitx_key_event_handler.h
--- google-mozc-git/src/unix/fcitx/fcitx_key_event_handler.h 1970-01-01 02:00:00.000000000 +0200
-+++ fcitx-mozc-git/src/unix/fcitx/fcitx_key_event_handler.h 2022-12-21 09:49:37.644546746 +0200
++++ fcitx-mozc-git/src/unix/fcitx/fcitx_key_event_handler.h 2022-12-30 15:40:50.413787897 +0200
@@ -0,0 +1,79 @@
+// Copyright 2010-2012, Google Inc.
+// Copyright 2012~2013, Weng Xuetian <wengxt@gmail.com>
@@ -852,7 +852,7 @@ diff -ruN google-mozc-git/src/unix/fcitx/fcitx_key_event_handler.h fcitx-mozc-gi
+#endif // MOZC_UNIX_FCITX_KEY_EVENT_HANDLER_H_
diff -ruN google-mozc-git/src/unix/fcitx/fcitx_key_translator.cc fcitx-mozc-git/src/unix/fcitx/fcitx_key_translator.cc
--- google-mozc-git/src/unix/fcitx/fcitx_key_translator.cc 1970-01-01 02:00:00.000000000 +0200
-+++ fcitx-mozc-git/src/unix/fcitx/fcitx_key_translator.cc 2022-12-21 09:49:37.644546746 +0200
++++ fcitx-mozc-git/src/unix/fcitx/fcitx_key_translator.cc 2022-12-30 15:40:50.413787897 +0200
@@ -0,0 +1,521 @@
+// Copyright 2010-2012, Google Inc.
+// Copyright 2012~2013, Weng Xuetian <wengxt@gmail.com>
@@ -1377,7 +1377,7 @@ diff -ruN google-mozc-git/src/unix/fcitx/fcitx_key_translator.cc fcitx-mozc-git/
+} // namespace mozc
diff -ruN google-mozc-git/src/unix/fcitx/fcitx_key_translator.h fcitx-mozc-git/src/unix/fcitx/fcitx_key_translator.h
--- google-mozc-git/src/unix/fcitx/fcitx_key_translator.h 1970-01-01 02:00:00.000000000 +0200
-+++ fcitx-mozc-git/src/unix/fcitx/fcitx_key_translator.h 2022-12-21 09:49:37.644546746 +0200
++++ fcitx-mozc-git/src/unix/fcitx/fcitx_key_translator.h 2022-12-30 15:40:50.413787897 +0200
@@ -0,0 +1,121 @@
+// Copyright 2010-2012, Google Inc.
+// Copyright 2012~2013, Weng Xuetian <wengxt@gmail.com>
@@ -1502,7 +1502,7 @@ diff -ruN google-mozc-git/src/unix/fcitx/fcitx_key_translator.h fcitx-mozc-git/s
+#endif // MOZC_UNIX_FCITX_FCITX_KEY_TRANSLATOR_H_
diff -ruN google-mozc-git/src/unix/fcitx/fcitx_mozc.cc fcitx-mozc-git/src/unix/fcitx/fcitx_mozc.cc
--- google-mozc-git/src/unix/fcitx/fcitx_mozc.cc 1970-01-01 02:00:00.000000000 +0200
-+++ fcitx-mozc-git/src/unix/fcitx/fcitx_mozc.cc 2022-12-21 09:49:37.644546746 +0200
++++ fcitx-mozc-git/src/unix/fcitx/fcitx_mozc.cc 2022-12-30 15:40:50.413787897 +0200
@@ -0,0 +1,552 @@
+// Copyright 2012~2013, Weng Xuetian <wengxt@gmail.com>
+// All rights reserved.
@@ -2058,7 +2058,7 @@ diff -ruN google-mozc-git/src/unix/fcitx/fcitx_mozc.cc fcitx-mozc-git/src/unix/f
+} // namespace mozc_unix_scim
diff -ruN google-mozc-git/src/unix/fcitx/fcitx-mozc.conf fcitx-mozc-git/src/unix/fcitx/fcitx-mozc.conf
--- google-mozc-git/src/unix/fcitx/fcitx-mozc.conf 1970-01-01 02:00:00.000000000 +0200
-+++ fcitx-mozc-git/src/unix/fcitx/fcitx-mozc.conf 2022-12-21 09:49:37.644546746 +0200
++++ fcitx-mozc-git/src/unix/fcitx/fcitx-mozc.conf 2022-12-30 15:40:50.413787897 +0200
@@ -0,0 +1,11 @@
+[Addon]
+Name=fcitx-mozc
@@ -2073,7 +2073,7 @@ diff -ruN google-mozc-git/src/unix/fcitx/fcitx-mozc.conf fcitx-mozc-git/src/unix
+LoadLocal=True
diff -ruN google-mozc-git/src/unix/fcitx/fcitx_mozc.h fcitx-mozc-git/src/unix/fcitx/fcitx_mozc.h
--- google-mozc-git/src/unix/fcitx/fcitx_mozc.h 1970-01-01 02:00:00.000000000 +0200
-+++ fcitx-mozc-git/src/unix/fcitx/fcitx_mozc.h 2022-12-21 09:49:37.644546746 +0200
++++ fcitx-mozc-git/src/unix/fcitx/fcitx_mozc.h 2022-12-30 15:40:50.413787897 +0200
@@ -0,0 +1,176 @@
+// Copyright 2012~2013, Weng Xuetian <wengxt@gmail.com>
+// All rights reserved.
@@ -2253,7 +2253,7 @@ diff -ruN google-mozc-git/src/unix/fcitx/fcitx_mozc.h fcitx-mozc-git/src/unix/fc
+
diff -ruN google-mozc-git/src/unix/fcitx/gen_fcitx_mozc_i18n.sh fcitx-mozc-git/src/unix/fcitx/gen_fcitx_mozc_i18n.sh
--- google-mozc-git/src/unix/fcitx/gen_fcitx_mozc_i18n.sh 1970-01-01 02:00:00.000000000 +0200
-+++ fcitx-mozc-git/src/unix/fcitx/gen_fcitx_mozc_i18n.sh 2022-12-21 09:49:37.644546746 +0200
++++ fcitx-mozc-git/src/unix/fcitx/gen_fcitx_mozc_i18n.sh 2022-12-30 15:40:50.413787897 +0200
@@ -0,0 +1,10 @@
+#!/bin/sh
+
@@ -2267,7 +2267,7 @@ diff -ruN google-mozc-git/src/unix/fcitx/gen_fcitx_mozc_i18n.sh fcitx-mozc-git/s
+done
diff -ruN google-mozc-git/src/unix/fcitx/mozc.conf fcitx-mozc-git/src/unix/fcitx/mozc.conf
--- google-mozc-git/src/unix/fcitx/mozc.conf 1970-01-01 02:00:00.000000000 +0200
-+++ fcitx-mozc-git/src/unix/fcitx/mozc.conf 2022-12-21 09:49:37.644546746 +0200
++++ fcitx-mozc-git/src/unix/fcitx/mozc.conf 2022-12-30 15:40:50.413787897 +0200
@@ -0,0 +1,7 @@
+[InputMethod]
+UniqueName=mozc
@@ -2278,7 +2278,7 @@ diff -ruN google-mozc-git/src/unix/fcitx/mozc.conf fcitx-mozc-git/src/unix/fcitx
+Parent=fcitx-mozc
diff -ruN google-mozc-git/src/unix/fcitx/mozc_connection.cc fcitx-mozc-git/src/unix/fcitx/mozc_connection.cc
--- google-mozc-git/src/unix/fcitx/mozc_connection.cc 1970-01-01 02:00:00.000000000 +0200
-+++ fcitx-mozc-git/src/unix/fcitx/mozc_connection.cc 2022-12-21 09:49:37.644546746 +0200
++++ fcitx-mozc-git/src/unix/fcitx/mozc_connection.cc 2022-12-30 15:40:50.413787897 +0200
@@ -0,0 +1,214 @@
+// Copyright 2010-2012, Google Inc.
+// Copyright 2012~2013, Weng Xuetian <wengxt@gmail.com>
@@ -2496,7 +2496,7 @@ diff -ruN google-mozc-git/src/unix/fcitx/mozc_connection.cc fcitx-mozc-git/src/u
+} // namespace mozc
diff -ruN google-mozc-git/src/unix/fcitx/mozc_connection.h fcitx-mozc-git/src/unix/fcitx/mozc_connection.h
--- google-mozc-git/src/unix/fcitx/mozc_connection.h 1970-01-01 02:00:00.000000000 +0200
-+++ fcitx-mozc-git/src/unix/fcitx/mozc_connection.h 2022-12-21 09:49:37.644546746 +0200
++++ fcitx-mozc-git/src/unix/fcitx/mozc_connection.h 2022-12-30 15:40:50.413787897 +0200
@@ -0,0 +1,154 @@
+// Copyright 2010-2012, Google Inc.
+// Copyright 2012~2013, Weng Xuetian <wengxt@gmail.com>
@@ -2654,7 +2654,7 @@ diff -ruN google-mozc-git/src/unix/fcitx/mozc_connection.h fcitx-mozc-git/src/un
+#endif // MOZC_UNIX_SCIM_MOZC_CONNECTION_H_
diff -ruN google-mozc-git/src/unix/fcitx/mozc_response_parser.cc fcitx-mozc-git/src/unix/fcitx/mozc_response_parser.cc
--- google-mozc-git/src/unix/fcitx/mozc_response_parser.cc 1970-01-01 02:00:00.000000000 +0200
-+++ fcitx-mozc-git/src/unix/fcitx/mozc_response_parser.cc 2022-12-21 09:49:37.647880232 +0200
++++ fcitx-mozc-git/src/unix/fcitx/mozc_response_parser.cc 2022-12-30 15:40:50.413787897 +0200
@@ -0,0 +1,447 @@
+// Copyright 2010-2012, Google Inc.
+// Copyright 2012~2013, Weng Xuetian <wengxt@gmail.com>
@@ -3105,7 +3105,7 @@ diff -ruN google-mozc-git/src/unix/fcitx/mozc_response_parser.cc fcitx-mozc-git/
+} // namespace mozc
diff -ruN google-mozc-git/src/unix/fcitx/mozc_response_parser.h fcitx-mozc-git/src/unix/fcitx/mozc_response_parser.h
--- google-mozc-git/src/unix/fcitx/mozc_response_parser.h 1970-01-01 02:00:00.000000000 +0200
-+++ fcitx-mozc-git/src/unix/fcitx/mozc_response_parser.h 2022-12-21 09:49:37.647880232 +0200
++++ fcitx-mozc-git/src/unix/fcitx/mozc_response_parser.h 2022-12-30 15:40:50.413787897 +0200
@@ -0,0 +1,97 @@
+// Copyright 2010-2012, Google Inc.
+// Copyright 2012~2013, Weng Xuetian <wengxt@gmail.com>
@@ -3206,7 +3206,7 @@ diff -ruN google-mozc-git/src/unix/fcitx/mozc_response_parser.h fcitx-mozc-git/s
+#endif // MOZC_UNIX_FCITX_MOZC_RESPONSE_PARSER_H_
diff -ruN google-mozc-git/src/unix/fcitx/po/ca.po fcitx-mozc-git/src/unix/fcitx/po/ca.po
--- google-mozc-git/src/unix/fcitx/po/ca.po 1970-01-01 02:00:00.000000000 +0200
-+++ fcitx-mozc-git/src/unix/fcitx/po/ca.po 2022-12-21 09:49:37.647880232 +0200
++++ fcitx-mozc-git/src/unix/fcitx/po/ca.po 2022-12-30 15:40:50.413787897 +0200
@@ -0,0 +1,80 @@
+# SOME DESCRIPTIVE TITLE.
+# Copyright (C) YEAR THE PACKAGE'S COPYRIGHT HOLDER
@@ -3290,7 +3290,7 @@ diff -ruN google-mozc-git/src/unix/fcitx/po/ca.po fcitx-mozc-git/src/unix/fcitx/
+msgstr "Premeu Ctrl+Alt+H per mostrar els usos."
diff -ruN google-mozc-git/src/unix/fcitx/po/da.po fcitx-mozc-git/src/unix/fcitx/po/da.po
--- google-mozc-git/src/unix/fcitx/po/da.po 1970-01-01 02:00:00.000000000 +0200
-+++ fcitx-mozc-git/src/unix/fcitx/po/da.po 2022-12-21 09:49:37.647880232 +0200
++++ fcitx-mozc-git/src/unix/fcitx/po/da.po 2022-12-30 15:40:50.413787897 +0200
@@ -0,0 +1,80 @@
+# SOME DESCRIPTIVE TITLE.
+# Copyright (C) YEAR THE PACKAGE'S COPYRIGHT HOLDER
@@ -3374,7 +3374,7 @@ diff -ruN google-mozc-git/src/unix/fcitx/po/da.po fcitx-mozc-git/src/unix/fcitx/
+msgstr "Tryk på Ctrl+Alt+H for at vise anvendelser."
diff -ruN google-mozc-git/src/unix/fcitx/po/de.po fcitx-mozc-git/src/unix/fcitx/po/de.po
--- google-mozc-git/src/unix/fcitx/po/de.po 1970-01-01 02:00:00.000000000 +0200
-+++ fcitx-mozc-git/src/unix/fcitx/po/de.po 2022-12-21 09:49:37.647880232 +0200
++++ fcitx-mozc-git/src/unix/fcitx/po/de.po 2022-12-30 15:40:50.413787897 +0200
@@ -0,0 +1,86 @@
+# SOME DESCRIPTIVE TITLE.
+# Copyright (C) YEAR THE PACKAGE'S COPYRIGHT HOLDER
@@ -3464,7 +3464,7 @@ diff -ruN google-mozc-git/src/unix/fcitx/po/de.po fcitx-mozc-git/src/unix/fcitx/
+msgstr "Ctrl+Alt+H um die Hilfe anzuzeigen"
diff -ruN google-mozc-git/src/unix/fcitx/po/fcitx-mozc.pot fcitx-mozc-git/src/unix/fcitx/po/fcitx-mozc.pot
--- google-mozc-git/src/unix/fcitx/po/fcitx-mozc.pot 1970-01-01 02:00:00.000000000 +0200
-+++ fcitx-mozc-git/src/unix/fcitx/po/fcitx-mozc.pot 2022-12-21 09:49:37.647880232 +0200
++++ fcitx-mozc-git/src/unix/fcitx/po/fcitx-mozc.pot 2022-12-30 15:40:50.413787897 +0200
@@ -0,0 +1,78 @@
+# SOME DESCRIPTIVE TITLE.
+# Copyright (C) YEAR THE PACKAGE'S COPYRIGHT HOLDER
@@ -3546,7 +3546,7 @@ diff -ruN google-mozc-git/src/unix/fcitx/po/fcitx-mozc.pot fcitx-mozc-git/src/un
+msgstr ""
diff -ruN google-mozc-git/src/unix/fcitx/po/ja.po fcitx-mozc-git/src/unix/fcitx/po/ja.po
--- google-mozc-git/src/unix/fcitx/po/ja.po 1970-01-01 02:00:00.000000000 +0200
-+++ fcitx-mozc-git/src/unix/fcitx/po/ja.po 2022-12-21 09:49:37.647880232 +0200
++++ fcitx-mozc-git/src/unix/fcitx/po/ja.po 2022-12-30 15:40:50.413787897 +0200
@@ -0,0 +1,87 @@
+# SOME DESCRIPTIVE TITLE.
+# Copyright (C) YEAR THE PACKAGE'S COPYRIGHT HOLDER
@@ -3637,7 +3637,7 @@ diff -ruN google-mozc-git/src/unix/fcitx/po/ja.po fcitx-mozc-git/src/unix/fcitx/
+msgstr "Ctrl+Alt+H キーを押して用例を表示"
diff -ruN google-mozc-git/src/unix/fcitx/po/ko.po fcitx-mozc-git/src/unix/fcitx/po/ko.po
--- google-mozc-git/src/unix/fcitx/po/ko.po 1970-01-01 02:00:00.000000000 +0200
-+++ fcitx-mozc-git/src/unix/fcitx/po/ko.po 2022-12-21 09:49:37.647880232 +0200
++++ fcitx-mozc-git/src/unix/fcitx/po/ko.po 2022-12-30 15:40:50.413787897 +0200
@@ -0,0 +1,82 @@
+# SOME DESCRIPTIVE TITLE.
+# Copyright (C) YEAR THE PACKAGE'S COPYRIGHT HOLDER
@@ -3723,7 +3723,7 @@ diff -ruN google-mozc-git/src/unix/fcitx/po/ko.po fcitx-mozc-git/src/unix/fcitx/
+msgstr "사용법을 보려면 Ctrl+Alt+H를 누릅니다."
diff -ruN google-mozc-git/src/unix/fcitx/po/Messages.sh fcitx-mozc-git/src/unix/fcitx/po/Messages.sh
--- google-mozc-git/src/unix/fcitx/po/Messages.sh 1970-01-01 02:00:00.000000000 +0200
-+++ fcitx-mozc-git/src/unix/fcitx/po/Messages.sh 2022-12-21 09:49:37.647880232 +0200
++++ fcitx-mozc-git/src/unix/fcitx/po/Messages.sh 2022-12-30 15:40:50.413787897 +0200
@@ -0,0 +1,33 @@
+#!/bin/sh
+
@@ -3760,7 +3760,7 @@ diff -ruN google-mozc-git/src/unix/fcitx/po/Messages.sh fcitx-mozc-git/src/unix/
+echo "Done"
diff -ruN google-mozc-git/src/unix/fcitx/po/ru.po fcitx-mozc-git/src/unix/fcitx/po/ru.po
--- google-mozc-git/src/unix/fcitx/po/ru.po 1970-01-01 02:00:00.000000000 +0200
-+++ fcitx-mozc-git/src/unix/fcitx/po/ru.po 2022-12-21 09:49:37.647880232 +0200
++++ fcitx-mozc-git/src/unix/fcitx/po/ru.po 2022-12-30 15:40:50.413787897 +0200
@@ -0,0 +1,83 @@
+# SOME DESCRIPTIVE TITLE.
+# Copyright (C) YEAR THE PACKAGE'S COPYRIGHT HOLDER
@@ -3847,7 +3847,7 @@ diff -ruN google-mozc-git/src/unix/fcitx/po/ru.po fcitx-mozc-git/src/unix/fcitx/
+msgstr "Нажмите Ctrl+Alt+H, чтобы показать использование."
diff -ruN google-mozc-git/src/unix/fcitx/po/zh_CN.po fcitx-mozc-git/src/unix/fcitx/po/zh_CN.po
--- google-mozc-git/src/unix/fcitx/po/zh_CN.po 1970-01-01 02:00:00.000000000 +0200
-+++ fcitx-mozc-git/src/unix/fcitx/po/zh_CN.po 2022-12-21 09:49:37.647880232 +0200
++++ fcitx-mozc-git/src/unix/fcitx/po/zh_CN.po 2022-12-30 15:40:50.413787897 +0200
@@ -0,0 +1,85 @@
+# SOME DESCRIPTIVE TITLE.
+# Copyright (C) YEAR THE PACKAGE'S COPYRIGHT HOLDER
@@ -3936,7 +3936,7 @@ diff -ruN google-mozc-git/src/unix/fcitx/po/zh_CN.po fcitx-mozc-git/src/unix/fci
+msgstr "按下 Ctrl+Alt+H 显示用法。"
diff -ruN google-mozc-git/src/unix/fcitx/po/zh_TW.po fcitx-mozc-git/src/unix/fcitx/po/zh_TW.po
--- google-mozc-git/src/unix/fcitx/po/zh_TW.po 1970-01-01 02:00:00.000000000 +0200
-+++ fcitx-mozc-git/src/unix/fcitx/po/zh_TW.po 2022-12-21 09:49:37.647880232 +0200
++++ fcitx-mozc-git/src/unix/fcitx/po/zh_TW.po 2022-12-30 15:40:50.413787897 +0200
@@ -0,0 +1,84 @@
+# SOME DESCRIPTIVE TITLE.
+# Copyright (C) YEAR THE PACKAGE'S COPYRIGHT HOLDER
@@ -4024,7 +4024,7 @@ diff -ruN google-mozc-git/src/unix/fcitx/po/zh_TW.po fcitx-mozc-git/src/unix/fci
+msgstr "按下 Ctrl+Alt+H 顯示用法。"
diff -ruN google-mozc-git/src/unix/fcitx/surrounding_text_util.cc fcitx-mozc-git/src/unix/fcitx/surrounding_text_util.cc
--- google-mozc-git/src/unix/fcitx/surrounding_text_util.cc 1970-01-01 02:00:00.000000000 +0200
-+++ fcitx-mozc-git/src/unix/fcitx/surrounding_text_util.cc 2022-12-21 09:49:37.647880232 +0200
++++ fcitx-mozc-git/src/unix/fcitx/surrounding_text_util.cc 2022-12-30 15:40:50.413787897 +0200
@@ -0,0 +1,243 @@
+// Copyright 2010-2013, Google Inc.
+// All rights reserved.
@@ -4271,7 +4271,7 @@ diff -ruN google-mozc-git/src/unix/fcitx/surrounding_text_util.cc fcitx-mozc-git
+} // namespace mozc
diff -ruN google-mozc-git/src/unix/fcitx/surrounding_text_util.h fcitx-mozc-git/src/unix/fcitx/surrounding_text_util.h
--- google-mozc-git/src/unix/fcitx/surrounding_text_util.h 1970-01-01 02:00:00.000000000 +0200
-+++ fcitx-mozc-git/src/unix/fcitx/surrounding_text_util.h 2022-12-21 09:49:37.647880232 +0200
++++ fcitx-mozc-git/src/unix/fcitx/surrounding_text_util.h 2022-12-30 15:40:50.413787897 +0200
@@ -0,0 +1,87 @@
+// Copyright 2010-2013, Google Inc.
+// All rights reserved.
@@ -4361,8 +4361,8 @@ diff -ruN google-mozc-git/src/unix/fcitx/surrounding_text_util.h fcitx-mozc-git/
+
+#endif // MOZC_UNIX_FCITX_SURROUNDING_TEXT_URIL_H_
diff -ruN google-mozc-git/src/WORKSPACE.bazel fcitx-mozc-git/src/WORKSPACE.bazel
---- google-mozc-git/src/WORKSPACE.bazel 2022-07-24 13:10:07.330855232 +0300
-+++ fcitx-mozc-git/src/WORKSPACE.bazel 2022-07-24 13:10:08.670903443 +0300
+--- google-mozc-git/src/WORKSPACE.bazel 2022-12-30 15:40:48.120413862 +0200
++++ fcitx-mozc-git/src/WORKSPACE.bazel 2022-12-30 15:40:49.630440664 +0200
@@ -67,6 +67,22 @@
packages = ["glib-2.0", "gobject-2.0", "ibus-1.0"],
)