summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorNaoya Inada2020-12-31 02:04:27 +0900
committerNaoya Inada2020-12-31 02:04:27 +0900
commit68208a145afb90b3ba23ed957427ad6c3753418c (patch)
tree7fbbf175017be58d89b3b8c5fc2070523293acb1
parent0954fb619ba9ca5004f43b0780f35529410e281b (diff)
downloadaur-68208a145afb90b3ba23ed957427ad6c3753418c.tar.gz
Update to mozc-2.26.4237.102 and mozc-ut-20201229
-rw-r--r--.SRCINFO31
-rw-r--r--PKGBUILD40
2 files changed, 34 insertions, 37 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 875631c55d0a..c2eaa279a206 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,8 @@
pkgbase = fcitx-mozc-ut
- pkgver = 2.26.4206.102.20201129
+ pkgdesc = Fcitx engine module for Mozc with Mozc UT Dictionary
+ pkgver = 2.26.4237.102.20201229
pkgrel = 1
url = https://osdn.net/users/utuhiro/pf/utuhiro/files/
- arch = i686
arch = x86_64
license = custom
makedepends = clang
@@ -18,29 +18,26 @@ pkgbase = fcitx-mozc-ut
makedepends = glib2
makedepends = bzip2
makedepends = unzip
- source = https://osdn.net/users/utuhiro/pf/utuhiro/dl/mozc-2.26.4206.102.tar.bz2
+ depends = fcitx
+ depends = qt5-base
+ conflicts = fcitx-mozc
+ conflicts = fcitx-mozc-ut2
+ conflicts = fcitx-mozc-neologd-ut
+ conflicts = fcitx-mozc-ut-unified
+ source = https://osdn.net/users/utuhiro/pf/utuhiro/dl/mozc-2.26.4237.102.tar.bz2
source = abseil-cpp-20200923.2.tar.gz::https://github.com/abseil/abseil-cpp/archive/20200923.2.tar.gz
source = googletest-release-1.10.0.tar.gz::https://github.com/google/googletest/archive/release-1.10.0.tar.gz
source = protobuf-3.13.0.tar.gz::https://github.com/protocolbuffers/protobuf/archive/v3.13.0.tar.gz
source = https://osdn.net/users/utuhiro/pf/utuhiro/dl/fcitx-mozc-20201111.patch
- source = https://osdn.net/users/utuhiro/pf/utuhiro/dl/fcitx-mozc-icons.tar.gz
- source = https://osdn.net/users/utuhiro/pf/utuhiro/dl/mozcdic-ut-20201129.1.tar.bz2
- sha1sums = a6bd5f40b623aef4e77c20fdcc208ba7ee75e1ee
+ source = https://osdn.net/users/utuhiro/pf/utuhiro/dl/fcitx-mozc-icons-20201229.tar.gz
+ source = https://osdn.net/users/utuhiro/pf/utuhiro/dl/mozcdic-ut-20201229.1.tar.bz2
+ sha1sums = b0b8fbf69f0d6089a800533a99be747e40faf922
sha1sums = 1dd3f0a937c3678437646d26ca6784bd6a9b2b26
sha1sums = 9c89be7df9c5e8cb0bc20b3c4b39bf7e82686770
sha1sums = 2160cfb354148da3fb3891b267c2edc7e3eb5c30
sha1sums = 38de276494e299dc7e4816dfd95403fd0fdf8601
- sha1sums = e930c580ecd0c9e0cecb57d148122c9122d4859c
- sha1sums = eb6fc52789044238b81596479107239e491c4f25
+ sha1sums = 3d9da92eed88817985e0047daf7a7cc2131a3bb4
+ sha1sums = f248798642153122628b41c62a7329c9be4f8e52
pkgname = fcitx-mozc-ut
- pkgdesc = Fcitx engine module for Mozc with Mozc UT Dictionary
- arch = i686
- arch = x86_64
- depends = mozc-ut=2.26.4206.102.20201129
- depends = fcitx
- conflicts = fcitx-mozc
- conflicts = fcitx-mozc-ut2
- conflicts = fcitx-mozc-neologd-ut
- conflicts = fcitx-mozc-ut-unified
diff --git a/PKGBUILD b/PKGBUILD
index 86c177565dfd..a5031036e6d1 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,22 +3,27 @@
# Contributor: Felix Yan <felixonmars@gmail.com>
# Contributor: ponsfoot <cabezon dot hashimoto at gmail dot com>
-# NOTE: This PKGBUILD is based on https://osdn.net/downloads/users/26/26962/fcitx-mozc-ut-2.26.4206.102.20201129.1.PKGBUILD/
+# NOTE: This PKGBUILD is based on https://osdn.net/downloads/users/27/27012/fcitx-mozc-ut-2.26.4237.102.20201229.1.PKGBUILD
## Mozc compile option
_bldtype=Release
-_mozcver=2.26.4206.102
+_mozcver=2.26.4237.102
_fcitxver=20201111
-_utdicdate=20201129
-pkgver=${_mozcver}.${_utdicdate}
+_iconver=20201229
+_utdicver=20201229
+pkgver=${_mozcver}.${_utdicver}
pkgrel=1
+_pkgbase=mozc
pkgname=fcitx-mozc-ut
-arch=('i686' 'x86_64')
+pkgdesc="Fcitx engine module for Mozc with Mozc UT Dictionary"
+arch=('x86_64')
url="https://osdn.net/users/utuhiro/pf/utuhiro/files/"
license=('custom')
+depends=('fcitx' 'qt5-base')
makedepends=('clang' 'gyp' 'ninja' 'pkg-config' 'python' 'curl' 'gtk2' 'qt5-base' 'fcitx' 'libxcb' 'glib2' 'bzip2' 'unzip')
+conflicts=('fcitx-mozc' 'fcitx-mozc-ut2' 'fcitx-mozc-neologd-ut' 'fcitx-mozc-ut-unified')
source=(
https://osdn.net/users/utuhiro/pf/utuhiro/dl/mozc-${_mozcver}.tar.bz2
@@ -26,18 +31,18 @@ source=(
googletest-release-1.10.0.tar.gz::https://github.com/google/googletest/archive/release-1.10.0.tar.gz
protobuf-3.13.0.tar.gz::https://github.com/protocolbuffers/protobuf/archive/v3.13.0.tar.gz
https://osdn.net/users/utuhiro/pf/utuhiro/dl/fcitx-mozc-${_fcitxver}.patch
- https://osdn.net/users/utuhiro/pf/utuhiro/dl/fcitx-mozc-icons.tar.gz
- https://osdn.net/users/utuhiro/pf/utuhiro/dl/mozcdic-ut-${_utdicdate}.${pkgrel}.tar.bz2
+ https://osdn.net/users/utuhiro/pf/utuhiro/dl/fcitx-mozc-icons-${_iconver}.tar.gz
+ https://osdn.net/users/utuhiro/pf/utuhiro/dl/mozcdic-ut-${_utdicver}.${pkgrel}.tar.bz2
)
sha1sums=(
- 'a6bd5f40b623aef4e77c20fdcc208ba7ee75e1ee'
+ 'b0b8fbf69f0d6089a800533a99be747e40faf922'
'1dd3f0a937c3678437646d26ca6784bd6a9b2b26'
'9c89be7df9c5e8cb0bc20b3c4b39bf7e82686770'
'2160cfb354148da3fb3891b267c2edc7e3eb5c30'
'38de276494e299dc7e4816dfd95403fd0fdf8601'
- 'e930c580ecd0c9e0cecb57d148122c9122d4859c'
- 'eb6fc52789044238b81596479107239e491c4f25'
+ '3d9da92eed88817985e0047daf7a7cc2131a3bb4'
+ 'f248798642153122628b41c62a7329c9be4f8e52'
)
prepare() {
@@ -49,9 +54,8 @@ prepare() {
mv ${srcdir}/protobuf-3.13.0 src/third_party/protobuf
patch -Np1 -i ${srcdir}/fcitx-mozc-${_fcitxver}.patch
- # Avoid build errors
- sed -i -e 's/-stdlib=libc++//' src/gyp/common.gypi
- sed -i -e 's/-lc++//' src/gyp/common.gypi
+ # use libstdc++ instead of libc++
+ sed "/stdlib=libc++/d;/-lc++/d" -i src/gyp/common.gypi
}
build() {
@@ -63,13 +67,9 @@ build() {
python build_mozc.py build -c $_bldtype $_targets
}
-package_fcitx-mozc-ut() {
- pkgdesc="Fcitx engine module for Mozc with Mozc UT Dictionary"
- arch=('i686' 'x86_64')
- depends=("mozc-ut=${pkgver}" 'fcitx')
- conflicts=('fcitx-mozc' 'fcitx-mozc-ut2' 'fcitx-mozc-neologd-ut' 'fcitx-mozc-ut-unified')
-
+package() {
cd mozc-${_mozcver}/src
+
for mofile in out_linux/${_bldtype}/gen/unix/fcitx/po/*.mo
do
filename=`basename $mofile`
@@ -82,5 +82,5 @@ package_fcitx-mozc-ut() {
install -D -m 644 unix/fcitx/mozc.conf "${pkgdir}/usr/share/fcitx/inputmethod/mozc.conf"
install -d ${pkgdir}/usr/share/fcitx/mozc/icon
- install -m 644 ${srcdir}/fcitx-mozc-icons/*.png ${pkgdir}/usr/share/fcitx/mozc/icon/
+ install -m 644 ${srcdir}/fcitx-mozc-icons-${_iconver}/*.png ${pkgdir}/usr/share/fcitx/mozc/icon/
}