summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorNocifer2022-07-24 13:53:33 +0300
committerNocifer2022-07-24 13:53:33 +0300
commiteba4e58a7cd5287a5031fcb71ebef01757d26cc1 (patch)
tree7f4c9597d7ead927a187f73056f7211e16c04e4c
parentcdbef2c607de0b2770ee2b9de509f61b5a04051a (diff)
downloadaur-eba4e58a7cd5287a5031fcb71ebef01757d26cc1.tar.gz
v=2.28.4800.102,r=1
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD16
-rw-r--r--fcitx.patch75
3 files changed, 48 insertions, 53 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 27b1d3e393e3..8f8ace1bb513 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = fcitx-mozc-ut
pkgdesc = Mozc module for Fcitx
- pkgver = 2.28.4770.102
+ pkgver = 2.28.4800.102
pkgrel = 1
url = https://github.com/fcitx/mozc
arch = x86_64
@@ -13,15 +13,15 @@ pkgbase = fcitx-mozc-ut
makedepends = python
makedepends = qt5-base
depends = fcitx
- depends = mozc>=2.28.4770.102
+ depends = mozc>=2.28.4800.102
optdepends = fcitx-configtool
- provides = fcitx-mozc=2.28.4770.102
+ provides = fcitx-mozc=2.28.4800.102
conflicts = fcitx-mozc
options = !distcc
options = !ccache
- source = fcitx-mozc-ut-git::git+https://github.com/google/mozc.git#commit=5e3542b98adb743553e672f34caee6d5d8021b85
+ source = fcitx-mozc-ut-git::git+https://github.com/google/mozc.git#commit=9dc923ab84f4f0369ba507848430c0bd42dbd01d
source = fcitx.patch
sha256sums = SKIP
- sha256sums = 02411077f078631811a90a7366d1da2f58d4a0440771c015dd40e5910c2cf4a2
+ sha256sums = 4074e50fca25ee36ac4a7bb98c05687881b6e8ad34b39695405e92f24c37135a
pkgname = fcitx-mozc-ut
diff --git a/PKGBUILD b/PKGBUILD
index adbabf500314..4fbd4e65e9c2 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,22 +4,22 @@
# Contributor: ponsfoot <cabezon dot hashimoto at gmail dot com>
pkgname='fcitx-mozc-ut'
-pkgver=2.28.4770.102
+pkgver=2.28.4800.102
pkgrel=1
pkgdesc='Mozc module for Fcitx'
arch=('x86_64')
url='https://github.com/fcitx/mozc'
license=('Apache' 'BSD' 'LGPL' 'custom')
-depends=('fcitx' 'mozc>=2.28.4770.102')
+depends=('fcitx' 'mozc>=2.28.4800.102')
makedepends=('bazel' 'git' 'python' 'qt5-base')
optdepends=('fcitx-configtool')
-provides=('fcitx-mozc=2.28.4770.102')
+provides=('fcitx-mozc=2.28.4800.102')
conflicts=('fcitx-mozc')
options=(!distcc !ccache)
-source=("${pkgname}-git::git+https://github.com/google/mozc.git#commit=5e3542b98adb743553e672f34caee6d5d8021b85"
+source=("${pkgname}-git::git+https://github.com/google/mozc.git#commit=9dc923ab84f4f0369ba507848430c0bd42dbd01d"
"fcitx.patch")
sha256sums=('SKIP'
- '02411077f078631811a90a7366d1da2f58d4a0440771c015dd40e5910c2cf4a2')
+ '4074e50fca25ee36ac4a7bb98c05687881b6e8ad34b39695405e92f24c37135a')
prepare() {
cd ${pkgname}-git/src
@@ -34,12 +34,6 @@ prepare() {
# Patch in the out-of-source fcitx target (pulled from https://github.com/fcitx/mozc)
patch -Np2 -i ${srcdir}/fcitx.patch
- # Fix the Qt5 include path
- sed -i -e 's/x86_64-linux-gnu\/qt5/qt/' config.bzl
-
- # Temp fix for the Android NDK error
- sed -i -e 's/android_ndk_repository(name = "androidndk")/#android_ndk_repository(name = "androidndk")/' WORKSPACE.bazel
-
# Load the application icon dynamically
sed -i -e 's|IconName=/usr/share/fcitx/mozc/icon/mozc.png|IconName=fcitx-mozc|' unix/fcitx/mozc.conf
}
diff --git a/fcitx.patch b/fcitx.patch
index c054e706454a..736ae93d8e8f 100644
--- a/fcitx.patch
+++ b/fcitx.patch
@@ -1,6 +1,6 @@
diff -ruN google-mozc-git/src/BUILD.fcitx.bazel fcitx-mozc-git/src/BUILD.fcitx.bazel
--- google-mozc-git/src/BUILD.fcitx.bazel 1970-01-01 02:00:00.000000000 +0200
-+++ fcitx-mozc-git/src/BUILD.fcitx.bazel 2022-07-03 09:58:03.694456181 +0300
++++ fcitx-mozc-git/src/BUILD.fcitx.bazel 2022-07-24 13:46:08.808295234 +0300
@@ -0,0 +1,27 @@
+package(
+ default_visibility = ["//visibility:public"],
@@ -31,7 +31,7 @@ diff -ruN google-mozc-git/src/BUILD.fcitx.bazel fcitx-mozc-git/src/BUILD.fcitx.b
+)
diff -ruN google-mozc-git/src/unix/fcitx/BUILD fcitx-mozc-git/src/unix/fcitx/BUILD
--- google-mozc-git/src/unix/fcitx/BUILD 1970-01-01 02:00:00.000000000 +0200
-+++ fcitx-mozc-git/src/unix/fcitx/BUILD 2022-07-03 09:58:03.697790230 +0300
++++ fcitx-mozc-git/src/unix/fcitx/BUILD 2022-07-24 13:46:08.811628641 +0300
@@ -0,0 +1,97 @@
+load(
+ "//:build_defs.bzl",
@@ -132,7 +132,7 @@ diff -ruN google-mozc-git/src/unix/fcitx/BUILD fcitx-mozc-git/src/unix/fcitx/BUI
+
diff -ruN google-mozc-git/src/unix/fcitx/eim.cc fcitx-mozc-git/src/unix/fcitx/eim.cc
--- google-mozc-git/src/unix/fcitx/eim.cc 1970-01-01 02:00:00.000000000 +0200
-+++ fcitx-mozc-git/src/unix/fcitx/eim.cc 2022-07-03 09:58:03.697790230 +0300
++++ fcitx-mozc-git/src/unix/fcitx/eim.cc 2022-07-24 13:46:08.811628641 +0300
@@ -0,0 +1,271 @@
+// Copyright 2012~2013, Weng Xuetian <wengxt@gmail.com>
+// All rights reserved.
@@ -407,7 +407,7 @@ diff -ruN google-mozc-git/src/unix/fcitx/eim.cc fcitx-mozc-git/src/unix/fcitx/ei
+}
diff -ruN google-mozc-git/src/unix/fcitx/fcitx.gyp fcitx-mozc-git/src/unix/fcitx/fcitx.gyp
--- google-mozc-git/src/unix/fcitx/fcitx.gyp 1970-01-01 02:00:00.000000000 +0200
-+++ fcitx-mozc-git/src/unix/fcitx/fcitx.gyp 2022-07-03 09:58:03.697790230 +0300
++++ fcitx-mozc-git/src/unix/fcitx/fcitx.gyp 2022-07-24 13:46:08.811628641 +0300
@@ -0,0 +1,111 @@
+#
+# Copyright (c) 2010-2012 fcitx Project http://code.google.com/p/fcitx/
@@ -522,7 +522,7 @@ diff -ruN google-mozc-git/src/unix/fcitx/fcitx.gyp fcitx-mozc-git/src/unix/fcitx
+}
diff -ruN google-mozc-git/src/unix/fcitx/fcitx_key_event_handler.cc fcitx-mozc-git/src/unix/fcitx/fcitx_key_event_handler.cc
--- google-mozc-git/src/unix/fcitx/fcitx_key_event_handler.cc 1970-01-01 02:00:00.000000000 +0200
-+++ fcitx-mozc-git/src/unix/fcitx/fcitx_key_event_handler.cc 2022-07-03 09:58:03.697790230 +0300
++++ fcitx-mozc-git/src/unix/fcitx/fcitx_key_event_handler.cc 2022-07-24 13:46:08.811628641 +0300
@@ -0,0 +1,243 @@
+// Copyright 2010-2012, Google Inc.
+// Copyright 2012~2013, Weng Xuetian <wengxt@gmail.com>
@@ -769,7 +769,7 @@ diff -ruN google-mozc-git/src/unix/fcitx/fcitx_key_event_handler.cc fcitx-mozc-g
+} // namespace mozc
diff -ruN google-mozc-git/src/unix/fcitx/fcitx_key_event_handler.h fcitx-mozc-git/src/unix/fcitx/fcitx_key_event_handler.h
--- google-mozc-git/src/unix/fcitx/fcitx_key_event_handler.h 1970-01-01 02:00:00.000000000 +0200
-+++ fcitx-mozc-git/src/unix/fcitx/fcitx_key_event_handler.h 2022-07-03 09:58:03.697790230 +0300
++++ fcitx-mozc-git/src/unix/fcitx/fcitx_key_event_handler.h 2022-07-24 13:46:08.811628641 +0300
@@ -0,0 +1,79 @@
+// Copyright 2010-2012, Google Inc.
+// Copyright 2012~2013, Weng Xuetian <wengxt@gmail.com>
@@ -852,7 +852,7 @@ diff -ruN google-mozc-git/src/unix/fcitx/fcitx_key_event_handler.h fcitx-mozc-gi
+#endif // MOZC_UNIX_FCITX_KEY_EVENT_HANDLER_H_
diff -ruN google-mozc-git/src/unix/fcitx/fcitx_key_translator.cc fcitx-mozc-git/src/unix/fcitx/fcitx_key_translator.cc
--- google-mozc-git/src/unix/fcitx/fcitx_key_translator.cc 1970-01-01 02:00:00.000000000 +0200
-+++ fcitx-mozc-git/src/unix/fcitx/fcitx_key_translator.cc 2022-07-03 09:58:03.697790230 +0300
++++ fcitx-mozc-git/src/unix/fcitx/fcitx_key_translator.cc 2022-07-24 13:46:08.811628641 +0300
@@ -0,0 +1,521 @@
+// Copyright 2010-2012, Google Inc.
+// Copyright 2012~2013, Weng Xuetian <wengxt@gmail.com>
@@ -1377,7 +1377,7 @@ diff -ruN google-mozc-git/src/unix/fcitx/fcitx_key_translator.cc fcitx-mozc-git/
+} // namespace mozc
diff -ruN google-mozc-git/src/unix/fcitx/fcitx_key_translator.h fcitx-mozc-git/src/unix/fcitx/fcitx_key_translator.h
--- google-mozc-git/src/unix/fcitx/fcitx_key_translator.h 1970-01-01 02:00:00.000000000 +0200
-+++ fcitx-mozc-git/src/unix/fcitx/fcitx_key_translator.h 2022-07-03 09:58:03.697790230 +0300
++++ fcitx-mozc-git/src/unix/fcitx/fcitx_key_translator.h 2022-07-24 13:46:08.811628641 +0300
@@ -0,0 +1,121 @@
+// Copyright 2010-2012, Google Inc.
+// Copyright 2012~2013, Weng Xuetian <wengxt@gmail.com>
@@ -1502,7 +1502,7 @@ diff -ruN google-mozc-git/src/unix/fcitx/fcitx_key_translator.h fcitx-mozc-git/s
+#endif // MOZC_UNIX_FCITX_FCITX_KEY_TRANSLATOR_H_
diff -ruN google-mozc-git/src/unix/fcitx/fcitx_mozc.cc fcitx-mozc-git/src/unix/fcitx/fcitx_mozc.cc
--- google-mozc-git/src/unix/fcitx/fcitx_mozc.cc 1970-01-01 02:00:00.000000000 +0200
-+++ fcitx-mozc-git/src/unix/fcitx/fcitx_mozc.cc 2022-07-03 09:58:03.697790230 +0300
++++ fcitx-mozc-git/src/unix/fcitx/fcitx_mozc.cc 2022-07-24 13:46:08.811628641 +0300
@@ -0,0 +1,552 @@
+// Copyright 2012~2013, Weng Xuetian <wengxt@gmail.com>
+// All rights reserved.
@@ -2058,7 +2058,7 @@ diff -ruN google-mozc-git/src/unix/fcitx/fcitx_mozc.cc fcitx-mozc-git/src/unix/f
+} // namespace mozc_unix_scim
diff -ruN google-mozc-git/src/unix/fcitx/fcitx-mozc.conf fcitx-mozc-git/src/unix/fcitx/fcitx-mozc.conf
--- google-mozc-git/src/unix/fcitx/fcitx-mozc.conf 1970-01-01 02:00:00.000000000 +0200
-+++ fcitx-mozc-git/src/unix/fcitx/fcitx-mozc.conf 2022-07-03 09:58:03.697790230 +0300
++++ fcitx-mozc-git/src/unix/fcitx/fcitx-mozc.conf 2022-07-24 13:46:08.811628641 +0300
@@ -0,0 +1,11 @@
+[Addon]
+Name=fcitx-mozc
@@ -2073,7 +2073,7 @@ diff -ruN google-mozc-git/src/unix/fcitx/fcitx-mozc.conf fcitx-mozc-git/src/unix
+LoadLocal=True
diff -ruN google-mozc-git/src/unix/fcitx/fcitx_mozc.h fcitx-mozc-git/src/unix/fcitx/fcitx_mozc.h
--- google-mozc-git/src/unix/fcitx/fcitx_mozc.h 1970-01-01 02:00:00.000000000 +0200
-+++ fcitx-mozc-git/src/unix/fcitx/fcitx_mozc.h 2022-07-03 09:58:03.697790230 +0300
++++ fcitx-mozc-git/src/unix/fcitx/fcitx_mozc.h 2022-07-24 13:46:08.811628641 +0300
@@ -0,0 +1,176 @@
+// Copyright 2012~2013, Weng Xuetian <wengxt@gmail.com>
+// All rights reserved.
@@ -2253,7 +2253,7 @@ diff -ruN google-mozc-git/src/unix/fcitx/fcitx_mozc.h fcitx-mozc-git/src/unix/fc
+
diff -ruN google-mozc-git/src/unix/fcitx/gen_fcitx_mozc_i18n.sh fcitx-mozc-git/src/unix/fcitx/gen_fcitx_mozc_i18n.sh
--- google-mozc-git/src/unix/fcitx/gen_fcitx_mozc_i18n.sh 1970-01-01 02:00:00.000000000 +0200
-+++ fcitx-mozc-git/src/unix/fcitx/gen_fcitx_mozc_i18n.sh 2022-07-03 09:58:03.697790230 +0300
++++ fcitx-mozc-git/src/unix/fcitx/gen_fcitx_mozc_i18n.sh 2022-07-24 13:46:08.811628641 +0300
@@ -0,0 +1,10 @@
+#!/bin/sh
+
@@ -2267,7 +2267,7 @@ diff -ruN google-mozc-git/src/unix/fcitx/gen_fcitx_mozc_i18n.sh fcitx-mozc-git/s
+done
diff -ruN google-mozc-git/src/unix/fcitx/mozc.conf fcitx-mozc-git/src/unix/fcitx/mozc.conf
--- google-mozc-git/src/unix/fcitx/mozc.conf 1970-01-01 02:00:00.000000000 +0200
-+++ fcitx-mozc-git/src/unix/fcitx/mozc.conf 2022-07-03 09:58:03.697790230 +0300
++++ fcitx-mozc-git/src/unix/fcitx/mozc.conf 2022-07-24 13:46:08.811628641 +0300
@@ -0,0 +1,7 @@
+[InputMethod]
+UniqueName=mozc
@@ -2278,7 +2278,7 @@ diff -ruN google-mozc-git/src/unix/fcitx/mozc.conf fcitx-mozc-git/src/unix/fcitx
+Parent=fcitx-mozc
diff -ruN google-mozc-git/src/unix/fcitx/mozc_connection.cc fcitx-mozc-git/src/unix/fcitx/mozc_connection.cc
--- google-mozc-git/src/unix/fcitx/mozc_connection.cc 1970-01-01 02:00:00.000000000 +0200
-+++ fcitx-mozc-git/src/unix/fcitx/mozc_connection.cc 2022-07-03 09:58:03.697790230 +0300
++++ fcitx-mozc-git/src/unix/fcitx/mozc_connection.cc 2022-07-24 13:46:08.811628641 +0300
@@ -0,0 +1,214 @@
+// Copyright 2010-2012, Google Inc.
+// Copyright 2012~2013, Weng Xuetian <wengxt@gmail.com>
@@ -2496,7 +2496,7 @@ diff -ruN google-mozc-git/src/unix/fcitx/mozc_connection.cc fcitx-mozc-git/src/u
+} // namespace mozc
diff -ruN google-mozc-git/src/unix/fcitx/mozc_connection.h fcitx-mozc-git/src/unix/fcitx/mozc_connection.h
--- google-mozc-git/src/unix/fcitx/mozc_connection.h 1970-01-01 02:00:00.000000000 +0200
-+++ fcitx-mozc-git/src/unix/fcitx/mozc_connection.h 2022-07-03 09:58:03.697790230 +0300
++++ fcitx-mozc-git/src/unix/fcitx/mozc_connection.h 2022-07-24 13:46:08.811628641 +0300
@@ -0,0 +1,154 @@
+// Copyright 2010-2012, Google Inc.
+// Copyright 2012~2013, Weng Xuetian <wengxt@gmail.com>
@@ -2654,7 +2654,7 @@ diff -ruN google-mozc-git/src/unix/fcitx/mozc_connection.h fcitx-mozc-git/src/un
+#endif // MOZC_UNIX_SCIM_MOZC_CONNECTION_H_
diff -ruN google-mozc-git/src/unix/fcitx/mozc_response_parser.cc fcitx-mozc-git/src/unix/fcitx/mozc_response_parser.cc
--- google-mozc-git/src/unix/fcitx/mozc_response_parser.cc 1970-01-01 02:00:00.000000000 +0200
-+++ fcitx-mozc-git/src/unix/fcitx/mozc_response_parser.cc 2022-07-03 09:58:03.697790230 +0300
++++ fcitx-mozc-git/src/unix/fcitx/mozc_response_parser.cc 2022-07-24 13:46:08.811628641 +0300
@@ -0,0 +1,447 @@
+// Copyright 2010-2012, Google Inc.
+// Copyright 2012~2013, Weng Xuetian <wengxt@gmail.com>
@@ -3105,7 +3105,7 @@ diff -ruN google-mozc-git/src/unix/fcitx/mozc_response_parser.cc fcitx-mozc-git/
+} // namespace mozc
diff -ruN google-mozc-git/src/unix/fcitx/mozc_response_parser.h fcitx-mozc-git/src/unix/fcitx/mozc_response_parser.h
--- google-mozc-git/src/unix/fcitx/mozc_response_parser.h 1970-01-01 02:00:00.000000000 +0200
-+++ fcitx-mozc-git/src/unix/fcitx/mozc_response_parser.h 2022-07-03 09:58:03.697790230 +0300
++++ fcitx-mozc-git/src/unix/fcitx/mozc_response_parser.h 2022-07-24 13:46:08.811628641 +0300
@@ -0,0 +1,97 @@
+// Copyright 2010-2012, Google Inc.
+// Copyright 2012~2013, Weng Xuetian <wengxt@gmail.com>
@@ -3206,7 +3206,7 @@ diff -ruN google-mozc-git/src/unix/fcitx/mozc_response_parser.h fcitx-mozc-git/s
+#endif // MOZC_UNIX_FCITX_MOZC_RESPONSE_PARSER_H_
diff -ruN google-mozc-git/src/unix/fcitx/po/ca.po fcitx-mozc-git/src/unix/fcitx/po/ca.po
--- google-mozc-git/src/unix/fcitx/po/ca.po 1970-01-01 02:00:00.000000000 +0200
-+++ fcitx-mozc-git/src/unix/fcitx/po/ca.po 2022-07-03 09:58:03.697790230 +0300
++++ fcitx-mozc-git/src/unix/fcitx/po/ca.po 2022-07-24 13:46:08.811628641 +0300
@@ -0,0 +1,80 @@
+# SOME DESCRIPTIVE TITLE.
+# Copyright (C) YEAR THE PACKAGE'S COPYRIGHT HOLDER
@@ -3290,7 +3290,7 @@ diff -ruN google-mozc-git/src/unix/fcitx/po/ca.po fcitx-mozc-git/src/unix/fcitx/
+msgstr "Premeu Ctrl+Alt+H per mostrar els usos."
diff -ruN google-mozc-git/src/unix/fcitx/po/da.po fcitx-mozc-git/src/unix/fcitx/po/da.po
--- google-mozc-git/src/unix/fcitx/po/da.po 1970-01-01 02:00:00.000000000 +0200
-+++ fcitx-mozc-git/src/unix/fcitx/po/da.po 2022-07-03 09:58:03.697790230 +0300
++++ fcitx-mozc-git/src/unix/fcitx/po/da.po 2022-07-24 13:46:08.811628641 +0300
@@ -0,0 +1,80 @@
+# SOME DESCRIPTIVE TITLE.
+# Copyright (C) YEAR THE PACKAGE'S COPYRIGHT HOLDER
@@ -3374,7 +3374,7 @@ diff -ruN google-mozc-git/src/unix/fcitx/po/da.po fcitx-mozc-git/src/unix/fcitx/
+msgstr "Tryk på Ctrl+Alt+H for at vise anvendelser."
diff -ruN google-mozc-git/src/unix/fcitx/po/de.po fcitx-mozc-git/src/unix/fcitx/po/de.po
--- google-mozc-git/src/unix/fcitx/po/de.po 1970-01-01 02:00:00.000000000 +0200
-+++ fcitx-mozc-git/src/unix/fcitx/po/de.po 2022-07-03 09:58:03.697790230 +0300
++++ fcitx-mozc-git/src/unix/fcitx/po/de.po 2022-07-24 13:46:08.811628641 +0300
@@ -0,0 +1,86 @@
+# SOME DESCRIPTIVE TITLE.
+# Copyright (C) YEAR THE PACKAGE'S COPYRIGHT HOLDER
@@ -3464,7 +3464,7 @@ diff -ruN google-mozc-git/src/unix/fcitx/po/de.po fcitx-mozc-git/src/unix/fcitx/
+msgstr "Ctrl+Alt+H um die Hilfe anzuzeigen"
diff -ruN google-mozc-git/src/unix/fcitx/po/fcitx-mozc.pot fcitx-mozc-git/src/unix/fcitx/po/fcitx-mozc.pot
--- google-mozc-git/src/unix/fcitx/po/fcitx-mozc.pot 1970-01-01 02:00:00.000000000 +0200
-+++ fcitx-mozc-git/src/unix/fcitx/po/fcitx-mozc.pot 2022-07-03 09:58:03.697790230 +0300
++++ fcitx-mozc-git/src/unix/fcitx/po/fcitx-mozc.pot 2022-07-24 13:46:08.811628641 +0300
@@ -0,0 +1,78 @@
+# SOME DESCRIPTIVE TITLE.
+# Copyright (C) YEAR THE PACKAGE'S COPYRIGHT HOLDER
@@ -3546,7 +3546,7 @@ diff -ruN google-mozc-git/src/unix/fcitx/po/fcitx-mozc.pot fcitx-mozc-git/src/un
+msgstr ""
diff -ruN google-mozc-git/src/unix/fcitx/po/ja.po fcitx-mozc-git/src/unix/fcitx/po/ja.po
--- google-mozc-git/src/unix/fcitx/po/ja.po 1970-01-01 02:00:00.000000000 +0200
-+++ fcitx-mozc-git/src/unix/fcitx/po/ja.po 2022-07-03 09:58:03.697790230 +0300
++++ fcitx-mozc-git/src/unix/fcitx/po/ja.po 2022-07-24 13:46:08.811628641 +0300
@@ -0,0 +1,87 @@
+# SOME DESCRIPTIVE TITLE.
+# Copyright (C) YEAR THE PACKAGE'S COPYRIGHT HOLDER
@@ -3637,7 +3637,7 @@ diff -ruN google-mozc-git/src/unix/fcitx/po/ja.po fcitx-mozc-git/src/unix/fcitx/
+msgstr "Ctrl+Alt+H キーを押して用例を表示"
diff -ruN google-mozc-git/src/unix/fcitx/po/ko.po fcitx-mozc-git/src/unix/fcitx/po/ko.po
--- google-mozc-git/src/unix/fcitx/po/ko.po 1970-01-01 02:00:00.000000000 +0200
-+++ fcitx-mozc-git/src/unix/fcitx/po/ko.po 2022-07-03 09:58:03.697790230 +0300
++++ fcitx-mozc-git/src/unix/fcitx/po/ko.po 2022-07-24 13:46:08.811628641 +0300
@@ -0,0 +1,82 @@
+# SOME DESCRIPTIVE TITLE.
+# Copyright (C) YEAR THE PACKAGE'S COPYRIGHT HOLDER
@@ -3723,7 +3723,7 @@ diff -ruN google-mozc-git/src/unix/fcitx/po/ko.po fcitx-mozc-git/src/unix/fcitx/
+msgstr "사용법을 보려면 Ctrl+Alt+H를 누릅니다."
diff -ruN google-mozc-git/src/unix/fcitx/po/Messages.sh fcitx-mozc-git/src/unix/fcitx/po/Messages.sh
--- google-mozc-git/src/unix/fcitx/po/Messages.sh 1970-01-01 02:00:00.000000000 +0200
-+++ fcitx-mozc-git/src/unix/fcitx/po/Messages.sh 2022-07-03 09:58:03.697790230 +0300
++++ fcitx-mozc-git/src/unix/fcitx/po/Messages.sh 2022-07-24 13:46:08.811628641 +0300
@@ -0,0 +1,33 @@
+#!/bin/sh
+
@@ -3760,22 +3760,23 @@ diff -ruN google-mozc-git/src/unix/fcitx/po/Messages.sh fcitx-mozc-git/src/unix/
+echo "Done"
diff -ruN google-mozc-git/src/unix/fcitx/po/ru.po fcitx-mozc-git/src/unix/fcitx/po/ru.po
--- google-mozc-git/src/unix/fcitx/po/ru.po 1970-01-01 02:00:00.000000000 +0200
-+++ fcitx-mozc-git/src/unix/fcitx/po/ru.po 2022-07-03 09:58:03.697790230 +0300
-@@ -0,0 +1,82 @@
++++ fcitx-mozc-git/src/unix/fcitx/po/ru.po 2022-07-24 13:46:08.811628641 +0300
+@@ -0,0 +1,83 @@
+# SOME DESCRIPTIVE TITLE.
+# Copyright (C) YEAR THE PACKAGE'S COPYRIGHT HOLDER
+# This file is distributed under the same license as the PACKAGE package.
+#
+# Translators:
++# Dmitry <dmitrydmitry761@gmail.com>, 2022
+# TotalCaesar659 <x24cm5b8c54q6szxw@yandex.ru>, 2016
+# TotalCaesar659 <x24cm5b8c54q6szxw@yandex.ru>, 2016
+msgid ""
+msgstr ""
+"Project-Id-Version: fcitx\n"
+"Report-Msgid-Bugs-To: fcitx-dev@googlegroups.com\n"
-+"POT-Creation-Date: 2022-06-02 20:29+0000\n"
++"POT-Creation-Date: 2022-07-03 19:07+0000\n"
+"PO-Revision-Date: 2012-03-06 06:51+0000\n"
-+"Last-Translator: TotalCaesar659 <x24cm5b8c54q6szxw@yandex.ru>, 2016\n"
++"Last-Translator: Dmitry <dmitrydmitry761@gmail.com>, 2022\n"
+"Language-Team: Russian (http://www.transifex.com/fcitx/fcitx/language/ru/)\n"
+"Language: ru\n"
+"MIME-Version: 1.0\n"
@@ -3839,14 +3840,14 @@ diff -ruN google-mozc-git/src/unix/fcitx/po/ru.po fcitx-mozc-git/src/unix/fcitx/
+
+#: ../fcitx_mozc.cc:494
+msgid "About Mozc"
-+msgstr "О "
++msgstr "О Mozc"
+
+#: ../mozc_response_parser.cc:365
+msgid "Press Ctrl+Alt+H to show usages."
+msgstr "Нажмите Ctrl+Alt+H, чтобы показать использование."
diff -ruN google-mozc-git/src/unix/fcitx/po/zh_CN.po fcitx-mozc-git/src/unix/fcitx/po/zh_CN.po
--- google-mozc-git/src/unix/fcitx/po/zh_CN.po 1970-01-01 02:00:00.000000000 +0200
-+++ fcitx-mozc-git/src/unix/fcitx/po/zh_CN.po 2022-07-03 09:58:03.697790230 +0300
++++ fcitx-mozc-git/src/unix/fcitx/po/zh_CN.po 2022-07-24 13:46:08.811628641 +0300
@@ -0,0 +1,85 @@
+# SOME DESCRIPTIVE TITLE.
+# Copyright (C) YEAR THE PACKAGE'S COPYRIGHT HOLDER
@@ -3935,7 +3936,7 @@ diff -ruN google-mozc-git/src/unix/fcitx/po/zh_CN.po fcitx-mozc-git/src/unix/fci
+msgstr "按下 Ctrl+Alt+H 显示用法。"
diff -ruN google-mozc-git/src/unix/fcitx/po/zh_TW.po fcitx-mozc-git/src/unix/fcitx/po/zh_TW.po
--- google-mozc-git/src/unix/fcitx/po/zh_TW.po 1970-01-01 02:00:00.000000000 +0200
-+++ fcitx-mozc-git/src/unix/fcitx/po/zh_TW.po 2022-07-03 09:58:03.697790230 +0300
++++ fcitx-mozc-git/src/unix/fcitx/po/zh_TW.po 2022-07-24 13:46:08.811628641 +0300
@@ -0,0 +1,84 @@
+# SOME DESCRIPTIVE TITLE.
+# Copyright (C) YEAR THE PACKAGE'S COPYRIGHT HOLDER
@@ -4023,7 +4024,7 @@ diff -ruN google-mozc-git/src/unix/fcitx/po/zh_TW.po fcitx-mozc-git/src/unix/fci
+msgstr "按下 Ctrl+Alt+H 顯示用法。"
diff -ruN google-mozc-git/src/unix/fcitx/surrounding_text_util.cc fcitx-mozc-git/src/unix/fcitx/surrounding_text_util.cc
--- google-mozc-git/src/unix/fcitx/surrounding_text_util.cc 1970-01-01 02:00:00.000000000 +0200
-+++ fcitx-mozc-git/src/unix/fcitx/surrounding_text_util.cc 2022-07-03 09:58:03.697790230 +0300
++++ fcitx-mozc-git/src/unix/fcitx/surrounding_text_util.cc 2022-07-24 13:46:08.811628641 +0300
@@ -0,0 +1,243 @@
+// Copyright 2010-2013, Google Inc.
+// All rights reserved.
@@ -4270,7 +4271,7 @@ diff -ruN google-mozc-git/src/unix/fcitx/surrounding_text_util.cc fcitx-mozc-git
+} // namespace mozc
diff -ruN google-mozc-git/src/unix/fcitx/surrounding_text_util.h fcitx-mozc-git/src/unix/fcitx/surrounding_text_util.h
--- google-mozc-git/src/unix/fcitx/surrounding_text_util.h 1970-01-01 02:00:00.000000000 +0200
-+++ fcitx-mozc-git/src/unix/fcitx/surrounding_text_util.h 2022-07-03 09:58:03.697790230 +0300
++++ fcitx-mozc-git/src/unix/fcitx/surrounding_text_util.h 2022-07-24 13:46:08.811628641 +0300
@@ -0,0 +1,87 @@
+// Copyright 2010-2013, Google Inc.
+// All rights reserved.
@@ -4360,10 +4361,10 @@ diff -ruN google-mozc-git/src/unix/fcitx/surrounding_text_util.h fcitx-mozc-git/
+
+#endif // MOZC_UNIX_FCITX_SURROUNDING_TEXT_URIL_H_
diff -ruN google-mozc-git/src/WORKSPACE.bazel fcitx-mozc-git/src/WORKSPACE.bazel
---- google-mozc-git/src/WORKSPACE.bazel 2022-03-05 23:38:12.704698418 +0200
-+++ fcitx-mozc-git/src/WORKSPACE.bazel 2022-04-08 14:34:39.720122998 +0300
-@@ -66,6 +66,22 @@
- path = "/usr", # For Debian
+--- google-mozc-git/src/WORKSPACE.bazel 2022-07-24 13:10:07.330855232 +0300
++++ fcitx-mozc-git/src/WORKSPACE.bazel 2022-07-24 13:10:08.670903443 +0300
+@@ -67,6 +67,22 @@
+ packages = ["glib-2.0", "gobject-2.0", "ibus-1.0"],
)
+# Fcitx