summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJack Chen2020-08-26 17:38:16 +0800
committerJack Chen2020-08-26 17:38:16 +0800
commit9878d328c3ca8bf8b6ccbe873970770bebef68ae (patch)
treef9e84398eb6bae5138dba3532d821a93e9eb1db0
parent6b76b47426f2ccc3c15f7384ec53a6b8fc3f5b02 (diff)
downloadaur-9878d328c3ca8bf8b6ccbe873970770bebef68ae.tar.gz
update PKGBUILD
-rw-r--r--.SRCINFO11
-rw-r--r--PKGBUILD24
2 files changed, 14 insertions, 21 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 07dee3e443d6..88ba28e2ce66 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,13 +1,12 @@
pkgbase = fcitx-skin-aqua
- pkgdesc = Fcitx Skin - Aqua
+ pkgdesc = Aqua - fcitx skin
pkgver = 0.1
- pkgrel = 2
- url = https://github.com/redchenjs/fcitx-skin-aqua/
+ pkgrel = 3
+ url = https://github.com/redchenjs/fcitx-skin-aqua
arch = any
license = Apache
- depends = fcitx
- source = https://github.com/redchenjs/fcitx-skin-aqua/archive/v0.1.tar.gz
- md5sums = 126d58f4a094c31c775d2341b8c65afe
+ source = https://github.com/redchenjs/fcitx-skin-aqua/archive/fdc8379b94ea79e9215673eb84e41fa40cae1ca9/fcitx-skin-aqua-fdc8379b94ea79e9215673eb84e41fa40cae1ca9.tar.gz
+ sha512sums = 7ba3dec58dba2a1fd52ec2661cd54cc4e85b2ffbe601b9ee1c67c0402a00daf48d707dd0b53880d82e8c65c65973b88ebdfe23de77714d633adfa9bb4f55f427
pkgname = fcitx-skin-aqua
diff --git a/PKGBUILD b/PKGBUILD
index 4062d1f4cf66..4376c129d1c0 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,23 +2,17 @@
pkgname=fcitx-skin-aqua
pkgver=0.1
-pkgrel=2
-pkgdesc='Fcitx Skin - Aqua'
+_commit=fdc8379b94ea79e9215673eb84e41fa40cae1ca9
+pkgrel=3
+pkgdesc="Aqua - fcitx skin"
arch=('any')
-url='https://github.com/redchenjs/fcitx-skin-aqua/'
+url="https://github.com/redchenjs/fcitx-skin-aqua"
license=('Apache')
-depends=(
- 'fcitx'
-)
-source=(
- 'https://github.com/redchenjs/fcitx-skin-aqua/archive/v'${pkgver}'.tar.gz'
-)
-md5sums=(
- '126d58f4a094c31c775d2341b8c65afe'
-)
+source=("https://github.com/redchenjs/fcitx-skin-aqua/archive/$_commit/fcitx-skin-aqua-$_commit.tar.gz")
+sha512sums=('7ba3dec58dba2a1fd52ec2661cd54cc4e85b2ffbe601b9ee1c67c0402a00daf48d707dd0b53880d82e8c65c65973b88ebdfe23de77714d633adfa9bb4f55f427')
package() {
- install -dm 755 ${pkgdir}/usr/share/fcitx/skin/aqua/
- install -Dm 644 ${srcdir}/fcitx-skin-aqua-${pkgver}/aqua/* \
- ${pkgdir}/usr/share/fcitx/skin/aqua/
+ cd $pkgname-$_commit
+ mkdir -p "$pkgdir/usr/share/fcitx/skin/aqua/"
+ install -Dm644 aqua/* "$pkgdir/usr/share/fcitx/skin/aqua/"
}