summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorwenLiangcan2015-06-08 23:05:28 +0800
committerwenLiangcan2015-06-08 23:05:28 +0800
commitfdf637d5639cf41e3f50bade8e96b01dc1112bac (patch)
treeccbe67e49a836dece4bda195a1e972d8452c8b8a
downloadaur-fdf637d5639cf41e3f50bade8e96b01dc1112bac.tar.gz
fcitx-skin-dartmouth 1.0-1.
-rw-r--r--.SRCINFO13
-rw-r--r--PKGBUILD22
2 files changed, 35 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..d58264b1ea80
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,13 @@
+pkgbase = fcitx-skin-dartmouth
+ pkgdesc = Dartmouth is a fcitx theme.
+ pkgver = 1.0
+ pkgrel = 1
+ url = http://kde-look.org/content/show.php/%22Dartmouth%22+-+Fcitx+openSUSE+12.3+Theme?content=156641
+ arch = any
+ license = GPL
+ depends = fcitx>=4.2.6
+ source = dartmouth.fskin::http://kde-look.org/CONTENT/content-files/156641-fcitx-openSUSE-12.3.fskin
+ md5sums = d744f95174a27aa5756e8719a88b1ddc
+
+pkgname = fcitx-skin-dartmouth
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..2e64f04652df
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,22 @@
+# Maintainer: wenLiangcan <boxeed at gmail dot com>
+
+_pkgname=dartmouth
+pkgname="fcitx-skin-${_pkgname}"
+pkgver=1.0
+pkgrel=1
+pkgdesc="Dartmouth is a fcitx theme."
+arch=("any")
+url="http://kde-look.org/content/show.php/%22Dartmouth%22+-+Fcitx+openSUSE+12.3+Theme?content=156641"
+license=('GPL')
+depends=('fcitx>=4.2.6')
+source=("${_pkgname}.fskin"::'http://kde-look.org/CONTENT/content-files/156641-fcitx-openSUSE-12.3.fskin')
+md5sums=('d744f95174a27aa5756e8719a88b1ddc')
+
+build() {
+ tar xzvf "${_pkgname}.fskin"
+}
+
+package() {
+ install -dm755 "${pkgdir}/usr/share/fcitx/skin"
+ mv openSUSE-default "${pkgdir}/usr/share/fcitx/skin/${_pkgname}"
+}