aboutsummarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorBian Jiaping2018-04-25 09:18:51 +0800
committerBian Jiaping2018-04-25 09:18:51 +0800
commit7ae1ce81b9281db43809fce66d88bb42e8149d7d (patch)
treed288f958f3b7657ba99e1b0ce6f326c35434a653
parent7aefd0d05144177ef0f2a2b496fc68afba8b5a19 (diff)
downloadaur-7ae1ce81b9281db43809fce66d88bb42e8149d7d.tar.gz
Bump to v2.2.0.0108
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD14
-rwxr-xr-xsogou-autostart6
3 files changed, 16 insertions, 12 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 10632322feb9..56f79be167df 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = fcitx-sogoupinyin
pkgdesc = Sogou Pinyin for Linux
- pkgver = 2.2.0.0102
- pkgrel = 2
+ pkgver = 2.2.0.0108
+ pkgrel = 1
url = https://pinyin.sogou.com/linux/
arch = x86_64
arch = i686
@@ -14,9 +14,9 @@ pkgbase = fcitx-sogoupinyin
depends = qtwebkit
source = sogou-autostart
md5sums = d20f07816f7be4bcd11e7a6f527de425
- source_x86_64 = http://cdn2.ime.sogou.com/dl/index/1509619794/sogoupinyin_2.2.0.0102_amd64.deb
+ source_x86_64 = http://cdn2.ime.sogou.com/dl/index/1509619794/sogoupinyin_2.2.0.0108_amd64.deb
md5sums_x86_64 = 2a58e8b4c2ae619e2b3f706665a559d5
- source_i686 = http://cdn2.ime.sogou.com/dl/index/1509619879/sogoupinyin_2.2.0.0102_i386.deb
+ source_i686 = http://cdn2.ime.sogou.com/dl/index/1509619879/sogoupinyin_2.2.0.0108_i386.deb
md5sums_i686 = 6845cbfe09d0e1b5a6c62c3c092a9c09
pkgname = fcitx-sogoupinyin
diff --git a/PKGBUILD b/PKGBUILD
index 521f1af9810a..945e8828dbc5 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,23 +4,23 @@
# Contributor: Felix Yan <felixonmars [AT] gmail.com>
pkgname=fcitx-sogoupinyin
-pkgver=2.2.0.0102
-pkgrel=2
+pkgver=2.2.0.0108
+pkgrel=1
pkgdesc="Sogou Pinyin for Linux"
arch=('x86_64' 'i686')
url="https://pinyin.sogou.com/linux/"
license=('custom')
depends=('fcitx' 'opencc' 'libidn' 'lsb-release' 'xorg-xprop' 'qtwebkit')
-_i686_time=1509619879
-_x86_64_time=1509619794
+_i686_time=1524572032
+_x86_64_time=1524572264
source=('sogou-autostart')
source_i686=("http://cdn2.ime.sogou.com/dl/index/${_i686_time}/sogoupinyin_${pkgver}_i386.deb")
source_x86_64=("http://cdn2.ime.sogou.com/dl/index/${_x86_64_time}/sogoupinyin_${pkgver}_amd64.deb")
-md5sums=('d20f07816f7be4bcd11e7a6f527de425')
-md5sums_x86_64=('2a58e8b4c2ae619e2b3f706665a559d5')
-md5sums_i686=('6845cbfe09d0e1b5a6c62c3c092a9c09')
+md5sums=('d1b6c174a455f7d7795da6e4ab829b12')
+md5sums_x86_64=('3fc65450b4a8c2f00561d9c8a4a07b5a')
+md5sums_i686=('475d07b3a99c2e23daca68c7d900388f')
package(){
cd ${srcdir}
diff --git a/sogou-autostart b/sogou-autostart
index ddb18e9bc5c1..4b8e81d25ff0 100755
--- a/sogou-autostart
+++ b/sogou-autostart
@@ -4,8 +4,12 @@
for i in $(seq 30); do
if fcitx-remote &> /dev/null; then
sogou-qimpanel
- break
+ echo 'sogou-qimpanel started'
+ exit
else
sleep 1
fi
done
+
+echo 'sogou-qimpanel failed to start: fcitx not running'
+exit 1