summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorfrantic10482016-12-03 17:50:40 +0800
committerfrantic10482016-12-03 17:50:40 +0800
commit69a52d9b61452fe51bbed219d645c8a837f0d38b (patch)
tree5c11ace2d71b16dd66d7d0cbdda61b8a43545c6e
downloadaur-69a52d9b61452fe51bbed219d645c8a837f0d38b.tar.gz
initial
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD31
2 files changed, 47 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..3cd6ef86b386
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+# Generated by mksrcinfo v8
+# Sat Dec 3 09:49:15 UTC 2016
+pkgbase = fcitx-table-cangjie5-colemak
+ pkgdesc = Fcitx Cangjie5 code table for Colemak layout.
+ pkgver = r3.c9767e3
+ pkgrel = 1
+ url = https://github.com/frantic1048/fcitx-table-cangjie5-colemak
+ arch = any
+ license = GPL
+ makedepends = git
+ depends = fcitx
+ source = fcitx-table-cangjie5-colemak::git+https://github.com/frantic1048/fcitx-table-cangjie5-colemak
+ sha512sums = SKIP
+
+pkgname = fcitx-table-cangjie5-colemak
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..e21d20df155a
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,31 @@
+# Maintainer: Frantic1048 <archer@frantic1048.com>
+pkgdesc='Fcitx Cangjie5 code table for Colemak layout.'
+pkgname='fcitx-table-cangjie5-colemak'
+pkgver=r3.c9767e3
+pkgrel=1
+makedepends=('git')
+depends=('fcitx')
+conflicts=()
+provides=()
+arch=('any')
+url='https://github.com/frantic1048/fcitx-table-cangjie5-colemak'
+license=('GPL')
+source=("${pkgname}::git+${url}")
+sha512sums=('SKIP')
+
+pkgver () {
+ cd "${pkgname}"
+ (
+ set -o pipefail
+ git describe --long 2>/dev/null | sed 's/\([^-]*-g\)/r\1/;s/-/./g' ||
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+ )
+}
+
+package () {
+ cd "${pkgname}"
+
+ install -d "${pkgdir}/usr/share/fcitx/table/"
+ install -m755 "table/cangjie5-colemak.conf" "${pkgdir}/usr/share/fcitx/table/"
+ install -m755 "table/cangjie5-colemak.mb" "${pkgdir}/usr/share/fcitx/table/"
+}