summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorrydesun2017-03-04 21:24:30 +0800
committerrydesun2017-03-04 21:27:19 +0800
commite8ecbd8cbb20e6108e12a7fc7c075af501d2985e (patch)
tree194e0fe0379f7a6daf9ee27f3e9e7adbfa9b8709
downloadaur-e8ecbd8cbb20e6108e12a7fc7c075af501d2985e.tar.gz
Initial commit
-rw-r--r--.SRCINFO13
-rw-r--r--PKGBUILD23
2 files changed, 36 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..3c89c8f2a7e2
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,13 @@
+pkgbase = fcitx-table-flypy
+ pkgdesc = XiaoHe shuangpin table for fcitx, also known as flypy or xhup.
+ pkgver = 0.1.0
+ pkgrel = 1
+ url = http://www.flypy.com
+ arch = any
+ license = GPL
+ depends = fcitx
+ source = git://github.com/rydesun/fcitx-table-flypy.git
+ md5sums = SKIP
+
+pkgname = fcitx-table-flypy
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..2c98fea1ac87
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,23 @@
+# Maintainer: heliary <rydesun@gmail.com>
+
+pkgname=fcitx-table-flypy
+pkgver=0.1.0
+pkgrel=1
+pkgdesc='XiaoHe shuangpin table for fcitx, also known as flypy or xhup.'
+arch=('any')
+license=('GPL')
+depends=('fcitx')
+url='http://www.flypy.com'
+source=("git://github.com/rydesun/fcitx-table-flypy.git")
+md5sums=('SKIP')
+
+pkgver() {
+ cd "$pkgname"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+package() {
+ cd $pkgname-$pkgver
+ install -Dm644 flypy.conf flypy.mb "$pkgdir/usr/share/fcitx/table"
+ install -Dm644 LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+}