summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorOriginCode2018-02-22 16:04:57 +0800
committerOriginCode2018-02-22 16:04:57 +0800
commitc2514fe386acbd4aa8a4cdf820bc1b6b5f635c6b (patch)
treea5a0078a1482c62ab38273c9722b7abc8595c530
downloadaur-c2514fe386acbd4aa8a4cdf820bc1b6b5f635c6b.tar.gz
First commit.
-rw-r--r--.SRCINFO19
-rw-r--r--PKGBUILD32
2 files changed, 51 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..cb1df86bf175
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+pkgbase = fcitx5-anthy-git
+ pkgdesc = Anthy input method for fcitx5
+ pkgver = r139.b9ac495
+ pkgrel = 1
+ url = https://github.com/fcitx/fcitx5-anthy
+ arch = x86_64
+ license = GPL
+ makedepends = cmake
+ makedepends = git
+ depends = fcitx5-git
+ depends = anthy
+ depends = hicolor-icon-theme
+ provides = fcitx5-anthy
+ conflicts = fcitx-anthy
+ source = git+https://github.com/fcitx/fcitx5-anthy.git
+ sha512sums = SKIP
+
+pkgname = fcitx5-anthy-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..c42909a4115d
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,32 @@
+# Maintainer: OriginCode <origincoder@yahoo.com>
+
+pkgname=fcitx5-anthy-git
+pkgver=r139.b9ac495
+pkgrel=1
+pkgdesc="Anthy input method for fcitx5"
+arch=('x86_64')
+url="https://github.com/fcitx/fcitx5-anthy"
+license=('GPL')
+depends=('fcitx5-git' 'anthy' 'hicolor-icon-theme')
+makedepends=('cmake' 'git')
+conflicts=('fcitx-anthy')
+provides=('fcitx5-anthy')
+source=('git+https://github.com/fcitx/fcitx5-anthy.git')
+sha512sums=('SKIP')
+
+pkgver() {
+ cd fcitx5-anthy
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+build() {
+ cd fcitx5-anthy
+
+ cmake -DCMAKE_INSTALL_PREFIX=/usr -DCMAKE_BUILD_TYPE=Release -DCMAKE_INSTALL_LIBDIR=/usr/lib .
+ make
+}
+
+package() {
+ cd fcitx5-anthy
+ make DESTDIR="$pkgdir" install
+}