summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorwhriedplanck2020-06-20 00:25:43 +0800
committerwhriedplanck2020-06-20 00:25:43 +0800
commit4f3da5a4f6d63eb042b39d6fd5977fe8908d0a96 (patch)
treee2d52008b2a147b6b91daaa68be2a250cfba7ce1
downloadaur-4f3da5a4f6d63eb042b39d6fd5977fe8908d0a96.tar.gz
first commit
-rw-r--r--.SRCINFO12
-rw-r--r--PKGBUILD35
2 files changed, 47 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..1bd00089b159
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,12 @@
+pkgbase = fcitx5-dark-default
+ pkgdesc = Dark theme based on the default fcitx5 theme
+ pkgver = 0.0.0.20200619
+ pkgrel = 1
+ url = https://github.com/evansan/fcitx5-dark
+ arch = any
+ license = MIT
+ source = https://github.com/evansan/fcitx5-dark/archive/9ec539e6d2be5415abf6224de6d74775d59abfb6/fcitx5-dark-default-9ec539e6d2be5415abf6224de6d74775d59abfb6.tar.gz
+ md5sums = aeb8ae759febc693384a0a139aea4e25
+
+pkgname = fcitx5-dark-default
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..9fba6364a842
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,35 @@
+# Maintainer: whriedplanck <fungdaat31[at]outlook.com>
+# Contributor: evansan
+
+pkgname=fcitx5-dark-default
+pkgver=0.0.0.20200619
+_commit=9ec539e6d2be5415abf6224de6d74775d59abfb6
+pkgrel=1
+pkgdesc="Dark theme based on the default fcitx5 theme"
+arch=('any')
+url="https://github.com/evansan/fcitx5-dark"
+license=('MIT')
+source=("$url/archive/$_commit/$pkgname-$_commit.tar.gz")
+md5sums=('aeb8ae759febc693384a0a139aea4e25')
+
+package() {
+ _variant_name=fcitx5-dark
+ cd $_variant_name-$_commit
+ #Modify theme.conf
+ sed -i 's/Per defecte/Per defecte(Negre)/g' theme.conf
+ sed -i 's/\[de\]=Standard/\[de\]=Standard(Schwarz)/g' theme.conf
+ sed -i 's/\[da\]=Standard/\[da\]=Standard(Sort)/g' theme.conf
+ sed -i 's/既定/既定(黒)/g' theme.conf
+ sed -i 's/기본값/기본값(검정색)/g' theme.conf
+ sed -i 's/По умолчанию/По умолчанию(черный)/g' theme.conf
+ sed -i 's/默认/默认(黑)/g' theme.conf
+ sed -i 's/預設/預設(黑)/g' theme.conf
+ sed -i 's/Default/Default(Dark)/g' theme.conf
+ #Installation
+ install -Dm644 arrow.png "$pkgdir"/usr/share/fcitx5/themes/$_variant_name/arrow.png
+ install -Dm644 highlight.png "$pkgdir"/usr/share/fcitx5/themes/$_variant_name/highlight.png
+ install -Dm644 panel.png "$pkgdir"/usr/share/fcitx5/themes/$_variant_name/panel.png
+ install -Dm644 radio.png "$pkgdir"/usr/share/fcitx5/themes/$_variant_name/radio.png
+ install -Dm644 theme.conf "$pkgdir"/usr/share/fcitx5/themes/$_variant_name/theme.conf
+ install -Dm644 LICENSE "$pkgdir"/usr/share/licenses/$pkgname/LICENSE
+}