summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorFelix Yan2017-08-11 11:39:04 +0800
committerFelix Yan2017-08-11 11:39:04 +0800
commit9e0d5e7a3d77d6ed3025dc1afae664fca35cd7cb (patch)
tree35fbb2b7dfed34f218bef1a8f09bd1eac7a5c036
downloadaur-9e0d5e7a3d77d6ed3025dc1afae664fca35cd7cb.tar.gz
addpkg: fcitx5-git r180.0dcfd68-1
-rw-r--r--.SRCINFO28
-rw-r--r--PKGBUILD33
2 files changed, 61 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..4e3d21a755a8
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,28 @@
+# Generated by mksrcinfo v8
+# Fri Aug 11 03:38:54 UTC 2017
+pkgbase = fcitx5-git
+ pkgdesc = Next generation of fcitx
+ pkgver = r180.0dcfd68
+ pkgrel = 1
+ url = https://github.com/fcitx/fcitx5
+ arch = i686
+ arch = x86_64
+ license = GPL
+ makedepends = extra-cmake-modules
+ makedepends = git
+ depends = cairo
+ depends = enchant
+ depends = iso-codes
+ depends = libgl
+ depends = libxkbcommon-x11
+ depends = pango
+ depends = systemd
+ depends = wayland
+ depends = wayland-protocols
+ depends = xcb-imdkit-git
+ depends = xcb-util-wm
+ source = git+https://github.com/fcitx/fcitx5.git
+ sha512sums = SKIP
+
+pkgname = fcitx5-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..d2e78e1faf65
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,33 @@
+# $Id: PKGBUILD 226039 2017-04-27 13:52:30Z felixonmars $
+# Maintainer: Felix Yan <felixonmars@archlinux.org>
+# Contributor: csslayer <wengxt AT gmail com>
+
+pkgname=fcitx5-git
+pkgver=r180.0dcfd68
+pkgrel=1
+pkgdesc="Next generation of fcitx"
+arch=('i686' 'x86_64')
+url="https://github.com/fcitx/fcitx5"
+license=('GPL')
+depends=('cairo' 'enchant' 'iso-codes' 'libgl' 'libxkbcommon-x11' 'pango' 'systemd' 'wayland'
+ 'wayland-protocols' 'xcb-imdkit-git' 'xcb-util-wm')
+makedepends=('extra-cmake-modules' 'git')
+source=("git+https://github.com/fcitx/fcitx5.git")
+sha512sums=('SKIP')
+
+pkgver() {
+ cd fcitx5
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+build(){
+ cd fcitx5
+
+ cmake -DCMAKE_INSTALL_PREFIX=/usr -DCMAKE_BUILD_TYPE=Release -DCMAKE_INSTALL_LIBDIR=/usr/lib .
+ make
+}
+
+package() {
+ cd fcitx5
+ make DESTDIR="$pkgdir" install
+}