summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJiachen YANG2020-04-02 12:05:38 +0900
committerJiachen YANG2020-04-02 12:05:38 +0900
commit21867540da182b9894dfbdaa23a126d73e242c6c (patch)
tree70f7034f2e79b83558686bd57899d86e0da1ab2c
downloadaur-21867540da182b9894dfbdaa23a126d73e242c6c.tar.gz
fcitx5-lua-git initial PKGBUILD
-rw-r--r--.SRCINFO23
-rw-r--r--PKGBUILD36
2 files changed, 59 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..f722effc76bc
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,23 @@
+pkgbase = fcitx5-lua-git
+ pkgdesc = Lua support for fcitx5, with an imeapi addon implementing googlepinyin api
+ pkgver = r11.48697f5
+ pkgrel = 1
+ url = https://github.com/fcitx/fcitx5-lua
+ arch = i686
+ arch = x86_64
+ license = LGPL
+ makedepends = boost
+ makedepends = extra-cmake-modules
+ makedepends = git
+ depends = boost-libs
+ depends = curl
+ depends = fcitx5-git
+ depends = gettext
+ depends = lua
+ provides = fcitx5-lua
+ conflicts = fcitx5-lua
+ source = git+https://github.com/fcitx/fcitx5-lua.git
+ sha512sums = SKIP
+
+pkgname = fcitx5-lua-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..b56b1917de1d
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,36 @@
+# Maintainer: Jiachen YANG <farseerfc@archlinux.org>
+# Contributor: csslayer <wengxt AT gmail com>
+
+_pkgname=fcitx5-lua
+pkgname="$_pkgname-git"
+pkgver=r11.48697f5
+pkgrel=1
+pkgdesc="Lua support for fcitx5, with an imeapi addon implementing googlepinyin api"
+arch=('i686' 'x86_64')
+url="https://github.com/fcitx/$_pkgname"
+license=('LGPL')
+depends=('boost-libs' 'curl' 'fcitx5-git' 'gettext' 'lua')
+makedepends=('boost' 'extra-cmake-modules' 'git')
+conflicts=("$_pkgname")
+provides=("$_pkgname")
+source=("git+$url.git")
+sha512sums=('SKIP')
+
+pkgver() {
+ cd $_pkgname
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+build(){
+ cd $_pkgname
+
+ mkdir build && cd build
+ cmake -DCMAKE_INSTALL_PREFIX=/usr -DCMAKE_BUILD_TYPE=Release -DCMAKE_INSTALL_LIBDIR=/usr/lib ..
+ make
+}
+
+package() {
+ cd $_pkgname
+ cd build
+ make DESTDIR="$pkgdir" install
+}