summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorFelix Yan2020-05-30 11:20:16 +0800
committerFelix Yan2020-05-30 11:20:16 +0800
commit0b2429e260ec2f26ecec65bd1588563259d84f05 (patch)
tree45f6a24a112ffe4d11d4fbc09debafff2446d99e
parent6725668f41aafe370d7df89ed7cc2e437ba18979 (diff)
downloadaur-0b2429e260ec2f26ecec65bd1588563259d84f05.tar.gz
upgpkg: fcitx5-pinyin-zhwiki 20200520-1
-rw-r--r--.SRCINFO12
-rw-r--r--PKGBUILD21
2 files changed, 17 insertions, 16 deletions
diff --git a/.SRCINFO b/.SRCINFO
index e19f923b8e8a..bfe76ee55941 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = fcitx5-pinyin-zhwiki
pkgdesc = Fcitx 5 Pinyin Dictionary from zh.wikipedia.org
- pkgver = 20200501
- pkgrel = 2
+ pkgver = 20200520
+ pkgrel = 1
url = https://github.com/felixonmars/fcitx5-pinyin-zhwiki
arch = any
license = GFDL
@@ -9,10 +9,10 @@ pkgbase = fcitx5-pinyin-zhwiki
makedepends = libime
makedepends = opencc
makedepends = pypinyin
- source = https://github.com/felixonmars/fcitx5-pinyin-zhwiki/archive/0.2/fcitx5-pinyin-zhwiki-0.2.tar.gz
- source = https://dumps.wikimedia.org/zhwiki/20200501/zhwiki-20200501-all-titles-in-ns0.gz
- md5sums = 48335943da934c1f4be18537b48ea051
- md5sums = 4d2ee3cf2637abe67bf1332465f57f45
+ source = https://github.com/felixonmars/fcitx5-pinyin-zhwiki/archive/0.2.1/fcitx5-pinyin-zhwiki-0.2.1.tar.gz
+ source = https://dumps.wikimedia.org/zhwiki/20200520/zhwiki-20200520-all-titles-in-ns0.gz
+ md5sums = 2d01f45a73b7c686fef5c44472a9572b
+ md5sums = 7e783c4611c642c64c50a7507fdb8d09
pkgname = fcitx5-pinyin-zhwiki
diff --git a/PKGBUILD b/PKGBUILD
index 05bf4133773c..63a7db151cb8 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,29 +1,30 @@
# Maintainer: Felix Yan <felixonmars@archlinux.org>
pkgname=fcitx5-pinyin-zhwiki
-pkgver=20200501
-pkgrel=2
+pkgver=20200520
+_converterver=0.2.1
+pkgrel=1
pkgdesc="Fcitx 5 Pinyin Dictionary from zh.wikipedia.org"
arch=('any')
url="https://github.com/felixonmars/fcitx5-pinyin-zhwiki"
license=('GFDL' 'CCPL:by-sa')
makedepends=('libime' 'opencc' 'pypinyin')
-source=("https://github.com/felixonmars/fcitx5-pinyin-zhwiki/archive/0.2/$pkgname-0.2.tar.gz"
+source=("https://github.com/felixonmars/fcitx5-pinyin-zhwiki/archive/$_converterver/$pkgname-$_converterver.tar.gz"
https://dumps.wikimedia.org/zhwiki/$pkgver/zhwiki-$pkgver-all-titles-in-ns0.gz)
-md5sums=('48335943da934c1f4be18537b48ea051'
- '4d2ee3cf2637abe67bf1332465f57f45')
+md5sums=('2d01f45a73b7c686fef5c44472a9572b'
+ '7e783c4611c642c64c50a7507fdb8d09')
prepare() {
- cd $pkgname-0.2
+ cd $pkgname-$_converterver
cp ../zhwiki-$pkgver-all-titles-in-ns0.gz ./
}
build() {
- cd $pkgname-0.2
- make FILENAME=zhwiki-$pkgver-all-titles-in-ns0
+ cd $pkgname-$_converterver
+ make VERSION=$pkgver
}
package() {
- cd $pkgname-0.2
- make DESTDIR="$pkgdir" install
+ cd $pkgname-$_converterver
+ make VERSION=$pkgver DESTDIR="$pkgdir" install
}