summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorFelix Yan2020-05-23 15:58:02 +0800
committerFelix Yan2020-05-23 15:58:02 +0800
commitade200ecc2e1094779c34fcc9f19c60fb2f5a1b0 (patch)
tree2a84ae2daa7237ae35c9e157f995e55cfcb10e8d
downloadaur-ade200ecc2e1094779c34fcc9f19c60fb2f5a1b0.tar.gz
Initial release
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD29
2 files changed, 47 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..d5e30062ae95
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = fcitx5-pinyin-zhwiki
+ pkgdesc = Fcitx 5 Pinyin Dictionary from zh.wikipedia.org
+ pkgver = 20200501
+ pkgrel = 1
+ url = https://github.com/felixonmars/fcitx5-pinyin-zhwiki
+ arch = any
+ license = GFDL
+ license = CCPL:by-sa
+ makedepends = libime
+ makedepends = opencc
+ makedepends = pypinyin
+ source = https://github.com/felixonmars/fcitx5-pinyin-zhwiki/archive/0.1/fcitx5-pinyin-zhwiki-0.1.tar.gz
+ source = https://dumps.wikimedia.org/zhwiki/20200501/zhwiki-20200501-all-titles-in-ns0.gz
+ md5sums = 1863f0d556a777c05bb573eebe809494
+ md5sums = 4d2ee3cf2637abe67bf1332465f57f45
+
+pkgname = fcitx5-pinyin-zhwiki
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..73db887b7cda
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,29 @@
+# Maintainer: Felix Yan <felixonmars@archlinux.org>
+
+pkgname=fcitx5-pinyin-zhwiki
+pkgver=20200501
+pkgrel=1
+pkgdesc="Fcitx 5 Pinyin Dictionary from zh.wikipedia.org"
+arch=('any')
+url="https://github.com/felixonmars/fcitx5-pinyin-zhwiki"
+license=('GFDL' 'CCPL:by-sa')
+makedepends=('libime' 'opencc' 'pypinyin')
+source=("https://github.com/felixonmars/fcitx5-pinyin-zhwiki/archive/0.1/$pkgname-0.1.tar.gz"
+ https://dumps.wikimedia.org/zhwiki/$pkgver/zhwiki-$pkgver-all-titles-in-ns0.gz)
+md5sums=('1863f0d556a777c05bb573eebe809494'
+ '4d2ee3cf2637abe67bf1332465f57f45')
+
+prepare() {
+ cd $pkgname-0.1
+ cp ../zhwiki-$pkgver-all-titles-in-ns0.gz ./
+}
+
+build() {
+ cd $pkgname-0.1
+ make FILENAME=zhwiki-$pkgver-all-titles-in-ns0
+}
+
+package() {
+ cd $pkgname-0.1
+ make DESTDIR="$pkgdir" install
+}