summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorHoward Cheung2020-06-27 15:41:41 +0800
committerHoward Cheung2020-06-27 15:41:41 +0800
commit056e07053a9702c2a988414aa1d9086c1789555c (patch)
treeae3418edb40e4fa276dc5bfc2a910ddb1ea5dc97
parent1d53728b075c55e778525ec9d4ff2d02c428df7d (diff)
downloadaur-056e07053a9702c2a988414aa1d9086c1789555c.tar.gz
update to 20200620
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD12
2 files changed, 9 insertions, 9 deletions
diff --git a/.SRCINFO b/.SRCINFO
index d738c04d9614..6c8a747e76e9 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = fcitx5-pinyin-zhwiki-rime
pkgdesc = Fcitx 5 Pinyin Dictionary from zh.wikipedia.org for rime
- pkgver = 20200601
+ pkgver = 20200620
pkgrel = 1
url = https://github.com/felixonmars/fcitx5-pinyin-zhwiki
arch = any
@@ -10,9 +10,9 @@ pkgbase = fcitx5-pinyin-zhwiki-rime
makedepends = opencc
makedepends = pypinyin
source = https://github.com/felixonmars/fcitx5-pinyin-zhwiki/archive/0.2.1/fcitx5-pinyin-zhwiki-rime-0.2.1.tar.gz
- source = https://dumps.wikimedia.org/zhwiki/20200601/zhwiki-20200601-all-titles-in-ns0.gz
+ source = https://dumps.wikimedia.org/zhwiki/20200620/zhwiki-20200620-all-titles-in-ns0.gz
md5sums = 2d01f45a73b7c686fef5c44472a9572b
- md5sums = 223f9ddca5e26714ae2777399637aeac
+ md5sums = 850f75a5a3a80a4dd58c83c715d80500
pkgname = fcitx5-pinyin-zhwiki-rime
diff --git a/PKGBUILD b/PKGBUILD
index ba7e28572693..f984ef41638d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,8 @@
# Maintainer: Felix Yan <felixonmars@archlinux.org>
pkgname=fcitx5-pinyin-zhwiki-rime
-pkgver=20200601
+_reponame=fcitx5-pinyin-zhwiki-rime
+pkgver=20200620
_converterver=0.2.1
pkgrel=1
pkgdesc="Fcitx 5 Pinyin Dictionary from zh.wikipedia.org for rime"
@@ -12,20 +13,19 @@ makedepends=('libime' 'opencc' 'pypinyin')
source=("https://github.com/felixonmars/fcitx5-pinyin-zhwiki/archive/$_converterver/$pkgname-$_converterver.tar.gz"
https://dumps.wikimedia.org/zhwiki/$pkgver/zhwiki-$pkgver-all-titles-in-ns0.gz)
md5sums=('2d01f45a73b7c686fef5c44472a9572b'
- '223f9ddca5e26714ae2777399637aeac')
+ '850f75a5a3a80a4dd58c83c715d80500')
prepare() {
- mv fcitx5-pinyin-zhwiki-$_converterver $pkgname-$_converterver
- cd $pkgname-$_converterver
+ cd ${_reponame}-$_converterver
cp ../zhwiki-$pkgver-all-titles-in-ns0.gz ./
}
build() {
- cd $pkgname-$_converterver
+ cd ${_reponame}-$_converterver
make VERSION=$pkgver zhwiki.dict.yaml
}
package() {
- cd $pkgname-$_converterver
+ cd ${_reponame}-$_converterver
make VERSION=$pkgver DESTDIR="$pkgdir" install_rime_dict
}