summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorHoward Cheung2020-06-19 15:35:47 +0800
committerHoward Cheung2020-06-19 15:35:47 +0800
commit36df9b90d744e0563111c6a80f0bdd687624dee0 (patch)
tree549cd7f16b0a41dea27f584c64a2f4f7d325c363
downloadaur-36df9b90d744e0563111c6a80f0bdd687624dee0.tar.gz
Initial commit
-rw-r--r--.SRCINFO20
-rw-r--r--PKGBUILD36
2 files changed, 56 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..1dbc5d7fcdc6
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,20 @@
+pkgbase = fcitx5-pinyin-zhwiki-rime
+ pkgdesc = Fcitx 5 Pinyin Dictionary from zh.wikipedia.org for rime
+ pkgver = 20200601
+ pkgrel = 1
+ url = https://github.com/felixonmars/fcitx5-pinyin-zhwiki
+ arch = any
+ license = GFDL
+ license = CCPL:by-sa
+ makedepends = opencc
+ makedepends = pypinyin
+ optdepends = libime: must choose one to build
+ optdepends = libime-git: must choose one to build
+ conflicts = rime-pinyin-zhwiki
+ source = https://github.com/felixonmars/fcitx5-pinyin-zhwiki/archive/0.2.1/fcitx5-pinyin-zhwiki-rime-0.2.1.tar.gz
+ source = https://dumps.wikimedia.org/zhwiki/20200601/zhwiki-20200601-all-titles-in-ns0.gz
+ md5sums = 2d01f45a73b7c686fef5c44472a9572b
+ md5sums = 223f9ddca5e26714ae2777399637aeac
+
+pkgname = fcitx5-pinyin-zhwiki-rime
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..57bb8e19afb4
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,36 @@
+# Maintainer: Felix Yan <felixonmars@archlinux.org>
+
+pkgname=fcitx5-pinyin-zhwiki-rime
+pkgver=20200601
+_converterver=0.2.1
+pkgrel=1
+pkgdesc="Fcitx 5 Pinyin Dictionary from zh.wikipedia.org for rime"
+arch=('any')
+url="https://github.com/felixonmars/fcitx5-pinyin-zhwiki"
+license=('GFDL' 'CCPL:by-sa')
+makedepends=('opencc' 'pypinyin')
+optdepends=(
+ 'libime: must choose one to build'
+ 'libime-git: must choose one to build'
+)
+conflicts=('rime-pinyin-zhwiki')
+source=("https://github.com/felixonmars/fcitx5-pinyin-zhwiki/archive/$_converterver/$pkgname-$_converterver.tar.gz"
+ https://dumps.wikimedia.org/zhwiki/$pkgver/zhwiki-$pkgver-all-titles-in-ns0.gz)
+md5sums=('2d01f45a73b7c686fef5c44472a9572b'
+ '223f9ddca5e26714ae2777399637aeac')
+
+prepare() {
+ mv fcitx5-pinyin-zhwiki-$_converterver $pkgname-$_converterver
+ cd $pkgname-$_converterver
+ cp ../zhwiki-$pkgver-all-titles-in-ns0.gz ./
+}
+
+build() {
+ cd $pkgname-$_converterver
+ make VERSION=$pkgver zhwiki.dict.yaml
+}
+
+package() {
+ cd $pkgname-$_converterver
+ make VERSION=$pkgver DESTDIR="$pkgdir" install_rime_dict
+}