summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorKienyew2020-10-02 19:45:09 +0800
committerKienyew2020-10-02 19:45:09 +0800
commit8c127d28be7805a9c5cd800ebafce5151b476a3d (patch)
tree8345dd6a4fed959c7aaca6bb20a2c3af3727f457
downloadaur-8c127d28be7805a9c5cd800ebafce5151b476a3d.tar.gz
Initial commit
-rw-r--r--.SRCINFO12
-rw-r--r--PKGBUILD22
2 files changed, 34 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..98051d2d2ad4
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,12 @@
+pkgbase = fcitx5-skin-arc
+ pkgdesc = A fcitx5 theme imitates the famous Arc theme
+ pkgver = 0.0.0.20201002
+ pkgrel = 1
+ url = https://github.com/Kienyew/fcitx5-arc-theme
+ arch = any
+ license = MIT
+ source = https://github.com/Kienyew/fcitx5-arc-theme/archive/e759f97590e02f307e402bdba68849f943558218/fcitx5-arc-theme-e759f97590e02f307e402bdba68849f943558218.tar.gz
+ md5sums = f9e3f4ac9ea621dafbbae3ff16a9aada
+
+pkgname = fcitx5-skin-arc
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..9d282f64d256
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,22 @@
+# Maintainer: Coelacanthus <liuhongwu2003@outlook.com>
+
+pkgname=fcitx5-skin-arc
+_pkgname=fcitx5-arc-theme
+pkgver=0.0.0.20201002
+_commit=e759f97590e02f307e402bdba68849f943558218
+pkgrel=1
+pkgdesc="A fcitx5 theme imitates the famous Arc theme"
+arch=('any')
+url="https://github.com/Kienyew/fcitx5-arc-theme"
+license=('MIT')
+source=("https://github.com/Kienyew/fcitx5-arc-theme/archive/$_commit/$_pkgname-$_commit.tar.gz")
+md5sums=('f9e3f4ac9ea621dafbbae3ff16a9aada')
+
+package() {
+ cd $_pkgname-$_commit
+ find 'Arc' -type f -exec install -Dm644 '{}' "$pkgdir/usr/share/fcitx5/themes/{}" \;
+ find 'Arc-Dark' -type f -exec install -Dm644 '{}' "$pkgdir/usr/share/fcitx5/themes/{}" \;
+
+ # install -Dm644 LICENSE "$pkgdir"/usr/share/licenses/$pkgname/LICENSE
+}
+