summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorCoelacanthus2020-06-18 22:55:55 +0800
committerCoelacanthus2020-06-18 22:55:55 +0800
commit63bb32f72987c7be76acd9fb9215a3dbf56201aa (patch)
treea252cbb3dbd0539e3141feecdefc4602504eeb7c
downloadaur-63bb32f72987c7be76acd9fb9215a3dbf56201aa.tar.gz
init
-rw-r--r--.SRCINFO12
-rw-r--r--PKGBUILD24
2 files changed, 36 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..146bf147b39d
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,12 @@
+pkgbase = fcitx5-dark-numix
+ pkgdesc = Modified Material-Color to fit in the numix dark theme.
+ pkgver = 0.0.0.20200618
+ pkgrel = 1
+ url = https://github.com/cjxgm/fcitx5-dark-numix
+ arch = any
+ license = Apache
+ source = https://github.com/cjxgm/fcitx5-dark-numix/archive/bf0049dd46f6336e3f7db60a17e61a4c34dd082c/fcitx5-dark-numix-bf0049dd46f6336e3f7db60a17e61a4c34dd082c.tar.gz
+ sha512sums = d8cad03869bbd909ee6f7883e8d5d52ff659852c04a3c955c51ba99b0113eba354185b08b0b3445c3e2354489f11834c6c8fd06541c01fff88418abdaa054c45
+
+pkgname = fcitx5-dark-numix
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..c56129db9466
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,24 @@
+# Maintainer: Coelacanthus <liuhongwu2003@outlook.com>
+
+pkgname=fcitx5-dark-numix
+pkgver=0.0.0.20200618
+_commit=bf0049dd46f6336e3f7db60a17e61a4c34dd082c
+pkgrel=1
+pkgdesc="Modified Material-Color to fit in the numix dark theme. "
+arch=('any')
+url="https://github.com/cjxgm/fcitx5-dark-numix"
+license=('Apache')
+source=("https://github.com/cjxgm/fcitx5-dark-numix/archive/$_commit/$pkgname-$_commit.tar.gz")
+sha512sums=('d8cad03869bbd909ee6f7883e8d5d52ff659852c04a3c955c51ba99b0113eba354185b08b0b3445c3e2354489f11834c6c8fd06541c01fff88418abdaa054c45')
+
+package() {
+ _variant_name=dark-numix
+ cd $pkgname-$_commit
+ install -Dm644 highlight.png "$pkgdir"/usr/share/fcitx5/themes/$_variant_name/highlight.png
+ install -Dm644 panel.png "$pkgdir"/usr/share/fcitx5/themes/$_variant_name/panel.png
+ install -Dm644 arrow.png "$pkgdir"/usr/share/fcitx5/themes/$_variant_name/arrow.png
+ install -Dm644 radio.png "$pkgdir"/usr/share/fcitx5/themes/$_variant_name/radio.png
+ install -Dm644 theme.conf "$pkgdir"/usr/share/fcitx5/themes/$_variant_name/theme.conf
+
+ #install -Dm644 LICENSE "$pkgdir"/usr/share/licenses/$pkgname/LICENSE
+}